locked
Location Constantly Switching RRS feed

  • Question

  • My laptop is both wired to my network and connected wirelessly using WPA-Personal TKIP encyption.  It seems every few seconds the firewall setting changes location from "Home or Work" and "Public Place'.  What can I do to stop this?
    Friday, July 13, 2007 3:02 AM

Answers

  • Open One Care firewall settings and uncheck "Automatically suspend all home or work locations when you are connected to any network in a public place".
    Friday, July 13, 2007 1:20 PM
    Moderator

All replies

  • Open One Care firewall settings and uncheck "Automatically suspend all home or work locations when you are connected to any network in a public place".
    Friday, July 13, 2007 1:20 PM
    Moderator
  • Thanks, but whats casuing it to do this?
    Friday, July 13, 2007 3:24 PM
  • I don't really know what is causing this. If you only use either your wired or wireless connection, do you still get those warnings?
    Friday, July 13, 2007 3:40 PM
    Moderator
  • Last night after disabling the wireless card it stop.  Tonight I will do the opposite and see what happens.
    Friday, July 13, 2007 4:44 PM
  • I am the Microsoft PM for this feature.

    This can be caused by flakiness of your wireless connection. Connection is connecting/disconnecting of the network.

    Is this on XP or Vista?

     

    Thanks

    Neeraj

    Friday, July 13, 2007 5:04 PM
  • Vista Ultimate with a PRO/Wireless 3945ABG connect to a NetGear WTG624
    Friday, July 13, 2007 6:08 PM
  • I have the same issue as this fellow. I use the same encryption as he does, and have the same wireless gateway, though connected to a Linksys wireless router. Windows Vista Business. I had a similar problem with 1.6, but I disabled the notifications somehow.
    Friday, July 13, 2007 7:32 PM
  • This issue has been driving me bonkers.. I think it's partly base Vista not just the firewall, but guess it's related.

    I have a variety of network interfaces
     - 2 x vmware
     - bluetooth PAN
     - ethernet
     - Wireless
     - VPN NIC

    It's mostly the wireless active, and I can associate a network location with this.

    However I still get frequent bouts of "identifying ....". It may in part be caused by the 2 vmware nics. They always fall into "unidentified network" and although then can be moved public->private, this doesn't persist - presumably because whatever Vista is using as a unique id, isnt there?

    The other networks are disconnected most of the time

    it's very frustrating...


    How does Vista "identify" a network - what components of the NIC does it use?
    What triggers an "Identifying .... " cycle?
    How can I associate a network with the vmware & VPN NICs?
    Can I somehow manually configure definitions perhaps by subnet?
    If I deselect the option you describe will this "get rid" of this feature for now?
    If not using livecare is it sufficient to just "turn on" the individual features file sharing/network discovery etc whilst in the public "zone"?

    Thanks - I've just done a google search and there are 100s of posts about perceived problems with Vista in this area... I think fundamentally it's lack of clarity over how a network is "identified", and how the relevant public/private zone can then be associated with it. It seems to work for wireless networks, but almost definately not for virtual networks.

    Thanks
    Tuesday, July 17, 2007 4:39 PM
  • Just out of interest I can see that my wireless NIC on 2 machines (Business x86, Ultimate x64) is flicking into "identifying..." every few minutes causing the file sharing etc to suspend since a public network zone is around.....

    So it's not <just> the unidentified network, but the re-identification also.

    It is running WPA-PSK and the connection is reliable
    Tuesday, July 17, 2007 4:47 PM
  • I have three computers running 2.0 and they all experience the location change issue.

     

    1. Vista Ultimate x64

    2. Vista Home Basic x86

    3. XP SP2 x86

     

    They are all using a wireless connection but are not switching from router to router. I am only using WEP encryption on these computers. I even experience this issue on my Ultimate x64 while using my WWLAN Sprint Power Vision connection. I have noticed the frequency of this message decreasing, but it still occurs for no reason.

     

    Thank you.

     

    Sunday, July 22, 2007 1:31 PM
  • Got the same problem since installing vmware 6. The only solution so far was to set the same ip-address as default gateway. But so far i don't know if it will cause any other problems.
    Sunday, July 22, 2007 7:00 PM
  • This continues to occur and is downright absurd!

    I guess the only solution is to reconfigure the firewall rules so that it is irrelevant, although the popups continue.

    Vista *needs* to be able to stop re-identifying the network!
    Monday, July 23, 2007 9:38 PM
  • MAC Address of default gateway is used as one of the key ingredient of "finger print" of a network.

    If you do not configure default gateway, both Vista and OneCare may stay in "identifying" state.

     

    Thursday, July 26, 2007 6:17 AM
  • I too have this issue. While as advised this is probably due to a wireless signal dropping for a few seconds it is very annoying. The suggestions on this page are either:

    a. Switch off feature - ok if you know you have a secure network but not good for a standard user

    b. Modify MAC address - again good for beta testers but not for standard users

     

    Suggest setting a longer delay in the application (perhaps 120 seconds?) before switching to public location as most wireless connectivity issues are only for a short time period.

     

     

    Saturday, August 11, 2007 5:55 AM
  • asmith02,

     

    Though I agree that would supress the messages, it really doesn't solve the problem, since it's not OneCare making the transition between networks, it's Vista. OneCare doesn't modify the operation of Vista in this case, it simply tracks what Vista is actually doing.

     

    In other words, OneCare is making you aware that Vista is togging between networks, which could be a bad thing if your firewall configuration continued to assume that it was safely attached to a Private network. The real solution must be found within Vista itself and your Wireless network configuration and drivers.

     

    It's possible that some improvements will be forthcoming in Vista to solve this if the issue is really related to a problem in that code. However, most of these situations I've seen myself seem to relate to older wireless hardware and/or drivers, which leads me to believe they need to be resolved by looking for updates for these or one of the workarounds mentioned above.

     

    BTW, the second workaround mentioned was to set the default gateway IP address, not the MAC address.

     

    OneCareBear

    Saturday, August 11, 2007 2:01 PM
    Moderator
  • I am running into the same problem with a Toshiba laptop that came with Vista Business installed.  Therefore, I hope it is not a older driver issue.

     

    Where would I reset the default gateway IP address?  Do I need to do it for all computers on the network, or only the one connected wirelessly?

     

    Is this related to Vista having to check the network computers each time I go to Network Places vs XP doing it in the background and immediately displaying the computers on my network?

    Tuesday, August 14, 2007 1:04 AM
  • You mentioned that "MAC address of default gateway" is used as a key indicator of the attached network...

    I use various VPN software, and specifically (where I'm monitored the behaviour) vmware -- in both cases a default gateway isn't necessarily assigned. Additionally addresses/networks can be dynamic.

    What happens with vmware is that the network is seen as "unidentified" - presumably as there's no default gw. It therefore is a public network. I can make it private, but this isn't persisted - presumably as there no unique identifier. That means the next time I start up the network is public again. I gather some have tried to assign default gw, but can't vista do better here in using the mac of the local interface, together with the absence of a default gw to identify the network?

    (I know this is slightly off the topic of constantly switching... my switching nightmare was just this - manually making a change and seeing it lost due to lack of identification, not dropped wireless. That's another matter. Infrequently my blasted atheros AR5007UG dies/freezes/hangs. Another day.....)
    Wednesday, August 15, 2007 6:45 PM
  • Interestingly I tried defining a default gw on both of my vmware network interfaces, using the local address. This didn't appear to help vista in identifying the network which is still showing as "Unidentified network". How would I resolve this?
    Wednesday, August 15, 2007 6:50 PM
  • I ran into this problem today and believe I have figured out what is going on -- and it may be some confusion re: what I think the Microsoftie meant re: the MAC address and default gateway.  In my case, I have a router in the basement and a repeater on the 3rd floor of my home.  When I'm on the 3rd floor, my laptop doesn't see the main router broadcasts and therefore I had never experienced the problem.  Then I went to the 2nd floor and encountered this constant switching.  I found a way to force my adapter to connect to a specific broadcast MAC address...in other words, since both the router and extender were broadcasting for the same network but with different MAC addresses which apparently was confusing for Onecare.

    Once I set my connection to always use the extender MAC address the problem stopped.  This solution obviously isn't ideal as if I take my laptop to the basement I don't believe it will let me connect to the network (unless the 'forced MAC' option works differently than expected)...but since I don't do that it seems to work pretty well for me.

    If this is indeed the problem, there should be a way for Microsoft to provide a means to prioritize a list of MAC addresses or at least provide a 'preferred' option or simply improve the 'roaming' capabilities of the network software so it doesn't attempt to jump between different broadcasting devices until there is a large discrepency between the two.  And that needs to happen in both directions.  In fact, maybe there should be an option to not automatically traverse these things and simply prompt the user and permit the user to set a threshhold when that prompt will happen.

    I don't know.  I do know that I expect more.  I'm am basically a computer god and it was hard enough for me to figure out what was going on and how to fix it -- especially with all the "ease of use" built into Vista.  How the heck is a normal person going to have any clue about how to address an issue like this?!?
    Sunday, September 30, 2007 10:07 PM
  • dotbombjoe,

     

    That's an interesting twist, since having such roaming ability isn't as common in home networking as it is in some business environments. I can see exactly why your problem would occur, since Vista would normally keep trying to find a better network to attach to. Again, this is really a Vista issue, with OneCare simply making you aware that the underlying networking is making these transitions.

     

    My issues with this have totally disappeared with the OneCare 2.0 beta, though I have also changed both laptop brand and physical location before switching to 2.0. However, I can still detect a few other networks close by, including at least one which isn't secured and in fact originally displayed the same SSID as my own router's default, though I quickly changed both that and my router's security settings.

     

    Most of the Vista Wireless settings assume there will be different networks involved, not multiple instances of the same network, so I'm not surprised at the confusion. Does your main router have the ability to adjust its wireless signal output? If so, you might try reducing it's output by a few decibels (some percentage of maximum), assuming that this will still provide the necessary coverage in the basement. Most Access Points are overpowered, which is why this problem often occurs in apartments, since few users are even aware how far their wireless signal reaches, let alone how to reduce the signal strength.

     

    There is some level of control over priority in vista, though I believe this relates to the network SSID, so it may not help in your situation.

     

    OneCareBear

    Monday, October 1, 2007 4:34 AM
    Moderator