locked
Issue with Reporting - CRM 2011/SQL2012 RRS feed

  • Question

  • Keep getting this error, tried with and without execution accounts. The account is in the PrivReporting already.

    Any ideas?

    Reporting services is on a separate server to CRM, running SQL 2012. Have also update the SPN for this box to use the account that the CRM app pool is using. No Job

    Any advice appreciated.

    Thanks

    webserver!ReportServer_0-2!a90!11/19/2013-17:25:00:: e ERROR: Reporting Services error Microsoft.ReportingServices.Diagnostics.Utilities.RSException: An error has occurred during report processing. ---> Microsoft.ReportingServices.ReportProcessing.ProcessingAbortedException: An error has occurred during report processing. ---> Microsoft.ReportingServices.ReportProcessing.ReportProcessingException: Query execution failed for dataset 'DSMain'. ---> Microsoft.Crm.Reporting.DataExtensionShim.Common.ReportExecutionException:
    Microsoft.Crm.CrmException: An unexpected error occurred.
    System.ServiceModel.Security.SecurityNegotiationException: A call to SSPI failed, see inner exception.
    System.Security.Authentication.AuthenticationException: A call to SSPI failed, see inner exception.
    System.ComponentModel.Win32Exception: The target principal name is incorrect ---> Microsoft.Crm.Reporting.DataExtensionShim.Common.ReportExecutionException: An unexpected error occurred. ---> Microsoft.Crm.Reporting.DataExtensionShim.Common.ReportExecutionException: A call to SSPI failed, see inner exception. ---> Microsoft.Crm.Reporting.DataExtensionShim.Common.ReportExecutionException: A call to SSPI failed, see inner exception. ---> Microsoft.Crm.Reporting.DataExtensionShim.Common.ReportExecutionException: The target principal name is incorrect


    Pete

    Tuesday, November 19, 2013 5:28 PM

All replies

  • This looks like an SPN issue, though you could get a similar error of no domain controller were available. Do you get the error for all reports (built-in and custom ones) ?

    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk

    Thursday, November 21, 2013 4:44 PM
    Moderator
  • Thanks David, it was indeed a SPN issue which I managed to fix :)

    Pete

    Thursday, November 21, 2013 4:46 PM