none
SyncToy, SkyDrive and Windows 8.1 problem

    Question

  • Immediately after installing Windows 8.1 and running SyncToy 2.1, thousands of files that were supposed to sync between SkyDrive and my USB drive disappeared from the USB drive. All the subfolders on SkyDrive were marked as availability "Online only". As a result I cannot use the USB drive as an offiline tool for any of those files. How can I restore SkyDrive to a "normal" file structure again, as it was under Windows 8 and Windows 7?


    • Edited by dnordberg Saturday, November 16, 2013 2:25 PM
    Saturday, November 16, 2013 2:25 PM

All replies

  • Hi,

    I'm having exactly the same problem.

    Wednesday, December 18, 2013 12:09 AM
  • Hello dnordberg,

    I found a way to overcome this issue. Even if all the skydrive files are "available offline" the status of the folders are "online-only". You need to make the folders "available offline" so that the SyncToy can recognize them. The way I found to do that was setting the folders as "available offline" through the Skydrive "Metro" app.

    Unfortunately I'm not able to post an image here to help, but it is easy...

    Hope a could help you.

    Wednesday, December 18, 2013 12:41 AM
  • Thanks, Douglas. It's surprisingly easy, even from the desktop / windows explorer, once some kind person has pointed the way. Thankfully changing the setting of the upper level folder automatically changes the status of subfolders. Why did Microsoft make online-only the default setting in Windows 8.1, I wonder?
    Wednesday, December 18, 2013 9:30 AM
  • I am unable to use synctoy 2.1 after upgrading to Win 8.1. gives error "Failed to create folder pair. Failed to create provider" when I map it to my external USB HDD or another location on local hdd. Any idea!!
    Saturday, December 21, 2013 7:30 AM
  • Kalra,

    I suspect you are having the same issue that Douglas Bizzaro has solved. Look at his response above and give it a try. From the desktop view, open Windows Explorer to "This PC", find SkyDrive, then right-click on it. One of the items will be something like "Make available offline". If you select that, it should solve the problem.

    Saturday, December 21, 2013 8:37 AM