none
RDP with computer name access RRS feed

  • Question

  • I named my WHS box "MyHomeServer" but I cannot RDP into the server using the name. I have to use the IP address. Anyone know of a way to RDP with the computer name?
    Sunday, August 30, 2009 5:28 AM

Answers

  • It's usually name resolution issues, caused by things like the wrong DNS server (address of the ISPs DNS instead of the router) and/or a DNS suffix configured via DHCP from your router, which causes all name resolution attempts to get this suffix attached and being resolved somewhere in the Internet that way. The command kariya mentioned will reveal this.

    Workarounds:
    Remove that suffix from the routers configuration
    add the IP address and name of the server to the hosts file on each client in Windows\system32\drivers\etc (which will cause issues, if the server gets a different IP address in the future)

    Best greetings from Germany
    Olaf

    • Marked as answer by Orlandotek Sunday, August 30, 2009 11:57 PM
    Sunday, August 30, 2009 11:30 AM
    Moderator

All replies

  • I named my WHS box "MyHomeServer" but I cannot RDP into the server using the name. I have to use the IP address. Anyone know of a way to RDP with the computer name?

    First, logging into the server desktop for any reason is unsupported and, unless you really know what you're doing (meaning you are familiar with the inner workings of WHS, which does not work like other OSes), not recommended.

    Having said that, what happens if you ping your server, both by name and by IP address?  Can you open a command prompt on both client and server, type ipconfig /all on each computer, then post the results here?
    • Marked as answer by Orlandotek Sunday, August 30, 2009 11:56 PM
    • Unmarked as answer by Orlandotek Sunday, August 30, 2009 11:57 PM
    Sunday, August 30, 2009 5:41 AM
    Moderator
  • It's usually name resolution issues, caused by things like the wrong DNS server (address of the ISPs DNS instead of the router) and/or a DNS suffix configured via DHCP from your router, which causes all name resolution attempts to get this suffix attached and being resolved somewhere in the Internet that way. The command kariya mentioned will reveal this.

    Workarounds:
    Remove that suffix from the routers configuration
    add the IP address and name of the server to the hosts file on each client in Windows\system32\drivers\etc (which will cause issues, if the server gets a different IP address in the future)

    Best greetings from Germany
    Olaf

    • Marked as answer by Orlandotek Sunday, August 30, 2009 11:57 PM
    Sunday, August 30, 2009 11:30 AM
    Moderator
  • Thanx for the reply.

    Yeah, I kinda knew it had something to do with DNS but I wasn't sure what.

    Since I am setting up shares and stuff on the WHS I need to log into it from time to time.

    I went ahead and did the following to correct the issue.

    1) Went into my router and set a smaller scope of IP addresses for DHCP.
    2) Went into the WHS ethernet adapter properties and manually set the IP address outside of the DHCP scope and set the subnet mask and the default
    gateway of the router.
    3) Manually set the DNS for the ISP so the WHS can still get updates from the web.
    4) Went into the hosts file on the connected PC's and set the IP address to the server name.

    All went well and works like a charm.

    Thanx again!
    Sunday, August 30, 2009 11:56 PM
  • Setting the IP address to the ISPs address is not such a good idea, using the address of the router instead would be better. The router acts as forwarder for queries, which it cannot resolve itself.
    Best greetings from Germany
    Olaf
    Monday, August 31, 2009 2:56 PM
    Moderator