locked
Configuring WHS on D-Link DI-624 RRS feed

  • Question

  • I have a question....

     

    I've set up WHS on my machine, but am having problems with the connection to the router for incoming requests.  I have a D-Link DI-624 router.

     

    I set up Virtual Servers for the protocols (80,443,4125) and have them using the server's IP address (under Private IP on the router), but when I run the Domain Name and Router details under the Remote Access option in the Settings, the settings for 'Verifying your router is accepting Web site connections', 'Verifying your router is accepting Remote Access connections', and 'Verifying your network configuration' all come back with the red X.  I also get the red X when I run the Domain Name Details with the options 'Verifying your Web site is accessible from the Internet' and 'Verifying Remote Access is accessible from the Internet'.

     

    It did come back fine that the router supports UPnP and made the changes to the router's firewall.

     

    I know I'm missing something, but can't put my finger on it.

     

    Any help would be appreciated.

     

    Thanks

     

    Jeff

    Thursday, May 17, 2007 10:34 PM

All replies

  • Jeff,
    not a great answer, but I have a DI-624 rev c with firmeware 2.76. and everytime as soon as it would do the UPnP, the stupid thing would reset right as it got to verifiying incoming connections.  I gave on the up on the router after an hour and a half and set the rules manually.  I set the RDP rule in the firewall, set the rules for http and https on the virtual server tab, and now it works fine.  Oh yeah, I set a static IP for the server too.  Not  sure why this is, other stuff sends upnp config data to the router and it works fine (games, utorrent, etc.).  No more red Xs after that. 

     

    Saturday, May 19, 2007 10:54 PM
  • IIRC don't use the virtual servers setting, and instead look for port forwarding. It won't pass on data like it should through the firewall.
    Thursday, May 24, 2007 9:58 PM
  • Don't use the virtual servers setting, it doesn't forward ports correctly. Use the Firewall tab (I think, been a while since I've used one) and set the ports manually through there. I highly recommend swapping out your router for a better one. Linksys/Netgear make far better home routers.
    Thursday, May 24, 2007 9:59 PM
  • There is an easier way to achieve the desired result with the DI624. All you need to do is enable the DMZ option for the IP address of the MHS.

    First check the server address by looking at the "DHCP" page on the router.

    Next choose "WAN", then "Advanced", then select the "DMZ" button on the left of screen.

    Choose the "Enabled" radio button then enter the IP address of the server and "Apply".

    You should now be up and working.

    • Proposed as answer by armacdee Tuesday, April 13, 2010 11:43 AM
    • Unproposed as answer by kariya21Moderator Sunday, April 18, 2010 11:53 PM
    Tuesday, April 13, 2010 11:42 AM
  • Putting something like a Windows Home Server into the DMZ is a bad idea.  This basically forwards all unhanlded traffic to your Windows Home Server.

    You should consult a site like portforward.com to see how you setup your router to forward particular ports.


    --
    Tuesday, April 13, 2010 1:41 PM