locked
SATA Showing as ATA RRS feed

  • Question

  • When I look in the WHS Console it shows all of my hard drives, however, it shows them as being ATA and not SATA.

    Saturday, August 11, 2007 4:33 PM

All replies

  • Hi,

    You need to enable the sata in BIOS as "AHCI" mode. Not as IDE or enhanced ide.

    If that the case, you better update the sata controller drivers within WHS (as RD to the WHS) before changing the BIOS settings.

    My best
    Saturday, August 11, 2007 5:49 PM
  • When you installed WHS, your SATA controller was probably configured as Legacy IDE (or equivalent) in the BIOS. This offers maximum compatibility with operating systems, but at the cost of some small amount of performance.

    You can try to install the AHCI drivers for your SATA controller and switch over to AHCI mode as another poster has suggested, but I don't know how WHS will react to this (pretty fundamental) change in the apparant storage hardware. So if you decide to do this, you should be prepared for a reinstallation of WHS afterward. Note that for a reinstallation, you should be able to select the "renistallation" option at the beginning of setup, which will preserve backups and data, but will lose any OS customizations and users. Choosing a new installation will lose backups and data as well.
    Saturday, August 11, 2007 6:20 PM
    Moderator
  • I would be careful with changing from Legacy IDE to AHCI. WHS will not do a new install if the bios setting is AHCI.

     

    Bryan

     

    Monday, August 13, 2007 5:35 PM