locked
Email router socket error when Testing profile RRS feed

  • Question

  • Dear all, I have settup Email router on my CRM server which is using Exchange online but CRM server on premise. I have define a profile with the exchange online web service. I have apply CRM 2011 Rollup 3 on all components Then I have define Access credential as "Other Specified" with the user name and passsword of the mail box owner. I am sure of the credential used. When pressing LoadData I can get email box displayed Pressing the Test button will return following error :
    "#26090 - An error occurred while opening mailbox info@solatys.com. System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 67.215.77.132:443 at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress) at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception) --- End of inner exception stack trace --- at System.Net.HttpWebRequest.GetRequestStream(TransportContext& context) at System.Net.HttpWebRequest.GetRequestStream() at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at Microsoft.Crm.Tools.Email.Providers.ExchangeServiceBinding.GetFolder(GetFolderType GetFolder1) at Microsoft.Crm.Tools.Email.Providers.ExchangeWSConnector.OpenMailbox() at Microsoft.Crm.Tools.Email.Providers.ExchangePollingMailboxProvider.InitExchangeConnector() at Microsoft.Crm.Tools.Email.Providers.ExchangePollingMailboxProvider.OpenMailbox() at Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.Run()" 
    
     
    Any idea ?
    regards serge

    Your knowledge is enhanced by that of others.
    Friday, September 9, 2011 11:25 AM

All replies

  • Hi,

    Seems like your exhange online server is not responding properly on this address  67.215.77.132:443 , verify the Exchange online address again and make sure that in your server outgoing/incommign traffic on port 443 is not blocked and you may also try configuring the outlook profile using the same settings for verificaiton.


    Jehanzeb Javeed

    http://worldofdynamics.blogspot.com
    Linked-In Profile |CodePlex Profile

    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".
    Friday, September 9, 2011 1:29 PM
  • I have already tcp port 443 open in/out on the server and try to defined an Ingoing and outgoing profile, same error for both.

    My CRM server is a VM hosted under a Hyper-V host server
    The cRM server is visible to my network and can go to internet.

    Does the port 443 need to be open as well on the Hyper-V host ?

    If not any idea what it could be esle ?

    regards

    serge


    Your knowledge is enhanced by that of others.
    Friday, September 9, 2011 2:58 PM
  • Hi,

    If you are even unable to configure the profile for Outlook using the same accoutn details then make sure to open 443 on Hyper-v host and verify that the Address, Port and Credentials are correct.


    Jehanzeb Javeed

    http://worldofdynamics.blogspot.com
    Linked-In Profile |CodePlex Profile

    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".
    Monday, September 12, 2011 5:34 AM
  • The profile for my outlook client with same account connect without any trouble and works fine.
    I have problem only from email router.
    Your knowledge is enhanced by that of others.
    Monday, September 12, 2011 9:01 AM
  • I have actually disable temporary Firewall on my CRM server and the HyperV host in order to be sure about firewall issue.

    I get same error, any idea what else it could be ?


    Your knowledge is enhanced by that of others.
    Monday, September 26, 2011 7:02 AM
  • The email you have an issue with is a distribution list or a normal e-mail ? 


    Mohammed JH

    Friday, February 1, 2013 10:09 AM