locked
WHS cannot see computers in my domain RRS feed

  • Question

  • I have a domain at home with a windows 2003 server. I have 2 Vista ultimate computers and 2 xp pro computers on the domain. I added a WHS to my physical network, I can connect to it remotely. It does not see any of my other computers at home. I tried adding the WHS to my domain and it still did not see any of my computers and when it was on the domain, I could not logon to it remotely.

    I removed it from my domain. Is it possible for the WHS to see computers in a domain it does not belong to? I added the ip of my domain controller to the dns address of the WMS.  

    Thanks,
    Brad 
    Monday, November 17, 2008 2:44 PM

All replies

  • It's probably firewall settings on the domain computers. Basic reading to do first: Home Networking. Then

    1.  WHS should not be member of the domain, however should be in the same network segment. If you use DHCP server this should be OK, otherwise you need to set correct TCP/IP settings and DNS server setting manually.

    2. Install Connector software on domain computers you want to join to WHS. This should set correct values in Windows firewall. If you have any other firewalls active you may need to set values manually there.

    3. Possibly you need to allow incoming ICMP ping requests on the clients for the LAN connection you are using for connection to WHS ( Network Connections, Right Click LAN connection, Properties, Advanced Tab, Windows Firewall Settings, Advanced Tab, Select LAN connection, Click Settings, ICMP Tab, check allow incoming echo requests).
    Monday, November 17, 2008 3:36 PM
    Moderator
  • I have done all the mods to the firewalls as described. The WHS doesn't see them at all as I have no computers in the list of available computers. What is the home connector software? I guess I need to do more homework. I just setup this all up yesterday and haven't really spent much time playing with it.

    Thanks,
    Brad
    Monday, November 17, 2008 3:47 PM
  • Hi Brad,
    another idea would be Install WINS on your Domain controller for NetBIOS name resolution and change the WINS settings of that server and all clients including WHS to point to that WINS server in their TCP/IP properties.
    Best greetings from Germany
    Olaf
    Monday, November 17, 2008 3:56 PM
    Moderator
  • Brad_700 said:

    I have done all the mods to the firewalls as described. The WHS doesn't see them at all as I have no computers in the list of available computers. What is the home connector software? I guess I need to do more homework. I just setup this all up yesterday and haven't really spent much time playing with it.

    Thanks,
    Brad


    Here's a link to almost all of the technical briefs for Windows Home Server including the getting started guide. 

    Thank you

    Lara Jones [MSFT] Windows Home Server Team
    Monday, November 17, 2008 3:56 PM
    Moderator
  • Brad_700 said:

    What is the home connector software?

    The software you need to install on each of the clients in order for WHS to recognise them properply.

    On each of the clients do http://yourservername:55000 (replace "yourservername" with the actual name of your server). This will get you to the page where you can download and install the correct version client software (provided your server is up to date).


    Brad_700 said:

    I guess I need to do more homework. 

    Good idea! Also overhere there's loads of documentation.

    • Edited by brubberModerator Monday, November 17, 2008 9:01 PM added links to client software and support pages
    Monday, November 17, 2008 8:52 PM
    Moderator
  • Well I installed the software on a Vista Ultimate PC (from my WHS, had I looked I would have seen the install software folder!) and I can see it in the list of available computers. At home I connected to it thru the internet via my home server from my laptop and it works fine. However at work, I always get a time out while trying to connect to that PC, same when I try and login to administer my home server. I can access the shared folders on my home server (from work) and have uploaded and downloaded file.

    I have found references to times outs, but that all seems to deal with the connection timing out after 20 minutes, I cannot connect at all. Perhaps it's the firewall or blocked ports at my office.

    What I found interesting is that when I did connect to the Vista Ultimate computer via the internet at home, is it forces me to login as either local administrator or another local account on the computer. It will not accept a domain/userid. As I stated earlier, I am running a domain at home. But my main question has been answered, it is possible to mix my WHS in my home network (with a domain) without adding the WHS to the domain. Thanks for the help so far, I am really enjoying playing with the WHS.

    Brad 
    Tuesday, November 18, 2008 12:31 PM
  • Timeouts for remote access from some other place are either caused by issues with port forwarding (port 80, 443, 4125), which can be located in your router, not allowed by ISP or (very often) blocked through the corporate firewall in your company, from where you try to access your WHS. Since you get the website, it seems port 80 and 443 go through, while 4125 for Remote Desktop Proxy is blocked.
    Best greetings from Germany
    Olaf
    Tuesday, November 18, 2008 2:19 PM
    Moderator
  •  
    Olaf Engelke said:

    Timeouts for remote access from some other place are either caused by issues with port forwarding (port 80, 443, 4125), which can be located in your router, not allowed by ISP or (very often) blocked through the corporate firewall in your company, from where you try to access your WHS. Since you get the website, it seems port 80 and 443 go through, while 4125 for Remote Desktop Proxy is blocked.
    Best greetings from Germany
    Olaf



    It does all work from other locations other than my office, I wonder if it's possible to reassign the port 4125 to one that might be available. I'll try and google it. I have been to Germany twice now and driven the entire length from north to south and then some. It's a beautiful country, my favorite country next Canada (where I live).
    Brad 
    Wednesday, November 19, 2008 2:26 PM
  • Brad_700 said:

    ... I wonder if it's possible to reassign the port 4125 to one that might be available. ...

    Not in this case. Port 4125 is built into WHS for the purpose of serving as the Remote Desktop proxy port.


    I'm not on the WHS team, I just post a lot. :)
    Wednesday, November 19, 2008 6:52 PM
    Moderator
  • Hi Brad,
    as a workaround you could try, if Remote Desktop Client would work from your office to the Home Server.
    To accomplish this arrange port forwarding for port 3389, and on Windows Home Server in Windows Firewall Settings change the scope of the Remotedesktop exception from local subnet to any computer.
    This would give you (unsupported) access to the server desktop (if it works from your office), from here you can start the console or establish connections to your client PCs.
    Best greetings from Germany
    Olaf
    Wednesday, November 19, 2008 7:45 PM
    Moderator
  •  
    Ken Warren said:

    Brad_700 said:

    ... I wonder if it's possible to reassign the port 4125 to one that might be available. ...

    Not in this case. Port 4125 is built into WHS for the purpose of serving as the Remote Desktop proxy port.


    I'm not on the WHS team, I just post a lot. :)



    that's a shame, one of the reasons I went to the trouble of setting WHS was for remote access to my home pc's, actually that was the only reason, I am sure most people are in the same boat as me, it just won't work from a corporate office, everything else it does I can accomplish quite easily and with less hassle with my Windows 2003 Server as all my PC's are within the same domain, really the marketing and advertising should come with a big warning when they state "access your home computer from anywhere" that in many cases it will not work, I think I'll reinstall server over it and have a backup domain controller again
    Friday, November 21, 2008 7:34 PM