locked
404 error after fresh install RRS feed

  • Question

  • I just installed CRM 2013 and it went through the installation without a hitch. When I load the website associated with it (both the secure and un secure) it takes a AD user name and then gives me a 404 error where the website should be. IIF says the website is started.

    Im getting REALLY frusturated as I have now uninstalled this and reinstalled it a few times I even built a new virtual server and installed only SQL and dynamics CRM 2013 on it and still get a 404 error. Please help Im lost to how to fix this.

    Ted

    Monday, April 28, 2014 3:46 AM

All replies

  • There is another thread from yesterday about it

    http://social.microsoft.com/Forums/en-US/home?forum=crm%2Ccrmdeployment&filter=alltypes&sort=lastpostdesc

    see if anything from helps you


    Please vote if you find my post helpful - Thanks

    Monday, April 28, 2014 6:03 AM
  • One thing to check is the organisation name you're using - e.g. if the orgname is MyOrg, and the server Url is http://crm, then try both http://crm and http://crm/MyOrg . The former can fail with a 404 if you had a previous organisation that you've since deleted (as CRM will try defaulting to the first organisation name)

    Also, if you are connecting from another machine, check your firewall settings. If you installed on port 5555 (for instance), this will be blocked by default.


    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk

    Monday, April 28, 2014 9:14 AM
    Moderator
  • I have read through that thread and he seems to have solved it but I am unsure exactly how Im sorry :(.

    I have tried to connect directly to the organization as noted above and in the other thread but still get a 404 error. I also have tried to directly connect on the machine so the firewall should not be an issue. Just the fact Im getting this error on two machines one of which is a fresh install is a but frustrating heh.

    Ted

    Monday, April 28, 2014 1:13 PM
  • Now I am getting really frusturated ... I just build ANOTHER new server ... Only thing installed on it is CRM and SQL. I did join it to the domain but NOTHING else was installed .... I still get a 404 error (it does bring up an authentication screen first) and nothing else. I mean srsly I built a completly fresh server and installed NOTHING on it but sql and crm 2013 and the website for the admin and users still does not work? what can I do to fix this?

    Ted

    Tuesday, April 29, 2014 3:48 AM
  • You get an authentication screen once and after you type credentials you get 404? or 401?

    Please vote if you find my post helpful - Thanks

    Tuesday, April 29, 2014 6:34 AM
  • It will authenticate once then go to 404.

    Now the only common element to any of the CRM installations is my AD ... is there anything in AD that could mess up this?

    Now Again I don't know how it could have messed it up but this all started when I installed an exchange 2013 server on my AD .. the exchange does run on its own server but before this I had a CRM install working fine ...after this my problems started ... could the exchange have made a change to the AD that is causing authentication issues? Is there anyway to bring up the website manually?

    Im at the point where I am willing to pay to have someone help as long as they tell me what I did wrong.

    Ted


    The initialization of the CRM authentication pipline execution has failed for org 69.64.71.40:81 with a sql error: System.Data.SqlClient.SqlException (0x80131904): The EXECUTE permission was denied on the object 'p_GetDefaultOrgFromAuthInfo', database 'MSCRM_CONFIG', schema 'dbo'.
       at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction)
       at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose)
       at System.Data.SqlClient.TdsParser.TryRun(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj, Boolean& dataReady)
       at System.Data.SqlClient.SqlDataReader.TryConsumeMetaData()
       at System.Data.SqlClient.SqlDataReader.get_MetaData()
       at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString)
       at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async, Int32 timeout, Task& task, Boolean asyncWrite, SqlDataReader ds)
       at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, TaskCompletionSource`1 completion, Int32 timeout, Task& task, Boolean asyncWrite)
       at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method)
       at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior, String method)
       at System.Data.SqlClient.SqlCommand.ExecuteDbDataReader(CommandBehavior behavior)
       at System.Data.Common.DbCommand.System.Data.IDbCommand.ExecuteReader()
       at Microsoft.Crm.CrmDbConnection.InternalExecuteWithRetry[TResult](Func`1 ExecuteMethod, IDbCommand command)
       at Microsoft.Crm.CrmDbConnection.InternalExecuteReader(IDbCommand command, Boolean capturePerfTrace)
       at Microsoft.Crm.CrmDbConnection.ExecuteReader(IDbCommand command, Boolean impersonate, Boolean capturePerfTrace)
       at Microsoft.Crm.ServerLocatorService.TryGetDefaultUserOrganizationFromDatabase(String authenticationInfo, Guid& organizationId)
       at Microsoft.Crm.ServerLocatorService.TryGetDefaultOrganization(String authenticationInfo, Guid& orgId)
       at Microsoft.Crm.ServerLocatorService.GetDefaultOrganization(String authenticationInfo)
       at Microsoft.Crm.Authentication.WindowsAuthenticationProvider.QueryForOrganizationId(String userToken)
       at Microsoft.Crm.Authentication.WindowsAuthenticationProviderBase.Authenticate(HttpApplication application, WindowsIdentity userIdentity)
       at Microsoft.Crm.Authentication.AuthenticationStep.Authenticate(HttpApplication application)
       at Microsoft.Crm.Authentication.AuthenticationPipeline.Authenticate(HttpApplication application)
       at Microsoft.Crm.Authentication.AuthenticationEngine.Execute(Object sender, EventArgs e)
    ClientConnectionId:3c8f8f52-09dc-40d6-baba-63200bb0c757.

    I seem to be having a security issue in SQL ...

    • Edited by Tedd Polzin Tuesday, April 29, 2014 5:11 PM
    Tuesday, April 29, 2014 1:03 PM
  • Does anyone know what security permission I am missing for the above? I see this error over and over again in the event viewer. Especially when I logon to the website, I obviously have a bad permission in the AD someplace and thats why it will not ever work no matter how many servers I setup.

    Ted

    Tuesday, April 29, 2014 8:53 PM
  • I have no idea which one did it .. I added a bunch of permissions to the SQL user account and it works .. I will trouble shoot this over the weekend when im not tired and I dont interfere with people entering stuff.

    Ted

    Wednesday, April 30, 2014 4:53 AM
  • Hi Tedd,

    It could be the missing "sysadmin" permission for the account used to install Dynamics CRM.


    Admin QuikView Solution for CRM 2013

    Wednesday, April 30, 2014 9:56 AM
  • Hi Ted,

    I am sorry to hear about your current experience with the new installation.

    I understand that you are getting a 404 error message when you are accessing a CRM org from a freshly installed CRM 2013 on premise environment. Both the direct access from the server and from a client machine has failed

    I would recommend you to continue the focus the troubleshooting first for one user (the Admin) and one machine ( the server) and ensure that you have granted the required permissions for the CRM Deployment Administrator Account following the below steps (Add Deployment Administrators  at http://technet.microsoft.com/en-us/library/gg197626.aspxand all other underlying required steps )

    If you need assistance on performing these checks or the given suggestions don’t help you moving forward, I’d suggest you to to open a Support Request with CRM Technical Support at the following link - http://www.microsoft.com/en-us/dynamics/crm-customer-center/contact-technical-support.aspx and work with our team to address the issue.

    Please let us know if this helps.

    Thank you for using Microsoft Dynamics CRM Communities.

    Nina Peneva

    Support Engineer

    Microsoft Dynamics CRM

    Friday, May 2, 2014 10:01 AM
  • Hi Ted, based on the error message. Please verify following bits:

    1. Check that the Network Service account is in the CRM PrivUserGroup in AD.

    2. Make sure CRM is installed by domain admin.

    Friday, May 2, 2014 1:00 PM
  • Long Shot: Are your VM's cloned properly? In the old day's we had to use newsid stuff.
    Saturday, May 3, 2014 5:57 AM