Delete that database! RRS feed

  • General discussion

  • I thought I would share my experience with a corrupt(?) databse. I'm not sure if it was a database issue or a disk issue but I received an error 0x45d when backing a particular computer and it is not in any listing or googleable. I could not delete the backups for that computer either - same error. For some reason I do not have the option to delete all backups (I know it should come with the PP but it didn't and I have no outstanding updates). I tried removing and adding each drive but no improvement. Repair just crashed the computer - I probably made things worse somewhere along the way. I couldn't delete the database manually becuase files were in use. The magic bullet was "Unlocker" a favourite utility which helps delete locked files. Download - run - reboot - done! Of course my database is done but I'll have all five home computers backed up again tonight.
    Monday, May 25, 2009 12:51 AM

All replies

  • Thanks for sharing your experience. A few remarks though:

    1. For manually deleting the backup database you should in general follow instructions as outlined in the Technical Brief Home Computer Backup and Restore, page 25. When you issue the commands net stop pdl and net stop whsbackup from a command prompt there should normally be no problems with locked files. If you did try this method and still had issues with locked files could you indicate which file was locked?
    2. If you have an issue with updates not downloading, please try and fix this first. Can you please check the version numbers displayed in the Windows Home Server Console, Settings, Resources?
    3. Some alternative ways of fixing a broken database can be found here.
    Monday, May 25, 2009 12:37 PM