locked
CRM 2011 SQLSERVERAGENT service is not running (during installation) RRS feed

  • Question

  • So I have an External SQL 2008 SP2 64 bit server we're going to use for our new CRm11 deployment.

    The server I'm deploying CRM on is a brand new Dell R610 running server 2008 Enterprise 64 bit.

    I'm creating a new deployment, later I will be upgrading a CRM4 deployment but that has nothing to do with my current problem.

    The service account entered for the CRM service is a domain admin account.

    I also added that account as a local admin account on the SQL server, even though I shouldn't have to since it's a domain admin account.

    I can telnet from the new CRM server to the SQL server on various ports the SQL server is listening on, that are listed in a netstat -a on the SQL server. (just to test FW) (although i don't see it listening on 1433 which is strange). TELNETTing to test ports works fine.  This SQL server is in production already though for several other internal applications.

    The sqlserveragent service IS running on the target SQL server, and I recycled it to be safe.

     

    Still, i'm getting "SQLSERVERAGENT (SQLSERVERAGENT) service is not running on the server " when I do the system check.

     

    I'm not sure what to do next, other systems connect to the DB fine.  It's on the same network segment as the SQL server.

     

    So anyway, one thing I noticed about this DB server while looking at the reporting services config is that the default instance on it isn't MSSQL (IE Servernam\MSSQL) but rather whomever built it named it "Servername\Servername"

    In the field during the CRM2011 setup early on it asks you "Enter or select the name of the computer that is running SQL Server to use with the deployment"

    It doesn't tell you to target the instance, so if you renamed your default instance this part will fail at the sqlserveragent check.

    When I went back and entered Servername\servername for my sql server field in the setup, it went through.  I figured it out while posting this but I figured someone else might want to know.

    Monday, September 26, 2011 8:07 PM

Answers

  • No what i'm saying is that when you install sql normally and keep the default instance name it's "server\mssql"

    Whoever built my sql server they named the default instance the same as the server name.

    And in addition, the field label during the installation just asks you for a server name, not the server name and instance.  So either it's misleading, or it assumes the default instance name of mssql.

     

    Either way, I fixed my problem by entering in the servername\instance instead of just the server name in that field during the setup.

    Monday, September 26, 2011 9:36 PM

All replies

  • Hi,

    You may refer to the solution mentioned in the following thread: http://social.microsoft.com/Forums/en-US/crmdeployment/thread/7c58de49-c2c3-4ed1-870d-c6127dd5b879


    Jehanzeb Javeed

    http://worldofdynamics.blogspot.com
    Linked-In Profile |CodePlex Profile

    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".
    Monday, September 26, 2011 9:21 PM
  • Is there more than one SQL instance on the same box?  Could you be connecting to the wrong one?
    Jamie Miley
    Check out my about.me profile!
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!
    • Proposed as answer by Khaja Mohiddin Friday, August 17, 2012 1:15 PM
    • Marked as answer by Jamie MileyModerator Wednesday, September 26, 2012 2:17 PM
    • Unmarked as answer by Statistic Thursday, January 30, 2014 9:20 PM
    Monday, September 26, 2011 9:32 PM
    Moderator
  • No what i'm saying is that when you install sql normally and keep the default instance name it's "server\mssql"

    Whoever built my sql server they named the default instance the same as the server name.

    And in addition, the field label during the installation just asks you for a server name, not the server name and instance.  So either it's misleading, or it assumes the default instance name of mssql.

     

    Either way, I fixed my problem by entering in the servername\instance instead of just the server name in that field during the setup.

    Monday, September 26, 2011 9:36 PM
  • Hi,

    Please check the sql agent services is running in services.msc.

    Chk whether firewall is blocking ur sql port.

    Chk in sql server whether remote access is enabled or not.


    Thanks & Regards, MS CRM Consultant, V.Surya.
    Tuesday, September 27, 2011 5:56 AM
    Answerer
  • Tuesday, March 6, 2012 2:57 PM
    Moderator
  • Hi everyBody,

    i know it's a old post, i'm facing the same issue during my first installation of microsoft dynamics crm 2011 on a Windows 2008 64bits and Sql server 2012 BI.

    I resolved this issue by reinstalling Sql server and i let the default instance of Sql. my first install i create a custom instance of Sql like CRM. when i see this error i go to services and look at the name of the Sql Agent service which is SQLSERVERAGENT$CRM and not the name that the installer of microsoft dynamics search.

    Microsoft dynamics don't let install the CRM on another instance of SQl server... Allo microsoft quoi !!

    Hope that help!

    sorry for English !

    Friday, April 26, 2013 10:13 AM
  • Hi Virgule,

    When this went wrong, did you have a default instance running in SQL or only a named instance?

    Kind Regards,

    Alexander

    Thursday, June 13, 2013 11:25 AM
  • Hi AlexR,

    When this went wrong I have only a named instance "CRM" but Microsoft Dynamics search only for the service SQLSERVERAGENT (name of the service). If you try to give another name when you install SQLSERVER, then the service name SQLSERVERAGENT become "SQLSERVERAGENT$<custominstancename>".

    When you install Dynamics, Dynamics try to detect the service "SQLSERVERAGENT" and only  "SQLSERVERAGENT".

    Best Regards.

    • Proposed as answer by dimaqw Thursday, January 30, 2014 9:09 PM
    Thursday, June 13, 2013 5:03 PM
  • Thank You friend! You so very rescued! The most helpful answer! I'm searched answer more two hours. Very respect you. Sorry for my bad English
    Thursday, January 30, 2014 9:08 PM