locked
Buttons disappear? RRS feed

  • Question

  • Hi guys,

     

    I have created a console tab with 5 'consoletoolbar'-buttons.

    When start the console and activate the tab, I see 4 buttons but the fifth isn't shown.

    When I then activate another tab and go back to my tab,the fifth button shows and then stays visible...

     

    Anyone else had this problem, any ideas what is causing this?

     

    PS: Is there any way of testing the UI of the add-in via a dummy console?

    That way I don't have to deploy everytime on the server and reboot+test, just to see if the UI is correct...

     

    Tnx,

    Nick

    Monday, July 16, 2007 4:21 PM

Answers

  • Hi Nick,

     

    Nice catch. THis is a known issue with ConsoleToolBar. The workaround is to create a dummy ToolStripSeparator at the end of the buttons and make it invisible.

     

    ToolStripSeparator dummy = new ToolStripSeparator();

    dummy.Visible = false;

    consoleToolBar.Items.Add(dummy);

     

    Hope this helps.

    Monday, July 16, 2007 6:58 PM
    Moderator

All replies

  • Hi Nick,

     

    Nice catch. THis is a known issue with ConsoleToolBar. The workaround is to create a dummy ToolStripSeparator at the end of the buttons and make it invisible.

     

    ToolStripSeparator dummy = new ToolStripSeparator();

    dummy.Visible = false;

    consoleToolBar.Items.Add(dummy);

     

    Hope this helps.

    Monday, July 16, 2007 6:58 PM
    Moderator
  • It's nice to know that I wasn't the only crazy one!!

     

    Rob

    Monday, July 16, 2007 8:54 PM
  • That does the job, thank you very much! :-)

     

    Best Regards,

    Nick

    Tuesday, July 17, 2007 8:52 AM