locked
Will not debug RRS feed

  • Question

  • Hello,

     

    I have added a simple workflow speech app project to an existing solution.  Without making any changes, clicking debug successfully builds the project then pops up an error dialog stating 'Unable to start program '<path>\<project>.dll'.  If I copy this exact same project and open it in a stand alone solution (no other projects), debugging works fine.

     

    Any suggestions?

     

    Thanks!

    Jon

    Wednesday, May 16, 2007 11:54 AM

Answers

  • You need to do step (3) "Set as Startup Project" before debugging.
    Wednesday, May 16, 2007 2:03 PM

All replies

  • I just tried the following in VS:

     

    1)      File->New Project->Windows Application

    2)      File->Open Project->ThinkingSounds.sln (from samples), selecting “Add to solution”

    3)      In Solution Explorer, right click ThinkingSounds and select Set as Startup Project

    4)      F5 – debugging starts as expected.

     

    For (2), right click Solution in Solution Explorer and select Add -> Existing Project yields the same results.

     

    Do these steps work for you?  Did you do step (3)?

    Wednesday, May 16, 2007 1:15 PM
  • Anthony,

     

    The steps I followed were:

    1. Open existing sln
    2. File > Add > New Project (selecting all default options for speech voice response workflow application)
    3. Right click on new project > debug > start new instance

    These are a bit different than your steps, but I don't see why this should cause any issues?

     

    Thanks

    Jon

    Wednesday, May 16, 2007 1:37 PM
  • Anthony,

     

    I also tried adding the ThinkingSounds project to the solution and got the same error:

     

    Microsoft Visual Studio

    Unable to start program 'c:\program files\microsoft office communications server 2007 speech server\samples\workflow\thinkingsounds\thinkingsounds\bin\thinkingsounds.dll'.

     

    Thanks

    Jon

    Wednesday, May 16, 2007 1:50 PM
  • You need to do step (3) "Set as Startup Project" before debugging.
    Wednesday, May 16, 2007 2:03 PM
  • That did it, thank you!

     

    It strikes me as odd that you have to mark it as the start up project, even if you are right-clicking on the individual project and clicking debug.

     

    Anyway, thanks again.

    Jon

    Wednesday, May 16, 2007 2:13 PM