none
Clicking forum Reply links, etc, in this forum does not work in IE 11 RRS feed

  • Question

  • I have had a long-standing problem when accessing the MSDN forums using IE 11 under 64-bit Windows 7. Clicking any of the links under a post, e.g. Reply, Quote, Mark as Answer, etc, does not have the desired effect. The status bar simply displays javascript: void();

    So far, my solution has been to use another browser but I would appreciate some assistance in fixing this problem with IE. Note that it only seems to occur with the MSDN forums.

    I have already tried a clean boot after editing the msconfig.exe settings. That had no effect. Neither does running IE in 'No Add-Ons' mode. The System File Checker tool (SFC.exe) also found no issues with any of my Windows system files.   

    Any suggestions?

    David

    Tuesday, February 17, 2015 1:09 PM

Answers

  • You could try a full IE reset (including the 'personal settings' checkbox) and see if that helps.


    Don't retire TechNet! - (Don't give up yet - 13,085+ strong and growing)

    • Marked as answer by haggis999 Tuesday, February 17, 2015 4:40 PM
    Tuesday, February 17, 2015 4:11 PM
    Moderator
  • You could try a full IE reset (including the 'personal settings' checkbox) and see if that helps.



    After going to Internet Options/Advanced I couldn't see any 'personal settings' checkbox but decided to click on the 'Restore advanced settings' button before attempting a full reset to default settings. To be honest, I wasn't quite sure what those 'advanced settings' might be but thought it could be worth trying to restore them.

    It worked! My problem with these forums has now disappeared.

    Many thanks for your help on this. It is much appreciated  ;-)

    David

    • Marked as answer by haggis999 Tuesday, February 17, 2015 4:40 PM
    Tuesday, February 17, 2015 4:40 PM

All replies

  • Hi David,

    I don't use IE11 to post often, but I haven't had any problems with it (and I'm posting this message with IE11 just to be sure).

    Make sure you're not in compatibility mode. I've seen that cause some strangeness.


    Don't retire TechNet! - (Don't give up yet - 13,085+ strong and growing)

    Tuesday, February 17, 2015 1:43 PM
    Moderator
  • Hi Mike,
    I had already checked that I was not using Compatibility Mode. Despite their apparent irrelevance, I even tried turning off both checkboxes in the Compatibility View Settings dialogue box but it made no difference.

    My security setting within IE Internet Options is set to a default version of 'Medium-high'. The Enable Protected Mode checkbox is set on.

    David

    EDIT: My IE 11 version is 11.0.9600.17633. Are you using the same version?

    • Edited by haggis999 Tuesday, February 17, 2015 2:14 PM
    Tuesday, February 17, 2015 2:10 PM
  • Hi Mike,
    I had already checked that I was not using Compatibility Mode. Despite their apparent irrelevance, I even tried turning off both checkboxes in the Compatibility View Settings dialogue box but it made no difference.

    My security setting within IE Internet Options is set to a default version of 'Medium-high'. The Enable Protected Mode checkbox is set on.

    David

    EDIT: My IE 11 version is 11.0.9600.17633. Are you using the same version?

    Yep, same version.

    Have you done the usual dance of clearing all cookies and cache? I've been having intermittent cookie problems with these forums and the Answers site for about a month or so that would stop me from being able to log in. Perhaps there's something similar going on.


    Don't retire TechNet! - (Don't give up yet - 13,085+ strong and growing)

    Tuesday, February 17, 2015 2:24 PM
    Moderator
  • I have just run CCleaner with most of its options set but this has made no difference. While posting this reply via Opera, I noticed that it too displays javascript: void(); whenever I hover over the Reply link, etc.

    David

    Tuesday, February 17, 2015 3:50 PM
  • You don't need to worry about seeing 'javascript:void();' appearing on hover, that's completely normal.

    Don't retire TechNet! - (Don't give up yet - 13,085+ strong and growing)

    Tuesday, February 17, 2015 3:51 PM
    Moderator
  • You don't need to worry about seeing 'javascript:void();' appearing on hover, that's completely normal.

    As soon as I saw that in Opera (and in Firefox) I guessed that it was unlikely to be related to my problem, as I have no issues when accessing the Microsoft forums using those browsers.

    Is there anything else worth checking on my machine that might highlight a reason for the misbehaviour of Internet Explorer?

    David

    Tuesday, February 17, 2015 4:05 PM
  • You could try a full IE reset (including the 'personal settings' checkbox) and see if that helps.


    Don't retire TechNet! - (Don't give up yet - 13,085+ strong and growing)

    • Marked as answer by haggis999 Tuesday, February 17, 2015 4:40 PM
    Tuesday, February 17, 2015 4:11 PM
    Moderator
  • You could try a full IE reset (including the 'personal settings' checkbox) and see if that helps.



    After going to Internet Options/Advanced I couldn't see any 'personal settings' checkbox but decided to click on the 'Restore advanced settings' button before attempting a full reset to default settings. To be honest, I wasn't quite sure what those 'advanced settings' might be but thought it could be worth trying to restore them.

    It worked! My problem with these forums has now disappeared.

    Many thanks for your help on this. It is much appreciated  ;-)

    David

    • Marked as answer by haggis999 Tuesday, February 17, 2015 4:40 PM
    Tuesday, February 17, 2015 4:40 PM
  • Cheers David, you're very welcome. I'm glad it all worked out.

    Don't retire TechNet! - (Don't give up yet - 13,085+ strong and growing)

    Tuesday, February 17, 2015 4:41 PM
    Moderator