locked
CRM 2013: Cannot read property 'Id' of undefined RRS feed

  • Question

  • Microsoft Dynamics CRM Error Report Contents
    
    <CrmScriptErrorReport>
      <ReportVersion>1.0</ReportVersion>
      <ScriptErrorDetails>
       <Message>Uncaught TypeError: Cannot read property 'Id' of undefined</Message>
       <Line>1</Line>
       <URL>/_static/_common/scripts/commandbaractions.js?ver=-1256700295</URL>
       <PageURL>/main.aspx#835848710</PageURL>
       <Function>anonymousr:Cannotreadproperty'Id'ofundefined</Function>
       <CallStack>
        <Function>anonymousr:Cannotreadproperty'Id'ofundefined</Function>
       </CallStack>
      </ScriptErrorDetails>
      <ClientInformation>
       <BrowserUserAgent>Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.114 Safari/537.36</BrowserUserAgent>
       <BrowserLanguage>undefined</BrowserLanguage>
       <SystemLanguage>undefined</SystemLanguage>
       <UserLanguage>undefined</UserLanguage>
       <ScreenResolution>1366x768</ScreenResolution>
       <ClientName>Web</ClientName>
       <ClientTime>2014-06-04T05:14:02</ClientTime>
      </ClientInformation>
      <ServerInformation>
        <OrgLanguage>1033</OrgLanguage>
        <OrgCulture>1033</OrgCulture>
        <UserLanguage>1033</UserLanguage>
        <UserCulture>1033</UserCulture>
        <OrgID>{3FF48E2D-53E2-E311-942C-00155D0AAB07}</OrgID>
        <UserID>{400B932A-5CE2-E311-942C-00155D0AAB07}</UserID>
        <CRMVersion>6.0.2.46</CRMVersion>
      </ServerInformation>
    </CrmScriptErrorReport>
    
    <CrmScriptErrorReport>
      <ReportVersion>1.0</ReportVersion>
      <ScriptErrorDetails>
       <Message>Uncaught TypeError: Cannot read property 'Id' of undefined</Message>
       <Line>1</Line>
       <URL>/_static/_common/scripts/commandbaractions.js?ver=-1256700295</URL>
       <PageURL>/main.aspx#835848710</PageURL>
       <Function>anonymousr:Cannotreadproperty'Id'ofundefined</Function>
       <CallStack>
        <Function>anonymousr:Cannotreadproperty'Id'ofundefined</Function>
       </CallStack>
      </ScriptErrorDetails>
      <ClientInformation>
       <BrowserUserAgent>Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.114 Safari/537.36</BrowserUserAgent>
       <BrowserLanguage>undefined</BrowserLanguage>
       <SystemLanguage>undefined</SystemLanguage>
       <UserLanguage>undefined</UserLanguage>
       <ScreenResolution>1366x768</ScreenResolution>
       <ClientName>Web</ClientName>
       <ClientTime>2014-06-04T05:14:15</ClientTime>
      </ClientInformation>
      <ServerInformation>
        <OrgLanguage>1033</OrgLanguage>
        <OrgCulture>1033</OrgCulture>
        <UserLanguage>1033</UserLanguage>
        <UserCulture>1033</UserCulture>
        <OrgID>{3FF48E2D-53E2-E311-942C-00155D0AAB07}</OrgID>
        <UserID>{400B932A-5CE2-E311-942C-00155D0AAB07}</UserID>
        <CRMVersion>6.0.2.46</CRMVersion>
      </ServerInformation>
    </CrmScriptErrorReport>
    

    When I click delete button on Contact entity view (no record has been selected in view), I got this error. 

    Error in commandbaractions.js. Error detail and image attached.

    Wednesday, June 4, 2014 11:24 AM

All replies

  • Looks like a bug to me!

    Best way to get it sorted is to submit it to Microsoft Connect (https://connect.microsoft.com/dynamicssuggestions)

    And in the meantime, don't try to delete without selecting a record first ;)


    Wednesday, June 4, 2014 2:02 PM