none
deleting a thread RRS feed

  • Question

  • A) Expanding a deleted thread causing the indicator to change but nothing is shown.

    Not sure this is a bug. But a deleted message would be nice.

    Repro:

     1) Create thread in tab 1.
     2) open forum list in tab 2
     3) tab 1, delete thread
     4) tab 2 expand thread

    B) If the thread was previously expanded in that tab/window, it can be expanded/deleted over and over again even though the thread was deleted. That somewhat of a good thing, but letting the user know it was deleted might be nice.

    Repro:

     1) Create thread in tab 1.
     2) open forum list in tab 2
     3) tab2: expand thread
     4) tab 1, delete thread
     5) tab 2: expand/abridge

    C) Replying to a deleted thread generates an unexpected error.

    Repro:

     1) Create thread in tab 1.
     2) open forum list in tab 2
     3) tab2: expand thread
     4) tab 1, delete thread
     5) tab 2: reply to thread


    D) deleting a thread that has a reply generates an unexpected error.

    Repro:

     1) Create thread
     2) Reply to thread
     3) Delete thread (not the reply, but the thread itself)
    Friday, July 24, 2009 1:59 PM

Answers

  • Hi Brian
    • Above mentioned A,B and C issues are by design, On refreshing the page deleted thread disappears from the Forum list.
    • I am not able to repro the D issue with the repro steps mentioned above.
    We disable the reply and Quotes on a deleted thread.

    Please let us know if your issues were answered.


    Forums Test Team member...
    Monday, July 27, 2009 9:06 PM
  • We disable the reply and Quotes on a deleted thread.
    This is just an FYI...  D) still stands "no repro" from one of our testers.

    STO Forums Test Lead
    Monday, July 27, 2009 9:11 PM
  • Hi Brian,

    What you're seeing is by design. A thread owner cannot delete a thread if there are subsequent replies. Only moderators and above can delete the entire thread (with replies).

    You're getting the unexpected error because when you're trying to delete the thread, it contains replies. If you refresh the page before delete the action, you'll notice that the delete button is not an option.

    Thanks.
    STO Forums Test Lead
    Wednesday, July 29, 2009 3:45 PM

All replies

  • Hi Brian
    • Above mentioned A,B and C issues are by design, On refreshing the page deleted thread disappears from the Forum list.
    • I am not able to repro the D issue with the repro steps mentioned above.
    We disable the reply and Quotes on a deleted thread.

    Please let us know if your issues were answered.


    Forums Test Team member...
    Monday, July 27, 2009 9:06 PM
  • We disable the reply and Quotes on a deleted thread.
    This is just an FYI...  D) still stands "no repro" from one of our testers.

    STO Forums Test Lead
    Monday, July 27, 2009 9:11 PM
  • OK, tested this in IE 6 and FF 3.51. And just to make this interesting i'll add pictures and conversations:

    IE 6
    Create a thread: <IMG SRC = "http://yfrog.com/3oie1lj">
    Reply to it: <IMG SRC = "http://yfrog.com/7gie2j">
    So now we have a thread with a post: <IMG SRC = "http://yfrog.com/5aie3j">
    Delete the thread, give a reason: <IMG SRC = "http://yfrog.com/4mie4j">
    Now that was unexpected: <IMG SRC = "http://yfrog.com/3oie5j">

    FF
    Create a thread: <IMG SRC = "http://yfrog.com/2zff1nj">
    Reply to it: <IMG SRC = "http://yfrog.com/0wff2lj">
    So now we have a thread with a post: <IMG SRC = "http://yfrog.com/13ff3sj">
    Delete the thread, give a reason: <IMG SRC = "http://yfrog.com/epff4oj">
    Now that was unexpected: <IMG SRC = "http://yfrog.com/0off5bj">
    Tuesday, July 28, 2009 11:42 AM
  • Hi Brian,

    What you're seeing is by design. A thread owner cannot delete a thread if there are subsequent replies. Only moderators and above can delete the entire thread (with replies).

    You're getting the unexpected error because when you're trying to delete the thread, it contains replies. If you refresh the page before delete the action, you'll notice that the delete button is not an option.

    Thanks.
    STO Forums Test Lead
    Wednesday, July 29, 2009 3:45 PM
  • Yeah, figured as much. As i said "Not sure this is a bug. But a deleted message would be nice."

    Friday, July 31, 2009 1:19 PM
  • Noted :). Thanks
    STO Forums Test Lead
    Friday, July 31, 2009 3:29 PM