SKYPE and LinksysCIT200 as service or add in? RRS feed

  • Question

  • Does anyone have any ideas how I can install Skype and the Linksys CIT200 driver (wireless DECT skype phone) on WHS. (as a service) As this machine is always on, and happens to be located in the centre of my house, it makes sense this to be running my skype.

    Would like to start testing, but unsure were to start. Obviously would prefer it to run without being logged on. further down the road an add-in showing my credit-level and sending a message when credit is low perhaps?

    Fantastic product, looking forward to discover all the other possible uses!

    Thursday, May 24, 2007 7:28 AM

All replies

  • http://support.microsoft.com/kb/137890

    Use the guide in the above link to create a user defined service.  The software will run at startup without anyone being logged on.  I used it as a method to install the Netgear MP101 mediaserver software and it worked a treat.

    Thursday, May 24, 2007 5:04 PM
  • I will try this later, I have successfully (I think) managed to get skype running as a service using firedaemon. (firedaemon is only free for 30 days so I would rather fine anotherway in the medium term)


    for howto see: http://forums.firedaemon.com/viewtopic.php?t=223


    however as I use a linksys skype phone (dect based, base plugged into usb of server) I also need to run CIT200. I have not yet managed this.


    CIT200 will run when put into winxp compatibilty mode. (rightclick on exe and adjust relevant compatibility settings). It then sees skype as long as i have started skype as an application (not service.)


    Next step is trying to get both as service, no luck so far. Does anyone have any ideas?


    If this is impossible, maybe there is another avenue to explore? Any ideas would be very welcome!!

    Sunday, May 27, 2007 10:35 AM
  • I'm not familure with these programs - if they run as a service in Windows I'll bet you'd be okay just running them


    if they're UI driven programs its a little trickier - an easy solution would be to use mstsc (Remote Desktop) and then just launch the app.  If you close the Remote Desktop session and dont log out the program will run until you either shut it off or shut down the machine.


    as an experiment Smile    I wonder what would happen if you run the app as a scheduled task? 

    Thursday, June 7, 2007 3:55 AM
  • If you do decide to go down the road of making Skype a service, be sure to explicitly set the permissions it needs -- nothing more. Skype, every now and then, comes out with its own exploitable defects which are magnified in a service space.
    Thursday, June 7, 2007 4:38 AM
  • Using the remote desktop I got skype and the software for my GE 2 in 1 internet wireless phone working. Everything is working except WHS dosen't see the hardware. WHS dosen't restart very offen and I was willing logon with remote desktop for now; but I can't get the phone to work. As far as I tell, WHS dosen't even see the onboard sound chip of my ASUS P4C800-E MB.  I was thinking same thing as Jaap_98, WHS PC is in the center of the house and runs 24/7 and is the logical choice for skype. Hopefully  with WHS updates coming microsoft will address skype problems.

    Monday, December 3, 2007 3:23 PM
  • Have you approached Skype support? It's usually up to the software provider to fit it's products to the operating system and I would imagine there will be quite a market for a lot of people to have this to run as a service now WHS is out.

    Your problem with the m/b sound, WHS as a server, doesn't have support for sound chips, but you might well be able to get your drivers to work, as there are other people on the forum with sound working.




    Monday, December 3, 2007 6:01 PM
  • The key to this is how you start Remote Desktop Connection on your PC! If your PC is running Vista you'll need to edit your short cut and add the following command to it, /admin so the short cut will look like this, %systemroot%\system32\mstsc.exe /admin. If you are running something other than Vista edit it to look like this, %systemroot%\system32\mstsc.exe /console next start Remote Desktop Connection, and click on Options>>> In the "Local Resources" (tab) under "Remote computer sound" set it to "Leave at remote computer" Then click on  "Connect" When WHS opens you'll now be able to click on | Start (menu) | Control Panel | Sound and Audio Devices | and on the "Audio" you should be able to select your audio device. If you don't see it there you may need to uninstall the driver rebbot and reinstall the driver. Hope this helps.

    Monday, February 18, 2008 3:44 PM