locked
OneCare is not notifying me of blocking ports of services RRS feed

  • Question

  •  

    I was having some problems reaching SQL Server Express with SQL Server Management Express (SSME) on one of the machines in my OneCare Circle and as a last resort, I shut down the OneCare Firewall temporarily and was able to reach using both the SQL Server Browser and SSME without any problems.  I tried the same strategy to see why my Workgroups and File and Printer Sharing were not working and it turned out OneCare was the problem there too.  I manually added the ports in my Windows Firewall and everything starts to work right away.  I don't know what ports to add to get my File and Printer Sharing or Workgroups going again.

     

    One of the things that I rely on OneCare to do is to at least tell me when it is blocking some communication on one of my machines.  Why am I not being informed so that I can release access to the program I am trying to reach?  This is of fundamental importance to me and determines whether I use a firewall product at all.

     

    Am I missing something?  Is there some part of OneCare that I can use to find out if it is playing a role without shutting it down?

    Monday, October 13, 2008 5:03 PM

Answers

  • I think that one of the issues you are encountering is that some ports are not going to be open unless you open them and OneCare won't tell you about it if the program is allowed to communicate over other open ports. That's a limitation of OneCare, but probably fine for most people to prevent too much confusion in prompts for allow or  block requests, which most users will answer incorrectly much of the time.

    Sharing, on the other hand, is an ongoing issue with OneCare that I see periodically. This was a much more widespread problem in the 1.x version, but it still crops up in 2.x.

    Open OneCare.

    Click Change Settings

    On the firewall tab, click configure firewall

    If the network is shown as Public, click Change Location to change it to "Home or Work."

    Click the Advanced Settings button

    Click Network connections tab.

    If there are multiple active connections shown, you may need to disable the extras in your Windows network connections settings. (Network and Sharing Center, manage connections, in Vista; Right click My Network Places and select Properties on the Start menu in XP)

    On the Ports and Protocols tab, add a check mark next to File and Printer Sharing - for subnet and Internet if the first setting alone (after all of the above are verified) does not allow Sharing to work.

    If all of the above fail, please contact support.

    How to reach support (FAQ) - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

     

    -steve

    Tuesday, October 14, 2008 4:06 PM
    Moderator