none
An application runs slowly when connecting to files on sbs2008 but fine when moved to an XP box. All other applications run fine RRS feed

  • Question

  • All other applications run fine between server and workstations. Have tried the following:

    Open command prompt and type:

    netsh interface tcp set global rss=disabled

    netsh interface tcp set global autotuning=disabled

    Restart server

     

    1.Run "regedit" on Windows Server 2008 based computer.

    2.Expand and locate the sub tree as follows.

    HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

    3.Add a new REG_DWORD key with the name of "Smb2" (without quotation mark)

    Value name: Smb2

    Value type: REG_DWORD

    0 = disabled

    1 = enabled

    4.Set the value to 0 to disable SMB 2.0, or set it to 1 to re-enable SMB 2.0.

    5.Reboot the server.

     

    Modify a serial registry key to control Windows Size and related network parameter.

    1) Tune AFD.sys

    Key: HKLM\System\CurrentControlSet\Services\AFD\Parameters.

    Name: LargeBufferSize

    Type: DWORD

    Data: 65534 (Dec)

     

    Name: TransmitIoLength

    Type: DWORD

    Data: 65534 (Dec)

     

    Name: Defaultsendwindow

    Type: DWORD

    Data: 65534 (Decimal)

     

    2) Tune Windows size

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\

    TcpWindowSize

    Type: DWORD

    Data: 16384 (Decimal)

    And restart.

     

    Tuesday, August 17, 2010 4:41 AM

Answers