CRM 4.0 - E-mail Router configuration error (Unable to connect to the remote server) RRS feed

  • Question

  • Hi,

    I'm trying to install the e-mail router for CRM4.0 but I'm getting an error when I try to click on the "Load Data" button within the "E-mail Router Configuration Manager".

    The error is:
    "The E-mail Router Configuration Manager was unable to retrieve user and queue information from Microsoft Dynamics CRM server. This may indicate that the MIcrosoft Dynamics CRM server is busy. Verify that URL http://100crm001/VIOS is correct. Additionally, this problem can occur if specified access credentilas are insufficient. To try again, click Load Data (Inable to connect to the remote server)"

    Our environment is composed of an Exchange 2007 server (installed on Windows 2008 with SP2), a CRM 4.0 server (installed on Windows 2008 R2) and a CRM database with SQL 2008 server (Installed on Windows 2008 R2).
    The CRM server is working perfectly (no other problems except this installation) and is up-to-date with Rollup 7 for both server and Email router.
    I have created a specific user (call 'CRMRouter') which has domain admin rights and Exchange rights to access all mailboxes.
    This user is used to run the E-mail router service.

    I have read all the posts I could find, and I probably tried hunderds of different solutions that I have read about so far such as:
    - making sure that the name of the company is spelled properly (Case sensitive).
    - using 'https' vs 'http' in the incoming profile.
    - changed the access credentials to the CRMRouter user, the domain administrator or the local system.
    - Added the CRMRouter user to all the CRM security groups that were created during the installation.
    - changed the CRM Router service to use 'Local system' account as oppose to the specific user.
    - ...

    I've run out of ideas so any suggestions from here would be much appreciated :-)

    Thanks a lot,

    Friday, December 4, 2009 12:29 AM


All replies

  • Hi Stephane,

    I'll assume your e-mail router is not installed on the e-mail sever.  If it is installed on the e-mail server try moving it to a different server.

    Since the CRMRouter user has full Domain Network rights, set your e-mail router service to use that user login account rather than Local System.

    If none of the above helps, have a look at this post

    If the post does not help, then please provide your Incoming and Outgoing settings in the same format as those provided in the post and I'll see if I can see any potential issues.
    Best Regards, Donna
    Friday, December 4, 2009 1:45 PM
  • Hi Donna,

    Thank you for your reply.

    The CRM Email router is indeed running on a separate server (not on my exchange server).
    It is currently running on my CRM server itself (note that the database server is separate).

    I've changed the CRM Email router service from "Local Account" to "CRMRouter" which is a user with full domain and exchange rights, but still no joy.

    I reviewed the post you mentionned above, but it seems to be all related with security issues.
    I don't think I even get to the point where the security is being checked.

    When I try to click on the "Load Data" button, the end of the error message says "Unable to connect to the remote server".
    Wouldn't that happen even before the security checks? No matter which option I change in the Profiles or Deployment, it always comes back with tha above error, which again could indicate that it doesn't even get to the security check but has more a connectivity problem?
    (Maybe something to do with IPv6??)

    Here is my configuration details:
    email server: exchange
    Authentication Type: Windows Authentication
    Location: https://100EXS001 (my exchange server name)
    Access Credentails: Other specified (CRMRouter user

    Email server type: SMTP
    Authentication Type: Windows Authentication
    Location: 100EXS001 (SSL unticked)
    Access Credentials: Local System Account

    Microsoft Dynamics Server: http://100CRM001/VIOS (Same server were the Email router is installed on).
    Access Credentials: Other Specified (CRM administrator user)

    Hope this helps,

    Monday, December 7, 2009 4:48 AM
  • I've just checked the application log on the CRM server (Were the Email router is installed) and I see some errors there (sorry I should have checked this earlier):

    "MSCRMEmail error: #23379 - Could not verify the version of Microsoft Dynamics CRM at http://100crm001/VIOS. Unable to connect to the remote server"

    I've ensured that both the CRM server and CRM Email router are both up-to-date (rollup 7).

    Thank you,

    Monday, December 7, 2009 5:16 AM
  • this error generally means that the e-mail router can not connect to the crm server.  It can sometimes be an IP issue or other network connectivity issue.  If you've made any recent network changes, I would probably begin there.

    Could not verify the version of Microsoft Dynamics CRM at http://100crm001/VIOS. Unable to connect to the remote server"

    Also, you can try changing the OUTGOING PROFILE:

    "Access Credentials: Local System Account" to a domain admin account and see if that helps.  If you're CRM Router user is a domain admin account, try setting outgoing, incoming, deployment and the CRM e-mail router service login to use that account and see if you get a different result.

    Best Regards, Donna
    Monday, December 7, 2009 1:39 PM

  • Try it.

    Download the Exchange Server MAPI Client


    Install it in the server where you installed the email router.

    My suggestion is to remove your email router installation and reinstall again.

    Tell us if your problem is resolved.

    PD: Is Email Router server in the PrivateUserGroup? If not , add it.

    Jimmy Larrauri
    Monday, December 7, 2009 2:54 PM
  • I went through the suggestions above, and still no joy:

    - Checked network connectivity: I can ping the server by IP, NETBIOS name and FQDN. I can also connect to the server via HTTP. Just in case it matters, I also disabled IPv6 completely (using registry hack as per Microsoft document). Opened up the firewall on the server to allow all incoming and outgoing connections.
    - Checked the DNS configuration. Everything seems fine there
    - Changed the Outgoing profile to use the domain admin account
    - Installed the Exchange Server MAPI Client
    - Uninstalled the CRM router, deleted the folder it was installed into, rebooted the server then re-installed the CRM router. Applied the rollup 7.

    Unfortunately, all the above did not fix the problem itas I still get the "unable to connect to the remote server" error.

    My CRM server and CRM Email router are both the same version: 4.0.7333.2138

    Short of re-installing the entire CRM server itseld, I'm not too sure on what to do anymore (and I start to believe that even that won't fix it).
    Could it be because the CRM server and CRM Email router (both on the same server) are installed on Windows 2008 R2 64bits?
    I've done similar deployments, but never run into this kind of connectivity problems before using R2.

    I'll first try to install a separate server with CRM Email router only (on Windows 2008 R2, then Windows 2008 if that still doesn't work).
    I'll will post the results, but if in the mean time you have any other suggestions... :-)

    Thank you again for your help

    Tuesday, December 8, 2009 2:52 AM
  • Hi Stephane!

    Check it:


    I had the same problems three months ago aproximately.

    I hope that this helps you;

    Jimmy Larrauri
    Tuesday, December 8, 2009 3:40 AM
  • I've installed the CRM Email router to a complete separate server installed with Windows 2008 server 32bits (therefore not R2), and unfortunately, still the same error.

    I also forgot to mention on my previous post that the Email Router server is part of the PrivateUserGroup.
    Tuesday, December 8, 2009 4:16 AM
  • Where ever you have a login to a service or other feature, use a Domain Admin for the login not Local Service or any other login.  I think there are at least 4 places where a login is used, Incoming Profile, Outgoing Profile, Deployment, and E-mail Router Service.  There might be a few more but if you don't find any additional try those 4 places.  Ensure the account is a Domain Admin account and not just a local Admin. 

    If the e-mail router installed without error, the above should work.

    You can also have a look at this post and see if anything is relevant to your environment.


    and this one


    Best Regards, Donna
    • Marked as answer by Jim Glass Jr Tuesday, December 8, 2009 8:13 PM
    Tuesday, December 8, 2009 1:25 PM
  • Hi Guys,

    I finally found the solution to this problem...

    The orignal installation of CRM was done with the default settings (which mean it got installed on IIS on port 5555), but I later on decided to change this setting to port 80.
    Obviously the way I changed this (only in the IIS bindings) was wrong as my issue is resolved if I revert the IIS binding back to port 5555.

    Glad it's been fixed though!

    Thank you for your assistance as your help and suggestions pointed me in the right directions.

    • Proposed as answer by aecardeg Monday, August 16, 2010 8:39 PM
    Monday, December 14, 2009 8:54 AM