none
Hyperthreading RRS feed

  • Question

  • When submitting a job to Windows HPC pack 2016 with update 2, Windows HPC is allocating resources to compute node as if hyperthreading is turned on as well as including the submit node as a resource.  I have confirmed that the head and compute nodes have hyperthreading disabled and from the “Resource Management” section of Windows HPC, it displays the expected number of cores.  Also, the head node is showing offline in HPC to denote it cannot receive jobs.

    The two issues I'm looking to resolve are these:

    1. Do not allow the submit node to be part of the resources available for jobs. 
    2. Windows HPC pack 2016 to not allocate resources as if hyperthreading is enabled to resources.

    Anyone know how to fix this?

    Wednesday, April 10, 2019 5:30 PM

All replies

  • 1. From the scheduler side, we won't know whether it is real core or hyper core. Admin even can over subscribe or under subscribe the core number for a node (Thus running more tasks or less tasks on the target node). It would be admin's duty not to bring the node online if it is configured not right (For example, hyper core is enabled). Admin can write simple diagnostics test (Adding to the diag tests in HPC Pack) and run those tests before bring the nodes online, including application check, env check. Etc



    Qiufang Shi

    Thursday, April 18, 2019 10:08 AM
  • Hello,

    The issue was resolved by switching node template from the current one, to a different one then back.  This older forum post provided this answer:

    "More tasks being allocated to a compute node than the number of cores available"

    I do have some questions about this:

    1.  Switching node templates caused the compute node to redeploy, is there another method to update hyperthreading in hpc pack?  The compute nodes were originally deployed with hyper threading and then we disabled it.  In hpc pack one menu was showing it displayed as disabled but when submitting jobs, it was showing as enabled.

    2.  Is this fixed in a different version of HPC pack, we are using 2016 and this forum post is from 2011?

    Thursday, May 2, 2019 3:48 PM
  • Taking the node offline and then bringing it online shall also work.

    The CPU core number change (disabling hyper threading reduced the logic core number) can be applied only when the node is in offline state.

    Monday, May 6, 2019 2:06 AM