locked
CRM 2013. Error accurred while fetching the list of data extensions installed on the report server. RRS feed

  • Question

  • Hi,

    After a clean install of CRM server 2013 in full server mode, we get this error when running a report.

    Webclient: Error accurred while fetching the list of data extensions installed on the report server.

    The windows application log: http://crm/reportserver/reportservice2005.asmx The request failed with the status 401: unauthorized. W3wp c:\programfiles\microsoft dynamics crm\crmweb\

    Reporting Extension are installed on the sql server.

    The sql server and report server have separate domain serviceaccounts. De CRM services use network service.

    Any help is much appreciated!

    Thanks,

    Jan

     
    • Edited by Nauta Friday, June 20, 2014 2:54 PM
    Wednesday, June 11, 2014 2:44 PM

Answers

  • Hi,

    

    We solved the problem:

    

    The rights for the serviceaccount of the application service were manually set:
    The settings are:
    CRMreaderole, publice and DB_owner for the MSCRM_config and ORG_MSCRM.
    Account is added to the privusergroup and has “log on as a service” rights.

    Regards,

    Jan

    • Marked as answer by Nauta Monday, August 11, 2014 2:05 PM
    Monday, August 11, 2014 2:04 PM

All replies

  • Hi,

    The Reporting Extensions need to be installed in server which has SQL Reporting Services installed and the account which is configured to run the SSRS should has permissions on SQL server.

    If the SSRS are running under Network Service, Please add the computer account in SQL Server. Try reinstalling Reporting Extensions.


    Manoj Batchu

    Thursday, June 12, 2014 11:58 AM
  • Hi,

    Thank you for your reply and we will check these settings.

    I will let you know.

    Regards,

    Jan

    Monday, June 16, 2014 9:05 AM
  • Hi,

    The SSRS has permissions on SQL server and we reinstalled the Reproting Extensions. We still get the error when running a report.

    Regards,

    Jan

    Friday, June 20, 2014 8:13 AM
  • Hi Jan,

    Can you please post the complete error message logged in CRM WEB Server Event Log.


    Manoj Batchu

    Friday, June 20, 2014 1:38 PM
  • Hi Manoj,

    Sorry for the late response. I will have to come back to you later with the event log.

    Kind regards,

    Jan 

    Thursday, July 3, 2014 8:22 AM
  • Hi,

    

    We solved the problem:

    

    The rights for the serviceaccount of the application service were manually set:
    The settings are:
    CRMreaderole, publice and DB_owner for the MSCRM_config and ORG_MSCRM.
    Account is added to the privusergroup and has “log on as a service” rights.

    Regards,

    Jan

    • Marked as answer by Nauta Monday, August 11, 2014 2:05 PM
    Monday, August 11, 2014 2:04 PM