locked
Installing Home Server Connector Failed...Installing Windows Home Server Failed. Device is not connected. RRS feed

  • Question

  • Hello, I have ben trying to upgrade from evaluation copy of WHS to the OEM version.  Everything worked quite well under eval copy, but I am stuck in a loop of failed installs with the OEM.  Oddly, the system keeps identifying a 3com network card that does not exist in the machine.  I had to buy a Dlink card that was listed on the HCL to get the eval copy to work, but that was the only obstacle I ran into.  The install is finalizing installation when it fails each time.  The resulting 'partial install' seems largely functional, but the failed instlal message persists.  Please help.  Below is the interesting end of my setup log file. 
    [3/24/2009 12:09:30 AM  c58] Progress: 60%
    [3/24/2009 12:09:30 AM  c58] Package umwhsarch already installed.
    [3/24/2009 12:09:30 AM  c58] Progress: 65%
    [3/24/2009 12:09:30 AM  c58] Package umddns already installed.
    [3/24/2009 12:09:30 AM  c58] Progress: 70%
    [3/24/2009 12:09:30 AM  c58] Package umpf already installed.
    [3/24/2009 12:09:30 AM  c58] Progress: 80%
    [3/24/2009 12:09:30 AM  c58] Progress: 80%
    [3/24/2009 12:09:30 AM  c58] Progress: 82%
    [3/24/2009 12:09:31 AM  c58] Creating directory
    D:\shares\Software\Home Server Connector Software
    [3/24/2009 12:09:31 AM  c58] ERROR: Failed to copy
    c:\WHS\WHSConnector.msi to D:\shares\Software\Home Server Connector
    Software\WHSConnector.msi (0x8007048f)
    [TRACE] PublishFiles : Exited (0x8007048f)
    [TRACE] Step_InstallQ : Exited (0x8007048f)
    [3/24/2009 12:09:31 AM  c58] Installing Windows Home Server failed.
    Error 0x8007048f.
    [TRACE] Looking for template _:\qs.ini
    [TRACE] Checked file C:\qs.ini, error 2
    [TRACE] Checked file D:\qs.ini, error 2
    [TRACE] Checked file X:\qs.ini, error 21
    [TRACE] Template _:\qs.ini NOT FOUND!
    [TRACE] FindOnMedia : Exited (0x80070002)
    [TRACE] FindSetupFile : Exited (0x80070002)
    [3/24/2009 12:09:31 AM  c58] MessageBox: Installing Windows Home
    Server failed: The device is not connected.

     (error code 0x8007048f).
    [3/24/2009 6:56:50 PM  c58] Windows Home Server setup failed. The
    error code is 0x8007048f. Please correct the problem and reboot to
    restart the setup program.
    [TRACE] Looking for template _:\qs.ini
    [TRACE] Checked file C:\qs.ini, error 2
    [TRACE] Checked file D:\qs.ini, error 2
    [TRACE] Checked file X:\qs.ini, error 21
    [TRACE] Template _:\qs.ini NOT FOUND!
    [TRACE] FindOnMedia : Exited (0x80070002)
    [TRACE] FindSetupFile : Exited (0x80070002)
    [3/24/2009 6:56:50 PM  c58] MessageBox: Windows Home Server
    installation failed. Do you want to view the installation log file?
    [3/24/2009 6:56:58 PM  c58] Spawning process [notepad.exe
    "C:\Documents and Settings\All Users\Application
    Data\Microsoft\Windows Home Server\logs\q_setup.log"]
    Wednesday, March 25, 2009 9:33 PM

All replies

  • Can you try another DVD drive?
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, March 25, 2009 10:18 PM
    Moderator
  • Hi Ken,
    I've got an external USB DVDRW on hand.  I'll give that a shot this weekend. System is USB 1.0, so it may take a while. The current internal DVD drive worked fine with the evaluation copy.  Can we assume it should work with OEM too, or is that just silly.  I'm guessing you are just trying to suggest some basic troubleshooting so simple problems can be rules out.
    Friday, March 27, 2009 8:03 PM
  • Well the external USB DVDRW failed to be useful.  Bios on ASUS A7V Mobo won't allow for booting from a USB device. I don't have another ATA DVD rom on hand, and am a bit tired of spending cash on this old box.  With the amount o ftime I've spent onthis so far, I might as well have startewd with a linux distro.

    I am about ready to return the darn WHS software.  I've spent about 200 bucks on software and new HD's for this old box and am looking at further expenses as the price of ATA drives rise.  I can't beleive the install process could be this messy when I already tested with the Eval copy.  I mean I thought htis was the whole point of an eval copy/  I've wasted enough time I should have just bought an HP media smart box with WHS preinstalled.

    The only hardware change that has taken place between eval copy and OEM copy was that a data drive seems to be failing.  But lose of one drive should not bring the system to it's knees. Right? 

    I was considering fdisking all drives (backups and data too) and starting from scratch.  Does anyone think there's much of  a point? Given the cryptic error log, I am not sure where to go next...expect to the UPS store to return the software.
    Monday, March 30, 2009 9:04 PM