locked
can't get remote access, d-link dir-655 RRS feed

  • Question

  • I have yet to get remote access working so I'm not sure what else to do.  Here's what I can tell you so far...

    When I configure the router in remote access settings all things check except the last two; 'Verifying that your router is accepting web site connections' and 'Verifying that your router is accepting remote access connections'.

    I have tried to forward the ports on my router, although I'm not 100% sure I've done this right.  Here is a screen shot for that:

    http://i49.photobucket.com/albums/f271/misajay/portforward-1.jpg

    Are there any other tips or tricks that I am missing here?  I have also tried to set up remote access without port forwarding to no avail.  Any help is greatly appreciated and I will gladly give more information if needed.

    Thanks!
    Friday, October 3, 2008 6:27 PM

Answers

  • misajay said:

    Alright, so I've had one heck of a time working on this but I really appreciate all your tips.  Here's what I've done so far:

    I tried to set up the 2Wire 2701HG-B into bridge mode using these directions (the ones suggested above) http://support.2wire.com/?page=view&article=22&text=bridge&cat=&sort

    Once I did this I could not connect to the internet/network at all.  I could not even get back into the 2Wire management by entering the IP in my browser (not sure why).  I did hard resets and retried several times with the same results.

    My thought is I'm missing one step somewhere messing everything up, or I need to change something (after putting the 2Wire into bridge mode) on my DIR-655.  Not sure what, played around with some things but I'm not a pro at this.

    Sorry for being new at this and I appreciate all the help.  Thanks again!


    This is why I didn't recommend setting the 2Wire in bridge mode. You had working setup, probably all you needed to was forward appropriate ports as I suggested before. IMHO you shouldn't mess around with basic network setup unless you really understand what you're doing.

    I didn't post this concern since there were a number of people all advising to use bridge mode and because setting one of the two devices in bridge mode is likely to resolve your original problem. 

    I'm not familiar with DIR-655, however I expect the DIR-655 WAN setup or some security setting is bugging you right now. If you can't find out what the problem is your best option is probably to setup the 2Wire as  it was before. In that case I hope you choose to save the settings of the 2Wire before you changed into bridge mode.

    If not you will probably have some work to do setting it up properly. To connect to the 2Wire best use a direct cable connection from a client PC to the 2Wire. You will then probably need to set manual IP address (temporarily) on that client as per instructions in the 2Wire support link in your post. If nothing works you may need to do a factory reset and reconfigure the 2Wire as per suppliers instructions. 

     
    [EDIT] Probably you need to set the DIR-655 WAN IP address to static, using the gateway address of the 2Wire[/edit]

    • Edited by brubberModerator Thursday, October 9, 2008 4:04 AM edit
    • Marked as answer by misajay Thursday, October 9, 2008 4:15 PM
    • Marked as answer by misajay Thursday, October 9, 2008 4:15 PM
    • Marked as answer by misajay Thursday, October 9, 2008 4:15 PM
    Thursday, October 9, 2008 3:57 AM
    Moderator

All replies

  • Actually, one other thing I should mention is that I am using a modem/wireless router as my modem only - connected to the dir-655.  I did this by connecting them via ethernet and disabling the wireless on the modem/wireless router.  The model number of the modem/wireless router is the 2 Wire 2701HG-B.  Thanks again!
    Friday, October 3, 2008 6:34 PM
  • misajay said:

    Actually, one other thing I should mention is that I am using a modem/wireless router as my modem only - connected to the dir-655.  I did this by connecting them via ethernet and disabling the wireless on the modem/wireless router.  The model number of the modem/wireless router is the 2 Wire 2701HG-B.  Thanks again!


    You may also need to forward the appropriate ports in your modem to the WAN address of your router. In your router you then need to forward the appropriate ports to your WHS.

    Also please note that in some cases you may get some error or warning messages when setting up  / testing remote access from the WHS console, even though things are setup correctly and remote acces is working fine. The best way to test remote access setup is from outside your LAN (friends / family).
    Friday, October 3, 2008 7:11 PM
    Moderator
  • Did you also set the 2Wire to Bridge mode?
    Simply disabling the wireless won't disable the routing functions.
    Note, though, before you do this:  you *need* to write down all of your connection settings in the gateway, so that you can enter them into the router.
    Configuring bridge mode:
    http://support.2wire.com/?page=view&article=22&text=bridge&cat=&sort=

    HTH,
    -Chris
    Saturday, October 4, 2008 12:58 AM
  • cuppie said:

    Did you also set the 2Wire to Bridge mode?
    Simply disabling the wireless won't disable the routing functions.
    Note, though, before you do this:  you *need* to write down all of your connection settings in the gateway, so that you can enter them into the router.
    Configuring bridge mode:
    http://support.2wire.com/?page=view&article=22&text=bridge&cat=&sort=

    HTH,


    -Chris



    Why would you set the modem to bridge mode? Simply forwarding the three relevant ports to the router WAN address should be enough.
    Saturday, October 4, 2008 1:25 AM
    Moderator
  • True.  However, there are other things (gaming, VPN, and sometimes IM) that are quite allergic to a double-NAT setup such as that.
    Also, it's a bit more complicated, networking-wise, to properly configure that.  If the chain of subnets (as well as the port-forwarding chain) aren't exactly right, well, things won't work.
    Setting the modem (gateway, in this case) to Bridge mode lets the modem be a modem, the router be a router, and, in the end, greatly simplifies the setup, especially in the long run.
    -Chris
    Saturday, October 4, 2008 1:55 AM
  • I've also had many issues beyond just Windows Home Server with the double NAT setup.  If you are capable of eliminating the double NAT setup, I would recommend doing so.  If you can't change the modem/router to bridge/transperant mode, you can always turn your D-Link into a WAP and forward the 3 ports in your modem/router.
    Windows Home Server Team
    Saturday, October 4, 2008 5:30 PM
    Moderator
  • Okay,  I get what you all are saying and I've played around with things a bit with no luck.  The problem is at my work, so it's not in front of me right now so I will further explore things in a couple days.  I will let you know if the suggestions fix things.  To clarify though - I am forwarding the ports from the modem/router to the dir-655 router - correct?  And then forward the ports on the dir-655 to the WHS.

    Also, is it very likely that if I switch the modem/router with just a simple modem wired to my router - the problem will be solved?  If so, I will seriously consider just buying a simple modem.

    Thanks again!
    Saturday, October 4, 2008 8:00 PM
  • If the router model supports attaching a DSL modem it should be fine. But DSL routers with integrated modems are not much more expensive and usually easier to configure (and one device less to consume power or to troubleshoot).
    Best greetings from Germany
    Olaf
    Saturday, October 4, 2008 9:31 PM
    Moderator
  • I have the dir-655 and i let the WHS do UPNP..  If you are able to I suggest diong what Joel states and trying to disable the NAT in the modem.  Let the DIR-655 handle the port forwarding and security.  Then I can verify that if you just let WHS do upnp, the DIrR-655 will work as intended.  As I have the same router (i like it a lot) let me know if you have any specific questions about it.
    athlon 3400, 2gb ram, 7 drives totaling about 3.15 tbs.
    Sunday, October 5, 2008 2:45 AM
  • Alright, so I've had one heck of a time working on this but I really appreciate all your tips.  Here's what I've done so far:

    I tried to set up the 2Wire 2701HG-B into bridge mode using these directions (the ones suggested above) http://support.2wire.com/?page=view&article=22&text=bridge&cat=&sort

    Once I did this I could not connect to the internet/network at all.  I could not even get back into the 2Wire management by entering the IP in my browser (not sure why).  I did hard resets and retried several times with the same results.

    My thought is I'm missing one step somewhere messing everything up, or I need to change something (after putting the 2Wire into bridge mode) on my DIR-655.  Not sure what, played around with some things but I'm not a pro at this.

    Sorry for being new at this and I appreciate all the help.  Thanks again!
    Wednesday, October 8, 2008 8:47 PM
  •  
    Have you done any sanity tests verifying that you can connect to your home network from outside?  I.e. ping the IP address?  I had an issue where I could not get to my home server using my homeserver.com address but could using my IP address.  This was because my work blocked the homeserver.com (godaddy?) network.
    Wednesday, October 8, 2008 9:17 PM
  • Here's some screen shots that might be helpful to explain what things look like under the hood:

    2Wire Bridge Mode Settings
    http://i49.photobucket.com/albums/f271/misajay/2wire01.jpg

    2Wire Bridge Mode Settings Pt. 2
    http://i49.photobucket.com/albums/f271/misajay/2wire02.jpg

    DIR-655 - Some things I tried to play with on the Dlink
    http://i49.photobucket.com/albums/f271/misajay/dlink01.jpg



    Wednesday, October 8, 2008 9:23 PM
  • @ Lliam - Yep.  I've tried that, no luck.
    Thursday, October 9, 2008 2:11 AM
  • misajay said:

    Alright, so I've had one heck of a time working on this but I really appreciate all your tips.  Here's what I've done so far:

    I tried to set up the 2Wire 2701HG-B into bridge mode using these directions (the ones suggested above) http://support.2wire.com/?page=view&article=22&text=bridge&cat=&sort

    Once I did this I could not connect to the internet/network at all.  I could not even get back into the 2Wire management by entering the IP in my browser (not sure why).  I did hard resets and retried several times with the same results.

    My thought is I'm missing one step somewhere messing everything up, or I need to change something (after putting the 2Wire into bridge mode) on my DIR-655.  Not sure what, played around with some things but I'm not a pro at this.

    Sorry for being new at this and I appreciate all the help.  Thanks again!


    This is why I didn't recommend setting the 2Wire in bridge mode. You had working setup, probably all you needed to was forward appropriate ports as I suggested before. IMHO you shouldn't mess around with basic network setup unless you really understand what you're doing.

    I didn't post this concern since there were a number of people all advising to use bridge mode and because setting one of the two devices in bridge mode is likely to resolve your original problem. 

    I'm not familiar with DIR-655, however I expect the DIR-655 WAN setup or some security setting is bugging you right now. If you can't find out what the problem is your best option is probably to setup the 2Wire as  it was before. In that case I hope you choose to save the settings of the 2Wire before you changed into bridge mode.

    If not you will probably have some work to do setting it up properly. To connect to the 2Wire best use a direct cable connection from a client PC to the 2Wire. You will then probably need to set manual IP address (temporarily) on that client as per instructions in the 2Wire support link in your post. If nothing works you may need to do a factory reset and reconfigure the 2Wire as per suppliers instructions. 

     
    [EDIT] Probably you need to set the DIR-655 WAN IP address to static, using the gateway address of the 2Wire[/edit]

    • Edited by brubberModerator Thursday, October 9, 2008 4:04 AM edit
    • Marked as answer by misajay Thursday, October 9, 2008 4:15 PM
    • Marked as answer by misajay Thursday, October 9, 2008 4:15 PM
    • Marked as answer by misajay Thursday, October 9, 2008 4:15 PM
    Thursday, October 9, 2008 3:57 AM
    Moderator
  • Success!  @brubber - Thanks.  I did exactly what you said and it is now working with the previous setup.

    Bridge Mode has me intrigued and if I run into firewall issues in the future I may look into this.  However, the original problem is solved.

    Thank you all for your help again!
    Thursday, October 9, 2008 4:17 PM