none
MPI Cluster debugger in MSVS 2010 SP 1: mpishim.exe invocation issue RRS feed

  • Question

  • I am trying to debug an open MPI application in Visual Studio 2010 SP1 using the MPI Cluster debugger. When I launch the application, I get the following error message:

    MPISHIM: Command line incomplete.  USAGE: mpishim100.exe PortNumber ComputerName

    On inspection of the batch file mpishim.bat, which is automatically generated in the built tree by Visual Studio, I can see that this error message is caused by wrong use of quotes. The batch file contains the following command:

    "E:\Apps64\openmpi-1.6\bin\mpiexec.exe" -n 1 -wdir "E:\Users\UserName\Build\mpi-examples\src\Debug\UserName\matvec_row" -np 2 "C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Remote Debugger\x64\mpishim100.exe" 61863 127.0.0.1

    I suspect the last arguments should be within the quotation marks. There is no way for me to fix this, because VS generates the file from scratch every time I start debugging. I have tried to change the mpishim.exe location parameter within the VS project options, hoping that putting it in a path not containing spaces would fix the problem. However, VS seems to ignore the non-default value I enter there, and keeps on referring to the standard location within the VS install directory.

    Friday, September 21, 2012 4:45 PM

All replies

  • Two years forward, and I'm having this problem as well. Has anyone come up with a solution?
    Monday, August 4, 2014 1:37 AM
  • The original issue may have been related to using Open MPI, which isn't a supported configuration for the MPI Cluster Debugger.  Are you also using Open MPI, or are you using MS-MPI?  If the latter, which version?

    Thanks,
    -Fab


    Tuesday, August 26, 2014 4:35 PM