locked
MOPS 2007: File Not Loading but Checked Out RRS feed

  • Question

  • Hello,

    I am working with MOPS 2007 and Project Pro 2007 (both are fully patched).  I have a MPP on the server that is not working.  I can see the file in the "Open" dialogue box and when clicked-on it appears to open normally--except it never opens.  I see the status bar in the lower-left of my Project Pro window indicating that it is loading the file from the server and it even gets checked out on the server.  Resources are able to submit task updates as well; I can also accept these task updates through PWA.

    All of the other files on the server work as expected.  This issue has just started occurring within the last week.  I have tried restoring from the archive database and reloading the file from a locally saved backup.  This worked for a few hours and then the issue happened again.

    My hunch is that the problem is within the file itself but I have no idea what could cause this behavior.

    Any help is much appreciated!

    Monday, December 13, 2010 4:35 PM

Answers

All replies

  • what other changes did you made to the mpp ? and if you have a local copy, could you try reverting those changes and republish it ?

    However there are multiple reasons just one of these which might cause this could be, summary task linkage been done in plan, that causes circular references and logic flow of task becomes complex, which results in unexpected behaviour, hence though it is possible to link but not recommended,

    Hence would suggest check project for such problems and revert those changes and republish,

    if it at all doesn't helps, since you have a local copy,  would suggest revert max changes or if you have the older copy(as much as can be beared), delete the project plan(only plan and not the workspace)  from server, republish the plan and re link the workspace

    Hope this helps    


    Thanks | Sunil Kr Singh | http://epmxperts.wordpress.com
    Monday, December 13, 2010 6:07 PM
  • Hi Sunil,

    I verified that I don't have any tasks with links.  I went ahead and tried to load another version of the local copy to the server and it imported correctly, but when I try to open it from the server i get the following error:

    "An unexpected error occurred during command execution.

    Try the following:

    • Verify that all argument names and values are correct and are of the correct type.
    • You may have run out of memory. to free up available memory, close programs, projects, or windows that you aren't using."

    I am fairly certain that the second suggestion is meaningless but do not exactly know what arguments are referred to in the first suggestion.  I would guess that the arguments refer to what you asked about above.

    We don't use project workspaces so I didn't have to link the new file again.

    Any other thoughts or ideas?  Thanks!

    Monday, December 13, 2010 7:50 PM
  • Hi Bryan,

    By any chance do you have project 2010 and 2007 both installed on machine, have seen errors in such cases, and gets resolved once you uninstall 2010 ? Just checking incase 

    and how large is the plan size? Do you try to save it in Old format tools >> option >> save >> 2000-2003 format ?

    to me seems like a corruption issue, based on the odd behaviour project is going through, usually happens if copy paste from other project is done typically creates duplicate task uid, also have seen in some case corruption has been caused by fragmentation of DB ?

    there isn't any tool which would really suggest if the project is  corrupt just saying based on the abrupt behaviour of project, would suggest to save a fresh copy of project plan, rename and publish, then check if that works fine,

    also you can take a copy and test it in dev environment just to check if the plan works fine there 


    Thanks | Sunil Kr Singh | http://epmxperts.wordpress.com
    Monday, December 13, 2010 7:57 PM
  • The MPP file is 3 MB.  I do have Project 2010 installed along with 2007 but I experienced the same issue on both a WinXP and Win7 PC with only Project 2007 installed on them.
    Monday, December 13, 2010 8:28 PM
  • Additionally I am able to view the data from the corrupt file in the OLAP cubes.  Not sure if this helps or not...
    Monday, December 13, 2010 9:06 PM
  • Could you check the event log, if any error is there like sql timeout exception, also could you check uls log on server for any errors reported?
    Thanks | Sunil Kr Singh | http://epmxperts.wordpress.com
    Monday, December 13, 2010 9:09 PM
  • This is the error message from the log:

     

    Event Type:        Error

    Event Source:    Office SharePoint Server

    Event Category:                Project Server Queue

    Event ID:              7704

    Date:                     12/9/2010

    Time:                     8:26:11 AM

    User:                     N/A

    Computer:

    Description:

    Standard Information:PSI Entry Point:

    Project User:

    Correlation Id: cf159277-c5f8-411e-96b2-a254ba7c932e

    PWA Site URL: 

    SSP Name: SharedServices1

    PSError: GeneralQueueJobFailed (26000)

    A queue job has failed. This is a general error logged by the Project Server Queue everytime a job fails - for effective troubleshooting use this error message with other more specific error messages (if any), the Operations guide (which documents more details about queued jobs) and the trace log (which could provide more detailed context). More information about the failed job follows. GUID of the failed job: 4f901205-eceb-4acc-afb9-2114d88291b2. Name of the computer that processed this job:         (to debug further, you need to look at the trace log from this computer). Failed job type: ProjectCheckIn. Failed sub-job type: FailIfNotCheckedOutMessage. Failed sub-job ID: 2. Stage where sub-job failed:  (this is useful when one sub-job has more than one logical processing stages).

     

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp .

    I didn't see anything in the queue that failed.  This error has happened several times in the last week and I would assume is the cause of the issues I am experiencing.

     

    Monday, December 13, 2010 9:30 PM
  • also could you check the central admin ULS logs for any error, along with that also check the client machine event log for any error, more imp would be ULS log as it would give the exact reason for queue error
    also there is an ULS Log viewer tool available on codeplex which would help in examining the log files
    Thanks | Sunil Kr Singh | http://epmxperts.wordpress.com
    Monday, December 13, 2010 9:43 PM
  • Here is the error from the local machine:

    "ID: 9, Application Name: Microsoft Office Project, Application Version: 12.0.6423.1000, Microsoft Office Version: 12.0.6425.1000. This session lasted 1550 seconds with 300 seconds of active time.  This session ended with a crash."

    I am not sure where to get the Central Admin files you are referring to.  Would they be in the file path specified in the Central Administration>Operations>Diagnostic Logging page (C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\LOGS\)?

    Monday, December 13, 2010 10:15 PM
  • Yes that would be the place "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\LOGS" where you would find the ULS log
    Thanks | Sunil Kr Singh | http://epmxperts.wordpress.com
    Tuesday, December 14, 2010 6:03 AM
  • I can't get the log to file to upload here.  What is the best way to get it up here?
    Tuesday, December 14, 2010 6:19 PM
  • You would need to enable the logging via CA for project server events

    CA >> Operations >> Diagnostic Logging >> Under Section Event Throttling >> Select category >> Select project Server Events you want to get log enabled for >> Select least Critical Event to report as Error >> verbose >> Save , It will start logging events

    now perform the same operation in which you are having error(In your case File Not Opening), and the error will be logged

    Now from the Log file we can trace where the error lies ?

    However have you tried to open the same file from other machines, also just wanted to be sure this is not a master project? 


    Thanks | Sunil Kr Singh | http://epmxperts.wordpress.com
    Wednesday, December 15, 2010 6:16 AM
  • I actually have the logs.  I just don't know how to upload them into the forum here...

    I actually have tried opening the file from several other machines and I witness the same thing happen.

    Wednesday, December 15, 2010 3:35 PM
  • Okay, to be honest seems case of file corruption,  You don't need to upload the files instead, download ULS Log viewer tool From Codeplex http://ulsviewer.codeplex.com/ and check for Level Error, and just share the error messages into the forum :)
    Thanks | Sunil Kr Singh | http://epmxperts.wordpress.com
    Wednesday, December 15, 2010 3:57 PM
  • From the log file I used after recreating the error.  All of the High level errors are for the w3mp.exe process.  Some of the Medium level errors:

    PWA:http://COMPUTER/PWA, SSP:SharedServices1, User:DOM\UserName, PSI: WinProj.ReadProjectCoreData [T:0fba8203-8798-4296-8828-54b0676dda4f][U:cc3a63bb-425e-417b-a9bb-5da5dc141854][S:06b133d9-6c4b-45d3-b043-7bd9579a44fa][D:2UA9380J08\Bryan Campbell][J:00000000-0000-0000-0000-000000000000][PS_AC][2] Data rows written: 10 for container LookupTable
    PWA:http://COMPUTER/PWA, SSP:SharedServices1, User:DOM\UserName, PSI: WinProj.ReadProjectCoreData [T:0fba8203-8798-4296-8828-54b0676dda4f][U:cc3a63bb-425e-417b-a9bb-5da5dc141854][S:06b133d9-6c4b-45d3-b043-7bd9579a44fa][D:2UA9380J08\Bryan Campbell][J:00000000-0000-0000-0000-000000000000][PS_AC][6] Exit ReadProjectCoreData(5ed04e37-5d22-4d07-94f8-2df8e63fe501, 2, 1, 12, 1033, 06b133d9-6c4b-45d3-b043-7bd9579a44fa, 2UA9380J08\Bryan Campbell, True)
    Not sure what exactly I am looking for.  Maybe you could point me to a process?

     

    Wednesday, December 15, 2010 5:12 PM
  • Bryan:

    Try saving the project as an XML file, then open it again in Project and import it back to the server. This should resolve any binary record corruption, which I believe is the problem here.


    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG
    Wednesday, December 15, 2010 9:32 PM
  • Hi Gary,

    I would love to try this but my local copy is now corrupted and won't open.  I have a call with Microsoft to figure this out later this afternoon as I need to get this resolved.

    I'll let you know what happens...

    Thursday, December 16, 2010 9:04 PM
  • Sorry for the delay in my posts--I resolved the problem and then went on vacation.  We were able to reopen the file in Project 2003 and then resave it.  I guess issues arise when the file was created in older versions of Project (as this file was).

    I now have an Excel file with the information in it should something happen again.  thanks you for all of your help Gary and Sunil!

    Tuesday, December 28, 2010 3:48 PM