CRM workflow bug? Workflow paused due to error: Unhandled Exception:System.Web.Services.Protocols.SoapException: RRS feed

  • Question

  • <!-- [if gte mso 10]> <mce:style>

    After we updated to Rollup 14, one server had problem with one workflow. We have 3 almost same CRM server groups for deferent level test (only end user input data is different). The first two have no problem.  But the last one got error (see details as following). Then I unpublish the workflow and republish again, it works fine.

    I got errors from AsyncOperationBase, which show workflow cannot create entity because of privilege problem. Why it can get required privilege after I republished the workflow without changing any other thing? This error also happened few times before, but we didn't republish the workflow at that time, only manually solved the problem for each case. Why sometimes it worked, but sometimes not, if it is privilege problem?

    Error sample:

    Workflow paused due to error: Unhandled Exception:
     Server was unable to process request.
     <detail><error>   <code>0x80040220</code>   <description>
    SecLib::CrmCheckPrivilege failed. Returned hr = -2147220960 on
     UserId: abde5a56-40b5-fd11-b8e3-500556819094
     and PrivilegeId: 8b87a7c6-f512-8480-a135c-f29ad46a70c
    </description>   <type>Platform</type>
         at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
         at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
         at Microsoft.Crm.SdkTypeProxy.CrmService.Create(BusinessEntity entity)
         at Microsoft.Crm.Asynchronous.SdkTypeProxyCrmServiceWrapper.Create(BusinessEntity entity)
         at Microsoft.Crm.Workflow.Services.CreateActivityService.Execute(ActivityExecutionContext executionContext, CreateActivity createActivity)
         at Microsoft.Crm.Workflow.Activities.CreateActivity.Execute(ActivityExecutionContext executionContext)
         at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(T activity, ActivityExecutionContext executionContext)
         at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(Activity activity, ActivityExecutionContext executionContext)
         at System.Workflow.ComponentModel.ActivityExecutorOperation.Run(IWorkflowCoreRuntime workflowCoreRuntime)
         at System.Workflow.Runtime.Scheduler.Run()

    Tuesday, March 8, 2011 3:37 PM

All replies

  • check out following article,  http://mayankp.wordpress.com/2010/10/13/crm-4-0-security-privileges/

    this provides query to find out which Privilege is missing, please let us know which previlegde is missine and that should give a way forward to resolve the issue



    My Blog
    Follow Me on Twitter
    Tuesday, March 8, 2011 5:05 PM
  • I run the query, and found the Privilege. I don't think it is real privilege missing problem. Why after I republished the workflow, it works fine?
    Thursday, March 10, 2011 3:40 PM
  • Hi Sunny,

    Which Privilege is this?

    My Blog
    Follow Me on Twitter
    Monday, March 14, 2011 3:14 PM
  • Hi Sunny,

    Which Privilege is this?

    My Blog
    Follow Me on Twitter
    According  ID and source code in IE, I found the privilege is to Create "Case Audit" - one of our Custom Entities. Our system change Incident owner to same user with system admin role by plug-in, then change status code. A workflow will be invoke if the status is "complete" to create new record of "Case Audit" and do other things. But the workflow can not be invoked occasionally and now we found if the workflow was re-published, it would be OK.
    Monday, March 14, 2011 6:57 PM