locked
Urgent help needed in records update!! RRS feed

  • Question

  • Hi,

    I am using CRM 2011.

    I exported around 16870 Accounts to a static worksheet and ticked 'Make this data available for re-importing' in order because I just want to update the records; there are no new records.

    When I tried to import, I got the error concerning the file being too large.I split the file in many files and did the update.
    Now I'm facing a HUGE problem! :S

    When I did the update of the first batch, containing 2800 records, I noticed that these records were updated but ALL the others were updated with empty values due to that I deleted the records from the Excel sheet. I tried to fix it by updating a second batch, thinking that in this way I will 'refill' them, it didn't, saying that the records have been changed after the export have been done.

    So now I'm left with Accounts with empty 'Account names' and all the attributes which are in the excel sheet became empty, this in all the records except the first batch.

    It's REALLY urgent that I fix this!!!

    I have the initial export file with all the records. Any help will be appreciated!



    • Edited by ms_crm Wednesday, March 14, 2012 9:56 AM More info
    Wednesday, March 14, 2012 8:32 AM

All replies

  • have you tried searching for inactive accounts with a date of modified on the date you did the import.

    hopefully all you accounts have been made inactive rather than deleted.

    If they are inactive then you can make them active again using either a bulk edit or an export and import by including the status and changing it in excel.


    Ben Hosking
    Check out my CRM Blog
    Linked-In Profile
    Follow Me on Twitter!

    Wednesday, March 14, 2012 10:10 AM
  • They didn't get deactivated.

    In the initial import file, I deleted the values inside the records in order to split it, not the whole records so the CRM records got updated with empty values.

    Now what I need is to do a rollback for my import.

    How is that possible?

    Wednesday, March 14, 2012 10:22 AM
  • You may be able to roll back the changes by going to imports, select the imported file 

    then on the delete button is a drop down with the option - All records import to this entity during this import.

    but I'm not entirely sure what it will do, it would hopefully roll back the changes made during the import.

    What you could do is export the list of accounts you export last time.  Sort the file in the same way as the previous export then you should be able to copy the account names back into the file.  You would need some way to work out you have got the files in the same order.  Basically you need to merge the files together using excel and copy and paste.  You should have this information because the account guid should be hidden on the left hand side of the excel files, you just need to unhide them and use that to sort them.


    Ben Hosking
    Check out my CRM Blog
    Linked-In Profile
    Follow Me on Twitter!

    Wednesday, March 14, 2012 3:12 PM
  • The maximum file size for importing records into CRM is 8MB. So if your XML file containing your records for re-import is larger than this you can try zipping it. If the zip file is larger than 8MB then you'll need to try splitting it again.

    But, as you have already discovered, splitting the file takes some care. The XML file that you're working with in Excel contains hidden columns that contain things like the GUID of the records in the file. If you delete some cells but don't delete the entire row then your file will still contain the hidden values and update the data to null values. That's how you got into a bad place.

    So delete the rows entirely when you split your file in Excel and try re-importing it.


    Neil Benson, CRM Addict and MVP at Customery Ltd. Join me on Twitter. Join over 20,000 other CRM professionals on the Microsoft Dynamics CRM group on LinkedIn.

    Wednesday, March 14, 2012 4:02 PM
    Moderator