locked
Cannot Synchronize AddBook on Vista RRS feed

Answers

  • This is a known issue that is being worked on. The best route to take now is to follow the steps in the FAQ:

    http://forums.microsoft.com/Ocs2007publicbeta/ShowPost.aspx?PostID=1614863&SiteID=57

     

    There are some things that can be checked to possibly resolve some issues.

    • Start Outlook, wait a few minutes and then start Communicator.
    • Check that Outlook is using the default profile.
    • Verify you are using Office Communicator 2007 build 2.6090.0.
    • Verify your Internet Explorer proxy settings are correct for your environment.
    • Try to connect to your Adress Book Server URL's manually. If they are not accessible, then troubleshoot your web services:
      • For example:
        • Try to connect to the URLs from the server.
        • Check for any DNS issues.
        • Check any routing issues.
        • Try resetting IIS.
        • Try restarting the web pages.
    • Verify you are using the same credentials in Outlook as you are in Communicator.
    • Verify your are not using an untrusted certificate in Exchange Server 2007.
    • Delete galcontacts.db located in %userprofile%\Local Settings\Application Data\Microsoft\Communicator On the OCS server open a command prompt. Navigate to <install path>\Server\Core\ and then run ABServer.exe -syncNow
    • In Office Communicator, under Tools>Options,on the bottom part of the Personal tab is the Personal information manager. Verify that the 'Automatically retrieve Out of Office settings from Outlook' and 'Update my status based on calendar data' options have been selected.

    And then if these do not help, please keep checking back on the forums for any other resolutions.

    Monday, June 4, 2007 9:35 PM

All replies

  • FYI: the link you mentioned  below actually solved my address book issue; Myconfig VISTA ENT, OFFICE 2007, LC2007 Client, Outlook integraion & Live Meeting. Good Luck 

     

    http://forums.microsoft.com/Ocs2007publicbeta/ShowPost.aspx?PostID=1501524&SiteID=57&mode=1

     

    Wednesday, May 2, 2007 5:10 PM
  • I am no lucky!

     

    I ll try again, I can browse the directory, but communicator still not working.

     

    Did you try to test your deployment from the exterior ?

     

    I mean outside your office ? or your OCS deploylement lab?

     

    JRNIKKI, can you give me more details about your deployment please ?

    Wednesday, May 2, 2007 5:22 PM
  • Please

     

    Is there somebody who have an idea ?

     

    Friday, May 4, 2007 12:27 PM
  • ++UP++

     

    still have the issue.

    It's wird that it's only apear on Vista .

    Any suggestions ?

    Somebody from Miccrosoft please help, I sincerly need help.

     

    thanks

    Wednesday, May 9, 2007 2:13 PM
  • Hi Serge,

     

    I am able to lis the directory and I can download the files ..dabs and lsabs.

    And it's working perfectly on windows XP my only problem is on Vista I dont understand why vista don't want to download the address book, whereas I can browse to it from an IE 7 webbrowser.

     

    I thinks that it is a missconfiguration on Vista because if the probleme was comming from the server it should not work on XP to.

     

    To add some information, I try to connect from the exterior, so it should try to get the Address book  from

    https://<poolname>/Abs/Ext but apparently he don't want to get it...

    Thursday, May 10, 2007 1:37 PM
  • Rol

     

    If you are connecting exteranally you have to go through a reverse proxy that is describe in the Egde Server Deployment Guide.  Are you having the same issue internally with Vista?  If so you need to take netmon or ethereal trace to see why the client is failing downloading the address book file.  Vista clients receive the same URL that XP clients does then it attempt to download the file using HTTP for internal and HTTPS for external connection. 

     

    Louis H

    Thursday, May 17, 2007 11:04 PM
  • Hi Louis,

     

    I use a reverse proxy as describe in the Edger Server Deployment guide.

    Internally with vista there is no problem, but externaly it's  still not working.

    I tried to use ethereal and I effectively notice an attempt to connect to the server but nothing apend.

    Same condition with XP and he get it.

    An other test: I connect my Vista computeur on the internal network and it get the address book, I supress the Galconta.db, I connect my computeur on an external network the same day the Galconta.db apear again and it seems to work.

    But the day after allways on the external network it's not working again. I should say that I did not rebbot my computer betwin the connection to external network and internal one.

     

    realy wird is n't it

    Monday, May 21, 2007 9:00 AM
  • This is a known issue that is being worked on. The best route to take now is to follow the steps in the FAQ:

    http://forums.microsoft.com/Ocs2007publicbeta/ShowPost.aspx?PostID=1614863&SiteID=57

     

    There are some things that can be checked to possibly resolve some issues.

    • Start Outlook, wait a few minutes and then start Communicator.
    • Check that Outlook is using the default profile.
    • Verify you are using Office Communicator 2007 build 2.6090.0.
    • Verify your Internet Explorer proxy settings are correct for your environment.
    • Try to connect to your Adress Book Server URL's manually. If they are not accessible, then troubleshoot your web services:
      • For example:
        • Try to connect to the URLs from the server.
        • Check for any DNS issues.
        • Check any routing issues.
        • Try resetting IIS.
        • Try restarting the web pages.
    • Verify you are using the same credentials in Outlook as you are in Communicator.
    • Verify your are not using an untrusted certificate in Exchange Server 2007.
    • Delete galcontacts.db located in %userprofile%\Local Settings\Application Data\Microsoft\Communicator On the OCS server open a command prompt. Navigate to <install path>\Server\Core\ and then run ABServer.exe -syncNow
    • In Office Communicator, under Tools>Options,on the bottom part of the Personal tab is the Personal information manager. Verify that the 'Automatically retrieve Out of Office settings from Outlook' and 'Update my status based on calendar data' options have been selected.

    And then if these do not help, please keep checking back on the forums for any other resolutions.

    Monday, June 4, 2007 9:35 PM
  • Rol

     

    I am having the same problem with Vista where the Address book Download will not work but it works on Vista I only need it to work internally as I have no external access.

     

    I noticed you got it working internally could you tell me how you got it working?

     

    Thank you 

    Tuesday, June 19, 2007 5:35 PM
  • After struggling for weeks now to get the addressbook download to work on my Vista client at home I finally have a remedy.

     

    Besides importing the root CA cert in the Local Computer's Trusted Root Certification Authorities list, I also imported the certificate of the published OCS webcomponent into the Local Computer's Trusted People list.

     

    Monday, October 15, 2007 8:08 PM
  •  

    Yeah

     

    Very good, I'am impatient to test this solution.

     

    Thanks to share your experience.

     

    Rol

    Friday, October 19, 2007 2:02 PM
  • Hi Rol!

    I had the same problem and for me the solution was to turn of the "check for server certificate revocation*" in internet explorer. When this setting is turned off my addressbok works without any problems.

     

    Rgrds

    HenrikR

    Monday, October 22, 2007 6:27 AM
  • Thanks I will test those solutions if the problem appened again within Customer Company.

     

    regards,

     

    Roland

     

    Monday, October 22, 2007 8:57 AM