locked
CRM 2011: 'Invalid Argument' error after installing Microsoft Dynamics CRM 2011 Update Rollup 12, 13 and 14 RRS feed

  • Question

  • Hi

    My CRM 2011 Server has UR 6. 

    I have upgraded the server, by installing UR12, 13 and 14 simulatneously and then Restarted the server.

    After installing the UR14, when I browsed the CRM website, I am facing the problem of 'Invalid Arguments'

    

    Anyone, have any idea, how to solve this?


    Regards, Karan Mittal
    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".

    Monday, September 9, 2013 6:28 AM

All replies

  • Can you use 'Download Log File' and post the contents of this please.

    Scott Durow
    Blog www.develop1.net    Follow Me
    Rockstar365
    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Monday, September 9, 2013 7:39 AM
    Answerer
  • Hey Scott,

    Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: System.Xml.XmlException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #899CF20BDetail:

    <OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts">

      <ErrorCode>-2147220970</ErrorCode>

      <ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" />

      <Message>System.Xml.XmlException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #899CF20B</Message>

      <Timestamp>2013-09-06T13:30:14.69575Z</Timestamp>

      <InnerFault>

        <ErrorCode>-2147220989</ErrorCode>

        <ErrorDetails xmlns:d3p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" />

        <Message>Encountered user '5d6da17d-d10b-e311-9c2a-005056aa0023' that does not belong to any teams</Message>

        <Timestamp>2013-09-06T13:30:14.69575Z</Timestamp>

        <InnerFault i:nil="true" />

        <TraceText i:nil="true" />

      </InnerFault>

     <TraceText i:nil="true" />

    </OrganizationServiceFault>



    Regards, Karan Mittal
    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".

    Monday, September 9, 2013 7:59 AM
  • Hi,

    Ok - can you now go into the Event Log on the CRM Server and search for #899CF20B then post the error message that is associated with this.

    Thanks!


    Scott Durow
    Blog www.develop1.net    Follow Me
    Rockstar365
    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Monday, September 9, 2013 8:05 AM
    Answerer
  • Not able to find anything in Event logs related to what you specified. :(

    Regards, Karan Mittal
    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".

    Monday, September 9, 2013 8:49 AM
  • You could try using the CrmDiagTool to capture the error then instead - http://crmdiagtool2011.codeplex.com/


    Scott Durow
    Blog www.develop1.net    Follow Me
    Rockstar365
    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Monday, September 9, 2013 8:59 AM
    Answerer
  • Hi Scott,

    I have uninstalled the UR 14 from the CRM server, and error vanishes.

    CRM is working fine, after uninstalling UR 14. 


    Regards, Karan Mittal
    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".

    Monday, September 9, 2013 9:01 AM
  • Similar problem here after installing UR14 (we were previously on UR13).

    Seems about 40-50% of users are receiving this error when clicking on "Accounts" in the sitemap.

    CRM error:

    System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: System.Xml.XmlException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #47619DF0Detail: 
    <OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts">
      <ErrorCode>-2147220970</ErrorCode>
      <ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" />
      <Message>System.Xml.XmlException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #47619DF0</Message>
      <Timestamp>2013-10-04T21:40:58.4627318Z</Timestamp>
      <InnerFault>
        <ErrorCode>-2147220989</ErrorCode>
        <ErrorDetails xmlns:d3p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" />
        <Message>Encountered user '76a18e1b-8119-e311-83da-005056a01946' that does not belong to any teams</Message>
        <Timestamp>2013-10-04T21:40:58.4627318Z</Timestamp>
        <InnerFault i:nil="true" />
        <TraceText i:nil="true" />
      </InnerFault>
      <TraceText i:nil="true" />
    </OrganizationServiceFault>


    Event log:


    Event code: 3005 Event message: An unhandled exception has occurred. Event time: 10/7/2013 8:11:32 AM Event time (UTC): 10/7/2013 3:11:32 PM Event ID: 81f546d60017416daeaad79ff1d790db Event sequence: 45097 Event occurrence: 6 Event detail code: 0 Application information: Application domain: /LM/W3SVC/1/ROOT-1-130255694167836313 Trust level: Full Application Virtual Path: / Application Path: C:\Program Files\Microsoft Dynamics CRM\CRMWeb\ Machine name: CRMSERVER Process information: Process ID: 6368 Process name: w3wp.exe Account name: NT AUTHORITY\NETWORK SERVICE Exception information: Exception type: CrmException Exception message: Encountered user 'a209d9a6-21a0-df11-bb4a-005056a057bf' that does not belong to any teams at Microsoft.Crm.Application.Platform.ServiceCommands.PlatformCommand.XrmExecuteInternal() at Microsoft.Crm.Application.Platform.ServiceCommands.RetrieveMultipleCommand.Execute() at Microsoft.Crm.ApplicationQuery.RetrieveMultipleCommand.RetrieveData() at Microsoft.Crm.ApplicationQuery.ExecuteQuery() at Microsoft.Crm.Application.Platform.Grid.GridDataProviderQueryBuilder.GetData(QueryBuilder queryBuilder) at Microsoft.Crm.Application.Platform.Grid.GridDataProviderQueryBuilder.LoadQueryData() at Microsoft.Crm.Application.Platform.Grid.GridDataProviderQueryBuilder.LoadData() at Microsoft.Crm.Application.Platform.Grid.GridDataProviderBase.PrepareGridData() at Microsoft.Crm.Application.Platform.Grid.GridDataProviderBase.PrepareData() at Microsoft.Crm.Application.Controls.GridUIProvider.Render(HtmlTextWriter output) at Microsoft.Crm.Application.Components.UI.Grid.DataGrid.RenderData(HtmlTextWriter output) at Microsoft.Crm.Application.Components.UI.Grid.DataGrid.RenderInnerHtml(HtmlTextWriter output) at Microsoft.Crm.Application.Components.UI.Grid.DataGrid.Render(HtmlTextWriter output) at System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) at System.Web.UI.HtmlControls.HtmlContainerControl.Render(HtmlTextWriter writer) at System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) at System.Web.UI.HtmlControls.HtmlContainerControl.Render(HtmlTextWriter writer) at System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) at System.Web.UI.HtmlControls.HtmlContainerControl.Render(HtmlTextWriter writer) at System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) at System.Web.UI.HtmlControls.HtmlContainerControl.Render(HtmlTextWriter writer) at System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) at System.Web.UI.HtmlControls.HtmlContainerControl.Render(HtmlTextWriter writer) at System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) at System.Web.UI.HtmlControls.HtmlContainerControl.Render(HtmlTextWriter writer) at System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) at System.Web.UI.HtmlControls.HtmlContainerControl.Render(HtmlTextWriter writer) at Microsoft.Crm.Web.EntityHomepage.Render(HtmlTextWriter writer) at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) Request information: Request URL: http://crmserver/MyOrg/_root/homepage.aspx?etc=1&etn=account&pagemode=iframe&sitemappath=Workplace|Customers|nav_accts&viewid={00000000-0000-0000-00AA-000010001001}&viewtype=1039 Request path: /MyOrg/_root/homepage.aspx User host address: 172.20.30.160 User: MYDOMAIN\CRM_Test Is authenticated: True Authentication Type: Negotiate Thread account name: NT AUTHORITY\NETWORK SERVICE

    *The CRM and event log errors are not from the same error instance, but you get the idea


    • Edited by dubn Monday, October 7, 2013 3:45 PM
    Monday, October 7, 2013 3:43 PM
  • Hi we just experienced this with UR 15.  Is there a resolution for this?

    Linna

    Wednesday, October 9, 2013 10:57 PM
  • I am experiencing the same error, but seem to be able to get around it by finding which user is referenced in the "Exception message: Encountered user '***' that does not belong to any teams" warning and adding them to another team. The user already appears to be part of two teams - "TeamName" and "TeamName_0". I am not sure if the TeamName_0 existed before the update--I'll need to ask my CRM admins.  

    Matthew

    Thursday, October 10, 2013 6:47 PM
  • Matthew,

    Thank you, that indeed worked!  

    A default team is created when your org is setup and all your users are automatically assigned to it.  I tried adding a security role with no privilege to this team and that also worked.  

    This is not really a viable solution for us as we have a ton of orgs so we are opening a support ticket with Microsoft. thx.


    Linna

    Friday, October 11, 2013 12:06 AM
  • Any update on this issue? We also experience this error. The temporary solution for us was removing the "Owner equals current user's teams" criteria from views.

    Linna, did Microsoft give you any answer?

    Thanks,

    Lilith

    Tuesday, January 7, 2014 8:56 AM
  • Hi Lilith, MS confirmed the bug and are fixing it for UR 16.  We're going to be testing out the preview version, so i will update you to see if that's resolved.

    thx


    Linna

    Tuesday, January 7, 2014 2:20 PM