none
Impersonation security setting while running the WCF service RRS feed

  • Question

  • Hi folks,

    • I have a COM+ service which is wrapped with WCF using COM+ integration .
    • So COM+ service is running as a WCF service
    • When I run the client I am getting the following error:

            "Client token at least needs to have Security Impersonation Level of atleast Impersonation out of process Webhost Activations".

    Please advise how to proceed to resolve this...!!!

    Thanks in advance...

    - VVR

    Thursday, December 30, 2010 1:00 PM

Answers

  • This question would be probably better dealt with in a development forum instead of the Training and Certification one.

    I would suggest two alternative approaches: one would be to lower the securtiy requirement of COM+, and the other would be to increase it in WCF. To decrease security in COM+, use the DCOMCNFG tool, open the Properties for your component, and in the General and Security tabs, change the configuration so that your component doesn't try to identify and impersonate the caller. Or, if you choose to increase security in WCF, add an [OperationContract(ImpersonationOption.Impersonate)] attribute in the service contract for the operation that you are using. This will require some adjustments to the Bindings, so that you use a security configuration that is compatible with this setting, and also some changes to the calling client code so that appropriate credentials are passed to the server.

    Mind you, I have not actually tried out the preceding, this is just some general suggestions about things to try out based on how COM+ and WCF work separately. I have not used both together. As I said before, this Training and Certification forum is probably not the best place to get a well tested and detailed answer for your question. I'd suggest trying out the development forums at MSDN.

     

    Friday, December 31, 2010 9:09 AM