locked
Address book Sync password prompt RRS feed

  • Question

  • We have been using OCS for about a week and everything has been working fine.  For some reason on Tuesday the address book would no longer sync and when OCS starts up it brings up a password prompt.  No matter what username or password we try, it keeps bouncing up until you hit cancel.  At this point the address book wont sync and you cant locate people.

    I've been around quite a few forums and tried several things.  Here's whats been attempted:

    \abserver.exe" -syncnow  - Ran this on the server and it forced the address book to sync but no change on the clientside.
    Deleted the galcontacts on the client machines but it wont download the new address book. 
    I heard that this may be an issue with the Kerberos so i checked the SPN and this registered correctly.
    I have checked the username and permissions in IIS and this is correct.
    The location of the address book and name match the FQDN and the location of the ABS has not been moved.
    I can get rid of the password prompt on the client side if i go to internet options\advanced and untick enable intergrated windows authenication but the address book still wont download or sync.
    Checked proxy settings but no change

    I'm unsure what else i can try? Like i say it was working without any problems and then it stopped.  The only thing that changed on the day was we setup the web access for OCS.  This works fine and it didn't require us to change any settings in OCS.
    Thursday, August 27, 2009 10:24 AM

Answers

  • Fixed


    On the Server where i installed OCS i also installed Communicator Web Access.  I have read online that if you install this on the same server its not supported and that it can break your Address Book.  I removed this from the server but there was no change.  I then ran this command on the OCS server in start run window

    iisreset /noforce

    This command stopped my OCS services in computer managment and also stopped my website.  After i restarted the services the address books started to sync again.  Some people were still getting the password prompt but i went into Internet explorerer on the client machine and then went:

    internet options\advanced and untick enable intergrated windows authenication  This stopped the password prompt and the address book then started to sync on these machines as well
    • Marked as answer by Gary Hyde Friday, August 28, 2009 8:07 AM
    Friday, August 28, 2009 8:07 AM

All replies

  • Have you seen this article?
    http://ucnoevil.blogspot.com/2008/03/address-book-chaos.html

    You can find lots of information on how to troubleshoot your issue
    - Belgian Unified Communications Community : http://www.pro-exchange.be -
    Thursday, August 27, 2009 10:53 AM
  • Fixed


    On the Server where i installed OCS i also installed Communicator Web Access.  I have read online that if you install this on the same server its not supported and that it can break your Address Book.  I removed this from the server but there was no change.  I then ran this command on the OCS server in start run window

    iisreset /noforce

    This command stopped my OCS services in computer managment and also stopped my website.  After i restarted the services the address books started to sync again.  Some people were still getting the password prompt but i went into Internet explorerer on the client machine and then went:

    internet options\advanced and untick enable intergrated windows authenication  This stopped the password prompt and the address book then started to sync on these machines as well
    • Marked as answer by Gary Hyde Friday, August 28, 2009 8:07 AM
    Friday, August 28, 2009 8:07 AM