locked
CRM Email Router - Errors in Event Logs RRS feed

  • Question

  • We currently getting a couple strange errors in the CRM Email Router Server(Intermittent email sends)

    #9628 - An error occurred while delivering the e-mail message with subject "Update - RE: CRM auto generated email notifications are currently down." in mailbox KGrudeinski@CRMURL for delivery to https://CRMURL/ORGName. System.ServiceModel.FaultException`1[Microsoft.Xrm.Sdk.OrganizationServiceFault]: Principal user (Id=af6e33XX-faXX-e3XX-87XX-5ef3fcddf8XX, type=8) is missing prvReadQueue privilege (Id=b140e7XX-dfXX-4bXX-a3XX-39ff830bacXX) (Fault Detail is equal to Microsoft.Xrm.Sdk.OrganizationServiceFault).

    #9628 - An error occurred while delivering the e-mail message with subject "RE: ***CRM REBOOT*** - CRM autogenerated email notifications are currently down." in mailbox NEnglish@CRMURL for delivery to https://CRMURL/OrgName. System.ServiceModel.FaultException`1[Microsoft.Xrm.Sdk.OrganizationServiceFault]: queue With Id = 00000000-0000-0000-0000-000000000000 Does Not Exist (Fault Detail is equal to Microsoft.Xrm.Sdk.OrganizationServiceFault).

    Any help in this regard, would really be appreciated.

    Thursday, May 7, 2015 8:17 PM

All replies

  • do a query in SQL on the systemuser table for systemuserid = af6e33XX-faXX-e3XX-87XX-5ef3fcddf8XX to see what user it is.  Then check the user record in CRM and look at the security role(s) assigned.  Is the user missing the read privilege for queues?

    Then check the NEnglish user record.  Are there any issues with his queue?  Was it deleted and recreated?  Try creating a new one and associating it to this user.


    Jason Peterson

    Thursday, May 7, 2015 10:38 PM