locked
Second router or WHS causing Internet to freeze? RRS feed

  • Question

  • I have a Linksys WRT54G3G router which I use to access the Internet - my mobile broadband card is inserted in it. This is then wired to my D-Link DIR-655 router, which has a laptop, Xbox 360, and HP MSS wired to it. So nothing is wired to the Linksys - I only use it to access the Internet.

     

    Very soon I'm getting a phone line installed so I can just use a modem and the D-Link, so the above setup will be obsolete before long, but I have an issue with that setup that has brought me back to the forums again!

     

    I had remote access set up correctly (ports were automatically forwarded) and it always worked great, but every couple days (sometimes less) the Linksys router would freeze and I would lose Internet access, and could only get things working again by unplugging the Linksys, plugging it back in again, then restarting my server - very frustrating.

     

    I'd been in contact with Linksys many times and they couldn't fix it and I'm supposed to RMA the device for a replacement.

     

    Knowing that I'm getting a new setup I just decided to unconfigure remote access and turn the websites feature off, but what's interesting is that since I did that the router has not frozen once, and has been working solidly for a long time, which in the whole two months I had that setup running just never happened.

     

    I'm not that knowledgeable when it comes to networking, but my guess is that there were conflicts between the two routers which is what caused the Linksys to freeze, but what I can't work out is how WHS's remote access function seems to have played a part in causing it to freeze, and now that it's disabled things work smoothly.

     

    Would anyone know what role WHS would play in causing the router to freeze?

     

    I'm just looking forward to having a 'normal' setup of the DSL modem and D-Link router running which will hopefully allow me to unleash remote access without having to worry about freezing routers ever again!

    Saturday, April 19, 2008 7:39 AM

All replies

  • I had a problem like this. I was using Mozilla Firefox to connect remotely. When I got to the home I had to reset the router. The next day used only Internet Explorer- worked fine ever since.
    Sunday, May 4, 2008 3:01 AM
  • To hazard a guess:
    - flaky firmware on one or both routers (have you tried updating it?)
    - UPnP conflict between WHS and D-Link router (assuming that the D-Link is handling all
    routing functions) - try disabling UPnP, and manually forwarding ports (80, 443, 4125) to the WHS (also give the WHS a static IP address when doing this.)
    - Improper setup / subnet chain between the routers (this will be corrected when you change your setup.)

    Given that you're ditching the Linksys router, My best suggestion is to first update the firmware on the DIR. 
    If the DSL modem that you get is a modem/router, make sure that you set it to bridge mode, so that the DIR handles all of the routing functions.

    Sunday, May 4, 2008 7:48 PM
  • Thanks for your replies! This issue is now obsolete as I've ditched this setup and now use a DSL modem set in half-bridge mode, and all routing is handled by the D-Link. It runs flawlessly so I'm happy!

     

    For the record cuppie, I think the problem was the second point you suggested, but anyway it's all sorted now.

     

    Monday, May 5, 2008 6:06 AM