locked
crm 4.0 workflow not working at all RRS feed

  • Question

  •  

    Did a reploy to CRM 4.0 -- I cant get any workflows tro work.  New one/old one etc.  Restarted iis, asy workflow service

     

    Any ideas on this one?

    Tuesday, November 25, 2008 5:52 PM

Answers

  • Is the CRM Asynchronous Process Service running? 
    Monday, December 1, 2008 2:34 PM

All replies

  •  

    If you are using a custom host header please take a look at the following blog:


    "After you get MSCRM 4.0 up and running (install or upgrade) on your system with a custom host header you may find that workflow doesn't work (or flow), imports sit in a submitted state forever, the email router and outlook client cannot connect to the MSCRM server. This could also happen if you change the website details in IIS. What is happening is even though you access your server on a specific URL, internally in the Async service (which handles the workflow, duplicate detection and imports) and the email router and outlook client actually just use the URL you used to connect to the Discovery Service.

    The discovery service is a web service which gives back the real URL to the web services in MSCRM, so if you changed IIS it still gives back the old ones. There is also a bug in the RTM of MSCRM 4.0 which causes it to use the machine name instead of the host header after upgrades. So you go to http://<nice name> and the discovery service gives back to http://<machine name>/mscrmservices/2007/crmservice.asmx which doesn't exist since your host headers should have it as http://<nice name>/mscrmservices/2007/crmservice.asmx

    You can pick this up using fiddler on the email server or desktop machine when trying to configure the email router or outlook client respectively. So I went though this with Microsoft PSS and they came back with a SQL command you can run to fix this." 

    Tuesday, November 25, 2008 7:35 PM
  • looked at that -- nothing wierd in the host headers

     

    any other ideas

    Tuesday, November 25, 2008 8:26 PM
  • Have a look at http://support.microsoft.com/default.aspx/kb/949256 for all CRM 4 updates and hotfixes.
    Tuesday, November 25, 2008 11:54 PM
  • Hi,

     

    Does values in the SQL database match your IIS host header for the CRM Web Site?

     

    'AsyncSdkRootDomain'

     

    'ADSdkRootDomain'

     

    'ADWebApplicationRootDomain'

    Wednesday, November 26, 2008 2:35 PM
  • the iis header isnt set -- its ip address = default port 5555  header value = blank

     

    Wednesday, November 26, 2008 3:08 PM
  • Is the CRM Asynchronous Process Service running? 
    Monday, December 1, 2008 2:34 PM
  • service is running

     

     

     

    Monday, December 1, 2008 2:36 PM
  • have you solved this please provide the solution
    Monday, November 1, 2010 2:41 PM