none
How to set the job template in MPI Cluster Debugger? RRS feed

  • Question

  • Is there any way to configure the MPI Cluster Debugger to use a non-default job template?  I'm using Visual Studio 2010 to debug an MPI application on an HPC 2008 R2 SP3 cluster.  The debugger works great on localhost, but when I try to use the cluster I get a window with the error message "Job template validation failed: The value of property IsExclusive is out of range.  Update the job and try again."  This happens because the debugger wants an exclusive job, but our default template does not allow exclusive jobs.  Exclusive jobs must be submitted using a different template.  I can easily change templates for jobs submitted on the command line (job.exe), but I don't see how to set the template used by the debugger.  I tried setting the CCP_JOBTEMPLATE environment variable but this seems to be ignored by the debugger.  The HPC Job Manager lets me inspect the failed job and it shows that the Debugging Session jobs use the 'Default' template only.
    Tuesday, January 24, 2012 3:15 PM

All replies

  • Hi Tom,

    If you have admin permission, you can modify the "Default" job template by changing the "Exclusive" property to "true".

    To do this, start the HPC Management Console:

    1. In Configuration, in the Navigation Pane, click Job Templates.
    2. In the views pane, double click Default job template

    3. In the popup windows, select Exclusive property

    4. Change the value to "true" and then click Save

     

    For more detailed info, you may refer to: http://technet.microsoft.com/en-us/library/ff919472(WS.10).aspx

    Thanks,

    James

    Saturday, January 28, 2012 11:54 PM
  • I'm not an admin of the cluster.  Besides, wouldn't this change the Default template for all users?  I don't want to do that.
    Sunday, January 29, 2012 12:18 AM