none
hwveri tool is not working with i7-3770 and ASUS P8H67-M PRO RRS feed

  • Question

  • Hi,

    We recently bought new PC for SORA, and installed XP SP3 eng, WINDDK, PCIe driver and hwtest driver.

    (FYI - USRP daughterboard: XCVR2450 rev. 1232)

    After that, I executed hwveri.exe to test send/receive test, but failed.

    According to the below message, I disabled and re-enabled the hwtest driver (+PCIe driver also)

    but of no use.

    Several times of reboot & try also didn't give any change.

    Here is the out messages when I tried sine/send test:

    Load radio configuration from D:\SoraSDK1.6\bin\SavedConfig.ini.
    freqOffset 0
    txgain 0xf00
    rxgain 0x2000
    rxpa 0x1000
    centralFreq 2422
    sampleRate 40
    freqOffsetLineSlope -0.894000
    freqOffsetLineIntercept 0.000000
    SoraUInitUserExtension called
    success
    SoraURadioStart called
    success
    SoraURadioSetFreqOffset called. freqOffset set to 0
    success
    SoraURadioSetTxGain called. txgain set to 0xf00
    success
    SoraURadioSetRxGain called. rxgain set to 0x2000
    success
    SoraURadioSetRxPA called. rxpa set to 0x1000
    success
    SoraURadioSetCentralFreq called. centralFreq set to 2422000
    success
    SoraURadioMapTxSampleBuf called
    success
    SoraURadioTransfer called. SampleSize = 1048576
    Failed. ret = 80050003
    SoraURadioUnmapTxSampleBuf called
    success
    SoraUCleanUserExtension called


    And this is the output of sine/receive test:

    Load radio configuration from D:\SoraSDK1.6\bin\SavedConfig.ini.
    freqOffset 0
    txgain 0xf00
    rxgain 0x2000
    rxpa 0x1000
    centralFreq 2422
    sampleRate 40
    freqOffsetLineSlope -0.894000
    freqOffsetLineIntercept 0.000000
    SoraUInitUserExtension called
    success
    SoraURadioStart called
    success
    SoraURadioSetFreqOffset called. freqOffset set to 0
    success
    SoraURadioSetTxGain called. txgain set to 0xf00
    success
    SoraURadioSetRxGain called. rxgain set to 0x2000
    success
    SoraURadioSetRxPA called. rxpa set to 0x1000
    success
    SoraURadioSetCentralFreq called. centralFreq set to 2422000
    success
    SoraURadioMapRxSampleBuf called
    success
    SoraURadioAllocRxStream called
    success
    Start receiving signal...
    SoraRadioGetRxStreamPos called
    SoraGetStreamVStreamMask called
    SoraCheckSignalBlock called
    SoraCheckSignalBlock timeout.
    Please disable and enable HwTest driver to solve the problem.
    End receiving signal.
    SoraURadioReleaseRxStream called
    SoraURadioUnmapRxSampleBuf called
    success
    SoraUCleanUserExtension called


    SNR/send test:

    Load radio configuration from D:\SoraSDK1.6\bin\SavedConfig.ini.
    freqOffset 0
    txgain 0xf00
    rxgain 0x2000
    rxpa 0x1000
    centralFreq 2422
    sampleRate 40
    freqOffsetLineSlope -0.894000
    freqOffsetLineIntercept 0.000000
    SoraUInitUserExtension called
    success
    SoraURadioStart called
    success
    SoraURadioSetFreqOffset called. freqOffset set to 0
    success
    SoraURadioSetTxGain called. txgain set to 0xf00
    success
    SoraURadioSetRxGain called. rxgain set to 0x2000
    success
    SoraURadioSetRxPA called. rxpa set to 0x1000
    success
    SoraURadioSetCentralFreq called. centralFreq set to 2422000
    success
    SoraURadioMapTxSampleBuf called
    success
    SoraURadioTransfer called. SampleSize = 7424
    Failed. ret = 80050003
    SoraURadioUnmapTxSampleBuf called
    success
    SoraUCleanUserExtension called


    SNR/receive test:

    Load radio configuration from D:\SoraSDK1.6\bin\SavedConfig.ini.
    freqOffset 0
    txgain 0xf00
    rxgain 0x2000
    rxpa 0x1000
    centralFreq 2422
    sampleRate 40
    freqOffsetLineSlope -0.894000
    freqOffsetLineIntercept 0.000000
    SoraUInitUserExtension called
    success
    SoraURadioStart called
    success
    SoraURadioSetFreqOffset called. freqOffset set to 0
    success
    SoraURadioSetTxGain called. txgain set to 0xf00
    success
    SoraURadioSetRxGain called. rxgain set to 0x2000
    success
    SoraURadioSetRxPA called. rxpa set to 0x1000
    success
    SoraURadioSetCentralFreq called. centralFreq set to 2422000
    success
    SoraURadioMapRxSampleBuf called
    success
    SoraURadioAllocRxStream called
    success
    Start receiving signal...
    SoraRadioGetRxStreamPos called
    SoraGetStreamVStreamMask called
    SoraCheckSignalBlock called
    SoraCheckSignalBlock timeout.
    Please disable and enable HwTest driver to solve the problem.
    End receiving signal.
    SoraURadioReleaseRxStream called
    SoraURadioUnmapRxSampleBuf called
    success
    SoraUCleanUserExtension called


    And I don't know what causes this problem.

    It will be very thankful to help me with this.

    Thank you.

    Jihoon Seo



    • Edited by Jihoon Seo Tuesday, October 9, 2012 4:59 AM
    Monday, July 23, 2012 5:20 AM

Answers

All replies

  • Hi Jihoon,

    The information shows the transfer procedure fails. Fortunately, we have just bought this ASUS motherboard. I will try it and back to you soon later.

    -Jiansong

    Thursday, August 2, 2012 7:54 AM
  • Thank you for answering.

    FYI, I first used Intel HD4000 (CPU+Mainboard graphic, so only SORA board is at one of 2 PCI-E slots), but failed.

    Next, we installed Nvidia GeForce 210 at first PCI-E slot and SORA board at second PCI-E slot, but failed too.

    Friday, August 3, 2012 7:10 AM
  • I guess the problem may be on your hardware board, could you check the states of the LEDs?

    You can also get help from Sora hardware OEM vendor.

    -Jiansong


    Friday, August 10, 2012 4:27 AM
  • I took a photo of SORA board.

    https://docs.google.com/open?id=0B_iqvW5XZhkyWVhqcE83RzlSY3M

    In [V5 USER IO] section located in upper-right corner, only [D1] LED is on.

    And, it will be grateful to let me know how to find the contact info of SORA vendor?

    I tried googling but couldn't find it.

    Thank you.

    Tuesday, August 14, 2012 8:33 AM
  • Dear Jihoon,

    Sorry for the late reply because I was in a trip during last two weeks.

    If only D1 is on, the hardware is not in a correct state.

    To reach Sora's heardware vendor, you can email yaoyuan@v3best.com.

    -Jiansong

    Sunday, August 26, 2012 7:44 PM
  • I sent an e-mail to HW vendor thanks to you.

    Thank you!

    Wednesday, August 29, 2012 3:34 AM