locked
German Translations Recently Starting Returning Bad Results RRS feed

  • Question

  • We have been using the Microsoft Translator API for AJAX. Our call to the Translate method is working as expected and is in the correct format, etc. The problem is the English Translation of the German word, 'blut', to 'bleed' instead of 'blood.' If you go to stand alone Bing Translator on the web, the translation comes back as 'blood,' but on the api call, the translation for blut comes back incorrectly. I believe our calls use the default setting of any returned translation and we haven't seen problems with any other words except 'blut.' In addition, this had been working correctly until just a few weeks ago when the calls starting returning incorrect results.
    Tuesday, November 29, 2011 4:01 PM

Answers

  • Hi PM,

    I cannot reproduce the problem. Can you show the Javascript snippet sending it?

    In general you should expect that the translation changes over time. We refresh the engine frequently with new training material and new capabilities. On average the translations get better. That means a few translations can get worse, as much as we don't like to see that happen.

    Chris Wendt
    Microsoft Translator

    Wednesday, November 30, 2011 2:42 AM

All replies

  • Hi PM,

    I cannot reproduce the problem. Can you show the Javascript snippet sending it?

    In general you should expect that the translation changes over time. We refresh the engine frequently with new training material and new capabilities. On average the translations get better. That means a few translations can get worse, as much as we don't like to see that happen.

    Chris Wendt
    Microsoft Translator

    Wednesday, November 30, 2011 2:42 AM
  • I'm also getting different results via SOAP Api compared via bing translator on the web...

    as in:

     "I see..." -> "Ich sehen" (MS Translator) <-> "Ich verstehe..." (Bing)

    and trying to get different available translations results in none beside this one.

    and same via direct http/ajax....the browser shows np, but doin either soap/webrequest via c# i always get the wrong translation :-/
    • Edited by Powers256 Friday, December 23, 2011 12:57 AM
    Thursday, December 22, 2011 9:43 PM