locked
Problem with Automatically expantion of grid in CRM 2011 RRS feed

  • Question

  • Hi,

    We are having issues with "Automatically expand to use available space" in crm 2011 in some of our forms.

    we are experiencing different behaviour. Some times it works and some times not. The detail of the isuue is below:

    All of our forms are designed in a way that the first tab is expanded and the reset of the TABs are collapsed so it would be easier on eyes.

    In my case I have 6 TABS:

    On first Tab I have 1 Subgrid with Fix rows

    On the second TAB I have 2 subgrids with fix rows

    On Third Tab I have a Subgrid that it set to 50 row and "Automatically expand to use available space" is checked.

    Strangly this subgrid is not expanding when I add rows to it.

    We have more than 50 entities and we have this issue on couple of them. It seems random to me.

    So we really need to know if anyone knows how to solve it or it is a known bug?

    Interestingly I changed the setting of the Grid on the third tab of the form I talked aboved to the fix rows and removed "Automatically expand to use available space" checkbox and save and published and later chage it again and checked the "Automatically expand to use available space" and aved and publsihed and it worked after.

    But it seems that it is not reliable and it will realy affect business.

    I found the folowing article http://rc.crm.dynamics.com/rc/2011/en-us/readme.htm. It did not help because I need all my tabs other than the first one to be collaps and I need  to check auto expand option.

    Any idea will be highly appricated.

    Thanks,

    Maryam

    Thursday, January 16, 2014 5:04 PM

Answers

  • Actually when I looked at the customization of those subgrids havingg expantin issue, there were some extra rows under subgrids that they could not be deleted and those rows were attached to the subgrids. I am not sure why they are there.

    But when I deleted the subgrids the row are gone. I recreated subgrids agian which caused those extra fields to go and the issue is fixed.

    Thanks,

    • Marked as answer by Maryam_r Saturday, January 18, 2014 12:07 AM
    Saturday, January 18, 2014 12:07 AM

All replies

  • Actually when I looked at the customization of those subgrids havingg expantin issue, there were some extra rows under subgrids that they could not be deleted and those rows were attached to the subgrids. I am not sure why they are there.

    But when I deleted the subgrids the row are gone. I recreated subgrids agian which caused those extra fields to go and the issue is fixed.

    Thanks,

    • Marked as answer by Maryam_r Saturday, January 18, 2014 12:07 AM
    Saturday, January 18, 2014 12:07 AM
  • I am able to fix this display issue by simply opening appropriate form in Customizations, and then showing the properties of the sub grid. if I hit "Okay," and then Publish the form, everything works as expected (the grid expands as necessary). However, every few days this happens again. 

    Is there a way to prevent this from continually happening? Is it possible this happens when CRM is restarted? If so, how can we prevent this? I do not want to have to periodically update this form to keep things working as expected. 

    Wednesday, April 16, 2014 6:21 PM