"Could not create scene from file" Error from HD View Control RRS feed

  • Question

  • First off, great work on this tool.  We love it here in Singapore and we're trying to do our first pano.


    I have a problem though.  The control works fine in most of our computers except a few where we get the following error:


    HD View Error

    Could not create scene from file http://s.amazonaws.com/HDView/SquamishWall/tiles/l_{l}/c_{c}/tile_{r}.wdp. ht=0x80040155


    This error occurs for both IE and FireFox.  We've also tried everything to reset our browsers.


    Just a FYI ... we are able to directly pull up a wdp file so we can confirm access through the proxies seem to work.


    Any ideas?



    Friday, August 10, 2007 2:00 AM

All replies

  • Thanks for the feedback. 


    As for your error.  Could you try the beta2 control that was just released (http://hdview.spaces.live.com/blog/cns!1AD33AA162CE96C2!277.entry)?  When this is installed you should see Beta2 in the splash screen.  We've fixed a few issues with opening wdp files in this release. 


    Saturday, August 11, 2007 4:28 PM

    Hey buddy,


    Thanks for the reply.  We have been using the Beta2 plug in. Sad  Any other ideas on what may be causing this?

    Tuesday, August 14, 2007 11:26 AM
  • 0x80040155 is “Interface not registered”, and it seems to have come from trying to download the tile.  But it sounds like you tried loading a .wdp directly with IE and Firefox through the proxies and it worked.  Hmm.   I assume it works with .jpg?

    Tuesday, August 14, 2007 10:44 PM
  • Do you get an error when you open this hdview? http://diddly.com/panos/Alaska/creek/  These contain jpg tiles instead of wdp tiles.  We are trying to determine if this error is coming from the wdp reader or somewhere else. 


    How about this one: http://research.microsoft.com/ivm/hdview/Berkeley/?FileName=SatherTower.xml&ToneMode=2



    Wednesday, August 15, 2007 4:40 AM

    Sorry folks, no love for either links.  Both JPG and WDP reader gives the same 80040155. 


    You're right, our initial search shows 80040155 as a "interface not registered" error.  We've tried to uninstall and reinstall but maybe it is not happening all the way?

    Wednesday, August 15, 2007 5:51 AM
  • Sorry, I noticed an error in my last post.


    I don't know what constitutes a "reader".  What I meant to say is that the HDView control gives the same 80040155 error for both panos based on both JPGs and WDPs.

    Wednesday, August 15, 2007 5:53 AM
  • You say it works on most of your computers...are the other computers different in some way?  Vista or XP?  32 or 64 bit?  Up to date (Windows update)?  Have you tried uninstalling the control (via Control Panel->Uninstall a program) and reinstalling?

    Wednesday, August 15, 2007 5:26 PM

    Nope.  Most of our equipment is Vista and works fine on most of them.  My wife's XP is giving the same error. 


    The machines are all updated.  We've tried uninstalling via the control panel also.

    Thursday, August 16, 2007 5:49 PM
  • We'd like to try some other debugging steps.  If you'd like to help further, the easiest thing for us would be if you could send an email to hdview@microsoft.com with your contact info.




    Friday, August 17, 2007 9:04 PM
  •  I got the same error message. After adding a mime type to the server, it's working fine now. In my environment I added
      AddType image/vnd.ms-photo wdp
    to the .htaccess file. Hope it works for some of you too.

    Sunday, May 25, 2008 10:46 AM
  • Brilliant hint, lastnickname, just a few days before I moved my sites to IIS 7 and it stopped working with the "Could not create scene" error. Adding the MIME type image/vnd.ms-photo wdp in IIS Manager fixed the issue. http://www.chiangmai.net/hdview
    Thursday, May 29, 2008 10:39 AM
  • I have read the fix but am not technical enough to understand the approach. I have the Could not Create error listed here and would be very grateful for clear instructions on the fix.








    Tuesday, July 8, 2008 3:33 PM
  • I just ran into the same issue (HD View 3.3, Firefox 52esr, Windows 10), trying to open an HDView html file, stored on the local disk.

    It turned out, that the reason was that the path contained Cyrillic characters. I've renamed all the folders to ASCII127 names, and now it works.

    (Just in case anyone else would run into this.)

    Thursday, January 31, 2019 8:31 AM