none
remote access to server (not console) RRS feed

  • Question

  • hi there, i am trying to connect to my server as a backup computer to run a program via remote access. unfortunately, even though i can access the shared files, i cannot run a virtual windows because the server isn't listed as one of the computers on the network. (i usually use remote desktop when on the network to access the server) please help!
    Wednesday, February 24, 2010 4:26 AM

Answers

  • Now I follow you.   You should look into an Add-In called "Advanced Admin Console".  It has an option called Show Desktop then you will have the same environment as if you made a remote desktop connection to the server.

    Download the Add-In to your Software\Add-Ins folder and install from the settings->Add-Ins tab.

    http://www.home-server-addins.com/downloads

    I guess I have to do the obligatory "Using Windows Home Server outside of the console is not supported" - so be careful.

    Cheers,
    Al
    --
    • Proposed as answer by Al West Wednesday, February 24, 2010 12:38 PM
    • Marked as answer by Ken WarrenModerator Wednesday, February 24, 2010 4:31 PM
    Wednesday, February 24, 2010 11:32 AM
  • right, al.....the connect to server option does come up. unfortunely, when i enter that, it is just letting me control the WHS console remotely, and not the actual server itself. i got the certificate warning by trying to bypass this domain i had setup and going directly to the server via RDC. thanks again for the input!

    This is by design. Remote Desktop access to your server is not supported, and therefore not presented through the Remote Access web site.

    I'm not on the WHS team, I just post a lot. :)
    Wednesday, February 24, 2010 1:15 PM
    Moderator

All replies

  • Hi,

    To access the server remotely you need to be using Internet Explorer (not firefox, opera, chrome etc - IE Only) , connected by HTTPS, with the site of your homeserver added to the trusted sites - look at the status bar of IE in the bottom right.  Your user also has to have Remote Access enabled in the "User Accounts" Tab of the Windows Home Server Console and the options should be either "allow access to shared folders and home computers" or "Allow access to home computers only".

    Cheers,
    Al
    --
    Wednesday, February 24, 2010 10:19 AM
  • thanks for the reply, al......so, actually, i do have remote access to both home computers & shared folders. the issue is that i wanted to access WHS as a "computer" and it isn't listed for remote access. i think i read i need to bypass this secure website and go directly via Remote Desktop using the Terminal Server? i did try this from outside my network and got some GoDaddy certificate problem, saying "certificate doesn't match".........very frustrated now. really need to run a program on the server from outside the network.
    Wednesday, February 24, 2010 11:08 AM
  • Just to be sure do you not see the connect to server option come up? It's not listed under computers:
    http://i49.tinypic.com/15rf7ee.png

    When you setup the remote access you selected a hostname for your server, something like myserver and then depending on which domain you set the certificate will be created for your hostname + the domain name.  If they don't match when you browse to the server then you will get the certificate warning.  You should enter that hostname + domain name as the address i.e.  http://myserver.homeserver.com/
    --
    Wednesday, February 24, 2010 11:19 AM
  • right, al.....the connect to server option does come up. unfortunely, when i enter that, it is just letting me control the WHS console remotely, and not the actual server itself. i got the certificate warning by trying to bypass this domain i had setup and going directly to the server via RDC. thanks again for the input!
    Wednesday, February 24, 2010 11:25 AM
  • Now I follow you.   You should look into an Add-In called "Advanced Admin Console".  It has an option called Show Desktop then you will have the same environment as if you made a remote desktop connection to the server.

    Download the Add-In to your Software\Add-Ins folder and install from the settings->Add-Ins tab.

    http://www.home-server-addins.com/downloads

    I guess I have to do the obligatory "Using Windows Home Server outside of the console is not supported" - so be careful.

    Cheers,
    Al
    --
    • Proposed as answer by Al West Wednesday, February 24, 2010 12:38 PM
    • Marked as answer by Ken WarrenModerator Wednesday, February 24, 2010 4:31 PM
    Wednesday, February 24, 2010 11:32 AM
  • now we're talking! so i downloaded the advanced admin console, but i don't see the "show desktop" option when i connect remotely to WHS. do i need to reboot the server? regards
    Wednesday, February 24, 2010 11:44 AM
  • never mind, al.....i got it.....thank you so much!!! that worked!
    Wednesday, February 24, 2010 11:51 AM
  • right, al.....the connect to server option does come up. unfortunely, when i enter that, it is just letting me control the WHS console remotely, and not the actual server itself. i got the certificate warning by trying to bypass this domain i had setup and going directly to the server via RDC. thanks again for the input!

    This is by design. Remote Desktop access to your server is not supported, and therefore not presented through the Remote Access web site.

    I'm not on the WHS team, I just post a lot. :)
    Wednesday, February 24, 2010 1:15 PM
    Moderator