none
Excel VBA 2010 HPC Automation Error RRS feed

  • Question

  • We are currently investigating using Excel in an HPC environment and have encountered some problems using HPC 2012.

    Our server (head node) has HPC version 2012.  We are running Office 2012.

    I have installed the 2012 HPC client and the 2012 HPC SDK (is this really 2008 SDK) onto the client machine.  I have run diagnostics through HPC Cluster Manager, the tests all run successfully.

    I then followed the example in this paper http://www.microsoft.com/en-us/download/details.aspx?id=2939 for creating an Excel Workbook with VBA.  However I encounter an Automation Error (system file not found) when I try to use the ExcelClient object (E.g Dim o as ExcelClient will fail).  The references requested in this paper are not available in VBA (e.g. Microsoft_Hpc_Excel).  I had to browse to a tlb file in (C:\Program Files\Microsoft HPC Pack 2012\Bin) that creates a reference to a Microsoft.Hpc.Excel file, this allowed the project to compile but I was faced with the Automation Error.  I suspect the installation package may not be registering all the components correctly.

    However if I uninstall the 2012 client and replace with the 2008 client I can successfully use the ExcelClient (but I cant use HPC Cluster Manager because the server version is different).  Any thoughts?  There are no code examples available yet for HPC 2012.

    Thanks for your help.

    System Information

    Client

    OS Name             Microsoft Windows 7 Ultimate

    Version                6.1.7601 Service Pack 1 Build 7601

    System Type      x64-based PC

    Processor            Intel(R) Core(TM)2 Duo CPU     E8500  @ 3.16GHz, 3166 Mhz, 2 Core(s), 2 Logical Processor(s)

    Server

    OS Name             Microsoft Windows Server 2012 Standard

    Version                6.2.9200 Build 9200

    System Type      x64-based PC

    Processor            Intel(R) Xeon(R) CPU E5-2407 0 @ 2.20GHz, 2200 Mhz, 4 Core(s), 4 Logical Processor(s)

    Thursday, January 17, 2013 3:50 PM

All replies

  • Can you try to change the .Net runtime policy of Excel?

    Create the Excel.exe.config under the same folder with Excel.exe, or modify it if it exists.

    Add following configuration:

    <?xml version="1.0"?>

    <configuration>

      <startup useLegacyV2RuntimeActivationPolicy="true">

        <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/>

      </startup>

    </configuration>

    Tuesday, March 19, 2013 3:14 AM
  • Hi BigDave - Now about 3 years later, I am facing this exact problem. Any thoughts about how you were able to resolve this (assuming you have)?
    Saturday, January 23, 2016 2:26 PM
  • Hi KMLN, have you tried to add the Excel.exe.config to support .Net 4.0 runtime as Yumin suggested? Which HPC Pack client version and Office Excel version are you using? Could you double check if the HPC Pack client was installed by running the setup.exe so that the vc++ 2010 runtime was installed? And also check if the Microsoft.Hpc.Excel reference is checked under Tools->References in the VBA editor.

    BR,

    Yutong Sun

    Monday, January 25, 2016 2:40 AM
    Moderator
  • Hi Yutong - Yes I did and that resolved the problem in this instance. However, that installation was really a test environment and when I went about scaling the cluster up to run production jobs, I am having a number of somewhat similar issues. I started a fresh installation and done everything by the book as mentioned here on Microsoft website: getting started with HPC server (this website is not allowing me to paste the link here).

    I have one head node, once compute node and domain controller is on a separate server. All have Windows Server 2012 R2 64-bit installed and Excel 2016 32-bit installed using Office Deployment Tool. I have installed HPC Pack 2012 R2 Update 3 on head node and compute node. The problem is when I run the Excel Configuration Test from Diagnostics of the HPC Cluster Manager, the test fails for both nodes. For the head node I get an exception with a long error message which ends with some problem with 'ExcelClient.Dispose'. On the compute node, the error is that it could not start the 'Excel service'.

    I think I have done everything exactly as instructed and followed other steps that helped me in a successful test deployment. Any help in understanding what I am doing wrong will be greatly appreciated!

    Wednesday, January 27, 2016 11:35 AM
  • Hi KMLN,

    Excel 2016 should work well with HPC Pack 2012 R2 Update 3, though only Excel 2010 and 2013 are fully tested and officially supported. The Excel.exe.config is still required for Excel 2016 to support the .Net 4.0 runtime for HPC Pack 2012 R2 Excel modules. I'm not quite sure now about the cause of the Excel diagnostic test failures due to lack of detailed error stacks. What I can recommend is : 1. check if a simple Excel workbook or UDF offloading can run on the cluster; 2. check if reinstalling the Excel 2016 by directly run setup.exe can do the work; 3. uninstall the compute node on the DC which is a not recommended configure, use the head node with the compute node role and see if Excel can run on the head node in one box.

    You may also check this HPC Excel Resources Wiki for helpful info and samples: http://social.technet.microsoft.com/wiki/contents/articles/1198.windows-hpc-and-microsoft-excel-resources-for-building-cluster-ready-workbooks.aspx

    BR,

    Yutong Sun

    • Proposed as answer by KMLN Friday, February 26, 2016 9:20 AM
    Saturday, January 30, 2016 6:57 AM
    Moderator
  • Thanks Yutong. When I uninstalled Excel 2016 downloaded via Office Deployment Tool and installed full Office pack (Word, PowerPoint, Publisher etc.), it worked. So the problem really was that one shouldn't download Excel 2016 using the tool. Though I would have really liked just downloading Excel to keep a light installation and for security reasons on my machines, I think I can do with having full Office for now. Thanks for the suggestion.

    If this is a bug that you plan on fixing in future, I would really love to know when you have fixed it.

    Saturday, January 30, 2016 11:38 PM
  • Hi KMLN,

    Glad to know reinstalling the full Office pack worked for you. If you would like to customize the Office installation, e,g. only install Excel on the nodes, I would recommend using the Office Customization Tool (OCT) to generate the .MSP file for the customized installation. This tool works well for the Excel 2010 and 2013 setup with HPC Pack 2012 R2.

    For installation via Office 2016 Deployment Tool, we would investigate to see why this tool failed to work with HPC Pack 2012 R2. If we can fix it from HPC Pack side, we would do so in the next release of HPC Pack.

    Thanks for the feedbacks.

    BR,

    Yutong Sun

    Sunday, January 31, 2016 10:20 AM
    Moderator
  • Hi Yutong - I do have one more related question if you can help me again that would be great. I have created an image for compute node using Sysprep tool with Office installed so that I can scale up my cluster quickly when needed. However, when I do launch multiple cluster nodes, everything works fine except that I get a warning that Excel is not activated on the new tools, which amounts to saying that I need to get into each node and key in my id and password. Is there a way to activate Excel automatically whenever I launch new compute nodes?
    Monday, February 1, 2016 12:33 AM
  • Hi KMLN, you may use the ospp.vbs tool with /inputkey and /act options to activate the Office via command line and use the clusrun tool in HPC Pack to run the ospp.vbs across the Excel compute nodes for volume activations. For details about ospp.vbs, please check this technet doc. HTH.

    BR,

    Yutong Sun

    Monday, February 1, 2016 2:07 AM
    Moderator
  • Hi Yutong Sun,

    I am getting the same error mentioned by KMLN [Automation Error (system file not <g class="gr_ gr_56 gr-alert gr_gramm gr_run_anim Punctuation only-del replaceWithoutSep" data-gr-id="56" id="56">found)]</g><g class="gr_ gr_56 gr-alert gr_gramm gr_disable_anim_appear Punctuation only-del replaceWithoutSep" data-gr-id="56" id="56">,</g> since I am very new to this HPC. I was not able to understand what exactly should be done.

    It would be great if you could give me detailed steps of what should be done.

    I have "HPC Pack 2012 R2" and "2012 server"

    JSP

    Wednesday, February 22, 2017 3:40 PM
  • Hi JSP_JSP,

    What's the Excel/Office edition did you install on the compute nodes? Are they activated? Have you added the Excel.exe.config on the computer nodes as mentioned above?Could you run the Excel VBA workbook successfully in local on the nodes?

    Regards,

    Yutong Sun

    Thursday, February 23, 2017 6:58 AM
    Moderator