locked
Security permission to view properties option in CRM 2013 online RRS feed

  • Question

  • Hi All;

    What is the security permission to view properties option in CRM 2013 online

    Any help much appreciated

    Thanks


    Pradnya07

    Monday, November 10, 2014 9:39 AM

Answers

  • I don't think that is a permission issue related to the functionality but the position of the button defined inside the solution.

    Inside customizations.xml the location is defined as

    Location="Mscrm.Form.{!EntityLogicalName}.Developer.Customize.Controls._children"

    meaning all the forms under the Developer tab. With CRM 2013 the tabs are not visible but still defined.

    Developer tab is accessible normally to System Administrator and System Customizer roles. I think if you move the location to another tab (like the save one or the export data) all the users will be able to see the option.

    EDIT: I modified the solution with this change, it uses ExportData tab now and I tested it. You can download from here:

    http://1drv.ms/1EuFA5F


    However I advised Scott about this thread, probably he will post shortly.


    My blog: www.crmanswers.net - Rockstar 365 Profile



    • Edited by Guido PreiteMVP Monday, November 10, 2014 1:51 PM
    • Marked as answer by Simran08 Monday, November 10, 2014 2:44 PM
    Monday, November 10, 2014 1:20 PM
  • for me works with CRM Online

    make sure you uninstalled before the previous solution (or you clicked overwrite customizations during the import) and close and open your browser in order to refresh the command bar.

    Notice the position under "Run Report"


    My blog: www.crmanswers.net - Rockstar 365 Profile

    • Marked as answer by Simran08 Monday, November 10, 2014 2:44 PM
    Monday, November 10, 2014 2:29 PM

All replies

  • Refer this. Properties is not present in crm 2013. You have to import the solution provided in the link. To remove it you have to remove the Solution

    Regards, Saad

    Monday, November 10, 2014 10:19 AM
  • Hi

    Thanks for your reply 

    Yes the properties is downloaded from that link 

    But this is properties is showed to some users but some cant see it

    I need to make this available for all users

    Hence need to know the security permission to view this properties

    Any help much appreciated


    Pradnya07

    Monday, November 10, 2014 10:38 AM
  • Hi Gareth,

    I don't think Properties is handled by any previlige. The Security Role needs to be System Administrator.

    Logically also only System Admin should have the right to access the information displayed in Properties.


    Regards, Saad

    Monday, November 10, 2014 12:19 PM
  • I don't think that is a permission issue related to the functionality but the position of the button defined inside the solution.

    Inside customizations.xml the location is defined as

    Location="Mscrm.Form.{!EntityLogicalName}.Developer.Customize.Controls._children"

    meaning all the forms under the Developer tab. With CRM 2013 the tabs are not visible but still defined.

    Developer tab is accessible normally to System Administrator and System Customizer roles. I think if you move the location to another tab (like the save one or the export data) all the users will be able to see the option.

    EDIT: I modified the solution with this change, it uses ExportData tab now and I tested it. You can download from here:

    http://1drv.ms/1EuFA5F


    However I advised Scott about this thread, probably he will post shortly.


    My blog: www.crmanswers.net - Rockstar 365 Profile



    • Edited by Guido PreiteMVP Monday, November 10, 2014 1:51 PM
    • Marked as answer by Simran08 Monday, November 10, 2014 2:44 PM
    Monday, November 10, 2014 1:20 PM
  • thanks for your reply but the solution didnt work
    It removed Properties completely from CRM 2013 online
     I need it to display properties to all the users

    Pradnya07

    Monday, November 10, 2014 2:21 PM
  • for me works with CRM Online

    make sure you uninstalled before the previous solution (or you clicked overwrite customizations during the import) and close and open your browser in order to refresh the command bar.

    Notice the position under "Run Report"


    My blog: www.crmanswers.net - Rockstar 365 Profile

    • Marked as answer by Simran08 Monday, November 10, 2014 2:44 PM
    Monday, November 10, 2014 2:29 PM
  • Thanks a load it worked like a charm

    Pradnya07

    Monday, November 10, 2014 2:45 PM
  • Hi,

    For my original solution to work you'll need to add the following permissions to users:

    Organization level, Read access: Publishers

    Organization level, Read access: Solution

    Scott


    Scott Durow
    Blog www.develop1.net    Follow Me
    Rockstar365
    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Monday, November 10, 2014 7:53 PM
    Answerer
  • Thanks Scott for this reply

    Pradnya07

    Tuesday, November 11, 2014 9:24 AM