locked
No Presence showing up in Outlook RRS feed

  • Question

  •  

    Have OCS running in a lab with Exchange 2003.  Also have the Conferencing add for exchange installed.  The presence info shows up in exchange but it is a gray circle, not green for available.  Any idea why it is gray and not the color that the Communicator shows?
    Monday, July 28, 2008 1:30 PM

Answers

  • Thanks Matt,

    I did have the DNS setup OK.  But I needed to manully configure the Communicator to goto ocsserver.1stxxxxx.com in the advanced options.  Without this, it kept on trying to goto ocsserver.firstxxxxx.com and when it did, it said there was a certificate issue even though I set the SAN to firstxxxxx.com.

    So now the user is logging in as firstxxxxx.com, communicator directs it to ocsserver.1stxxxxx.com and it works OK.  Not presence within Outlook shows up OK also.

     

    Thursday, July 31, 2008 5:02 PM

All replies

  • Make sure you do have latest update for office outlook installed. That should fix it.


    Regards,
    R. Kinker
    MCSE 2003 (Messaging), MCTS - LCS 2005, MCTS - OCS 2007
    http://www.ocspedia.com
    http://www.itcentrics.com/LCS_Home.htm
    Monday, July 28, 2008 2:18 PM
  •  

    I have Microsoft Office Outlook SP3, version 11.0 installed.  Is there something more recent than that?
    Monday, July 28, 2008 5:04 PM
  • Yes, there is a Presence-specific hotfix for Outlook 2007: http://support.microsoft.com/kb/936864

     

    Monday, July 28, 2008 5:12 PM
    Moderator
  • Thanks, But is there a hotfix for Office 2003?

     

    Monday, July 28, 2008 5:36 PM
  • I'm having similar issues. The hotfixed referenced above returns an error message that no products covered by this hotfix are installed. Using Office Outlook 2003 SP3.

    Joel
    Tuesday, July 29, 2008 1:08 PM
  • Did you visit the first link in the two references discussions above?  There are a handful of suggestions regarding matching SIP<>SMTP addresses, existance of the Office 2007 compatibilty pack, and other potential problems.

    Tuesday, July 29, 2008 1:22 PM
    Moderator
  • I have gone back and made sure the SIP and SMTP addresses match.  I have had the Office 2007 compatibily pack installed allready.  I still get a 'gray' presence indicator within Outlook.  Anything else I should try?

     

    Wednesday, July 30, 2008 11:32 AM
  • Hmmm...I see you mentioned this is in a lab.  How many clients do you have configured and are seeing no presence?  Is this just one virtual workstation you are testing with?

    Wednesday, July 30, 2008 12:13 PM
    Moderator
  • Jeff,

    I have 4 clients setup.  Plus one DC and one OCS server.  The only server running virtual is exchange server on a separate machine.  All OCS functionality is working fine (Presence, IM, A/V, Live Meeting).  Within Outlook, conferencing and Live meeting works fine.  Just the presence indicator within Outlook show grey next to the name, not green for available.

    After digging a little, it looks like exchange, through its policy, changes the SMTP e-mail address to an alias (firstxxxxx.com).  For example:  the main domain is 1stxxxxx.com, the alias is firstxxxxx.com.  So I setup the OCS environment for the 1stxxxxx.com domain and setup the certificates based on that.  Since the SMTP and SIP addresses need to match, I have added firstxxxxx.com as the primary SIP domain for OCS and changed the user login to match the firstxxxxx.com so that the SIP URL and SMTP adress will match.  But now when the user tries to login to OCS, it comes back with a certificate error.  I believe it is because the FQDN for the certificate has 1stxxxxx.com in the name, not firstxxxxx.com.  Do you think that's possible?  Do I need to redo the certificate from OCS?

    Thanks

     

    Wednesday, July 30, 2008 3:58 PM
  • Hi,

    Yep - you'll need to add a SAN to your cert that includes servername.firstxxxxx.com. I'd re-issue the cert with a SAN for each of the SIP domains that you are looking to support.

     

    BTW - this is only for auto-configured clients. You should be able to set your clients to "manual config" and put in the servername.1stxxxx.com and have it connect without cert errors.

     

    Regards,

    Matt

     

    Wednesday, July 30, 2008 5:13 PM
  • Matt,

    Thanks.  I re-issued the cert with the SAN set to firstxxxxx.com

    Now when I try to login to OCS using the communicator with the user as  username@firstxxxxx.com, I get an error 'failed to connect to server ocsserver.firstxxxx.com on port 5061 due to error 10060.' ...server not listening on port in question...

    If I have a user login with username@1stxxxxx.com, no problem.

    Any thoughts?

     

     

    Wednesday, July 30, 2008 9:14 PM
  •  

    Hi there,

    OK couple things to make sure of:

    1) do you have a DNS entry for ocsserver.firstxxxx.com? is it pointing to the correct IP (Same as ocsserver1stxxxxx.com)?

    2) do you have an SRV record in the "firstxxxx.com" domain?

     

    Regards,

    Matt

     

    Thursday, July 31, 2008 3:00 PM
  • Thanks Matt,

    I did have the DNS setup OK.  But I needed to manully configure the Communicator to goto ocsserver.1stxxxxx.com in the advanced options.  Without this, it kept on trying to goto ocsserver.firstxxxxx.com and when it did, it said there was a certificate issue even though I set the SAN to firstxxxxx.com.

    So now the user is logging in as firstxxxxx.com, communicator directs it to ocsserver.1stxxxxx.com and it works OK.  Not presence within Outlook shows up OK also.

     

    Thursday, July 31, 2008 5:02 PM