locked
Issues with Self Build + Reinstall RRS feed

  • Question

  • Hi All

    Got some serious issues with my Home Server, and like many just painstakingly moved all my data off several machines and now I've hit several problems with the actual WHS box...

    Some Background with the machine:
    Brand new build, all new parts (except CDdrive). AMD Phenom Processor, 2GB Corsair XMS Ram, Asus M3N-HD/HDMI Mobo, 3 x 1TB Western Digital Green Power Drives, Corsair PSU (I think).

    I've been having problems with the server for a while, with it dropping off the network after a while, randomly and having to manually restart it to get it to work again. It was an annoyance, but wasn't too bad and I put it down to the dodgy network we had in my Uni house.

    I moved house (first time) and the machine was fine, and then I moved again and it was running fine, but remote desktop from my reformatted laptop with Win 7 Ultimate RC failed to connect, however it was working fine with another machine (Running XP (Home I assume)). After a while, and playing with the Lan settings I made the fatal (and rather stupid mistake of disabling the LAN card... - so I had to shut the server down by using the power button, but it shut itself down fine.

    (After connecting the monitor) and logging in, the machine itself hung with a black screen after the loading WHS screen. I tried booting in with Safe Mode, with and without Networking support, with the same problems each time. I also tried the boot with Last Known Good Configuration, but still no luck.

    So I decided to bite the bullet and reinstalled the OS - which whilst taking an age, did its job and I booted back in, only to be confronted with an extremely slow and unresponsive system - which the backup system wasn't working. However, remote desktop etc was - so I took some screen shots that I'll link too in a minute.

    As you can see, one of my hard drives is no longer in the pool - whilst saying it is recognised by Windows device manager etc. All the disks are recognised by the bios (although since they are all identical its hard to know which one is which) obviously I can't remove the drive, as i'll lose my data, but there isnt an option to repair it. I checked the drives, and booted it up again and had the same problem - despite the bios saying all the drives are there.

    Then I took the hard drives fully out of the machine to check for any damage, or obvious overheating or anything, and I think I have got my cables muddled up when putting them back in, leading too a few Disk Boot Errors - but I put them back in (by deduction) and it booted fine once - but now its not even loading the bios....

    Assuming I'll need to check the usual cables etc and clear the CMOS battery to get the machine to boot into the bios again, but do you have any ideas how to get my server back up and running?

    Ill attach the images in the next post -

    Thanks for any advice
    Monday, September 7, 2009 8:08 PM

All replies

    • Edited by El Del Sunday, September 13, 2009 3:36 PM
    Monday, September 7, 2009 8:13 PM
  • Just as a quick update, got the machine back to booting up and coming to the Windows Home Server loading screen then a crash on the black screen, and I have just attempted a 'Last Known Good Configuration', but it seems to be hanging on the black screen. Going to leave it on overnight to test that I'm not being impatient...
    Monday, September 7, 2009 8:57 PM
  • For me it sounds, as if you have a serious hardware problem. In case there are floppy drives and IDE devices involved, check if the cables are not rotated in the slot. Other than that, a disk could have failed or you could have attached drives to SATA ports, which are not supported in non RAID mode by the system.
    If this is not the case, I would attach an empty drive alone and try a installation to that machine again. If it runs stable now, ok and you could follow the FAQ How to recover data after server failure.

    You say, not even the Bios boots up any more. So remove all components not needed, check, if the cards and memory modules are sitting good in their slots, if the CPU is cooled well, and if there is no circuit on the motherboard, caused by a screw somewhere or by a screw holder on the downside in a position without hole on the board.
    You could also have removed a cable from the mainboard or graphic card, which is necessary to supply the needed power.

    The power supply also could be broken or to weak.

    Best greetings from Germany
    Olaf
    Tuesday, September 8, 2009 8:12 AM
    Moderator
  • I think the hardware configuration is alright now, as I said its booting up to the WHS loading screen then stopping. Must have knocked a cable which meant it wouldn't boot to the bios but as I said its working now fine. Will try another reinstall to see if that helps - but I cannot understand why it says the drive can be added too the pool but apparently one of the drives is missing. The HD is also present in the bios Once I get home from work ill have another play and come back with the results. If I can get back into the machine I'll run CHKDSK and report any errors - I assume a HD fault that CHKDSK would highlight?
    Tuesday, September 8, 2009 12:26 PM
  • Well seems I haven't had a hardware error at all, but the recovery is currently in progress...

    I loaded a Linux Live CD up to look at the drives - it reported one drive, with a 20GB SYS partition and a 931GB Data Partition, so I was a bit worried, but further investigation showed the DATA drive to be 2.7TB - The rest of the missing space.

    WHS still wouldn't see the drive, so I am currently copying all the data off the drives onto my new 1.5TB drive via a Windows Server 2003 install from a spare HDD.

    Decided to add more storage and reinstall, with freshly wiped drives, set my shares up with the duplication on this time, then copy the data back over.

    Seems Windows had somehow managed to corrupt itself... but fingers crossed I get it back up and running asap!
    Sunday, September 13, 2009 3:32 PM