none
S & T 2011 with GPS will not run in Windows 7 RRS feed

  • Question

  • I have installed & re-installed S&T 2011 it brings up splash screen & then hangs. I went to Microsoft support site no help available.

    When I entered product ID it said this version of product not supported in my country.(USA, Washington state) 

    Support site gave to chat e-mail or phone, e-mail gave me the not supported message & no phone number was offered up.

    I just received the software today from Amazon, I have S&T 2008 but it won't run on Win 7 either!


    Andrew Lindsay
    Thursday, December 22, 2011 4:26 AM

All replies

  • Without question, properly installed S&T2011 runs very well in Windows 7, whether 32 or 64 bit verison.  You must have a local problem.  For instance, have you tried going to the file folder where S&T is loaded using windows explorer and double-clicking on the "streets.exe" file? 
    Thursday, December 22, 2011 2:19 PM
  • I have installed & re-installed S&T 2011 it brings up splash screen & then hangs. I went to Microsoft support site no help available.

    When I entered product ID it said this version of product not supported in my country.(USA, Washington state) 

    Support site gave to chat e-mail or phone, e-mail gave me the not supported message & no phone number was offered up.

    I just received the software today from Amazon, I have S&T 2008 but it won't run on Win 7 either!


    Andrew Lindsay


    Go to Start and in the search pane type in msconfig.exe then enter.  No check Diagnostic startup followed by OK. It should reboot and once it does try loading S&T 2011. If it loads past the startup screen then your problem is probably in the services and startup items.

    Now if it load then simply load msconfig.exe again only this time check on the Service tab and then the Startup tab selecting ddisableall on both screens.

    With that said you can add back services a few at a time and try again until it stops loading. Now most of us that had this problem found it was usually some such as the Tablet PC Input Service needed to be disabled. In Startup I had nothing so I suggest you disable all startup until you locate the problem service first. Once I disabled that service it worked fine and I have no idea really as to what that service does. I just leave it Selective StartUp mode. There is instructions under a section on the Streets and Trips site at Microsoft but don't have the URL now that I've fixed it. There are also several threads here that had similar problems which have been solved also.

    Friday, December 23, 2011 1:48 AM
  • Try KB2643882 - http://support.microsoft.com/kb/2643882 - it works wonders! ;-)
    • Proposed as answer by donmeek Tuesday, January 17, 2012 5:35 AM
    Tuesday, January 17, 2012 1:43 AM