locked
Change main CRM site URL RRS feed

  • Question

  • Hello.

    The way our CRM installation was set up, we have a strange redirect that I'd like to get rid of.

    If I go here:
    http://crm.company.com

    I end up getting a 302 redirect to:
    http://company.crm.company.com

    I'm thinking this is a setting in CRM somewhere, but I'm not able to find it.

    Thanks very much!
    -Gary
    Tuesday, November 25, 2008 9:51 PM

Answers

  • Gary,

     

    Is it a On-Premise deployment or IFD?

    Also, have you setup the DNS suffixes?

     

    Jim

     

    Wednesday, November 26, 2008 12:04 PM
    Moderator

All replies

  • Gary,

     

    It could be the DNS issue, please check your server DNS settings.

     

    Jim

     

    Tuesday, November 25, 2008 10:40 PM
    Moderator
  • Thanks Jim.

    That's what support at my host suggested as well.  When I set all this up, I first added a DNS A record for crm.company.com.  I then noticed that when I hit this URL, I was being redirected to http://company.crm.company.com (and getting a "server not found" error).  I added the new DNS A record for company.crm.company.com, and it works now.  I'd just like to fix the URL and get rid of the redirect if possible.

    So I'm thinking that since the redirect was happening before I ever added the second DNS record, it's not a DNS thing, but either IIS or CRM sending a 302 redirect to the browser.

    Thanks!
    -Gary
    Tuesday, November 25, 2008 11:33 PM
  • Little more information on this.  If I hit the following bogus URL:
    http://crm.company.com/foo.aspx

    ...I get redirected to the following URL:
    http://company.crm.company.com/signin.aspx?targeturl=http%3a%2f%2fcompany.crm.company.com%2ffoo.aspx

    However, if I comment out the following single line in web.config on the web site:
          <add name="CrmAuthentication" type="Microsoft.Crm.Authentication.AuthenticationEngine, Microsoft.Crm, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />

    ...and hit the same bogus URL, I get a 404 error (as expected).

    This seems to be pretty convincing evidence that this is CRM doing the redirect.

    Thanks!
    -Gary
    Wednesday, November 26, 2008 4:16 AM
  • Gary,

     

    Is it a On-Premise deployment or IFD?

    Also, have you setup the DNS suffixes?

     

    Jim

     

    Wednesday, November 26, 2008 12:04 PM
    Moderator
  • Got some help from fpweb (our host) on this.  This is an internet-facing deployment (IFD).

    Turns out the "organization name" is prepended to the domain name you have set up in the IFD tool.  The organization name is "company" (not the real name clearly).  The domain name in the IFD tool is crm.company.com.  So the organization name is prepended, and we get company.crm.company.com.  We could change the domain in the IFD to remove the crm, and end up with company.company.com.  Apparently the only way to get the domain to be crm.company.com would be to change the organization name to "crm".  That makes little sense, and even if we wanted to do it, probably a pain since CRM licenses are tied to organization name.

    So for now we're just going to deal with the strange and vaguely annoying URL.  Be nice if you could turn off the "feature" where the org. name is prepended to the domain.  Anyone know if that's possible?

    Thanks!
    -Gary

    Tuesday, December 2, 2008 3:32 PM
  • About the only way you can get around this is to use an ISA server.  Load your SSL onto the ISA server (one with a friendly name like crm.company.com) and then have the ISA server redirect traffic for that site to the company.crm.company.com site.  This blog will give you more indepth information on how to setup ISA with CRM (http://blogs.technet.com/isablog/archive/2008/07/23/publishing-microsoft-crm-4-0-through-isa-server-2006.aspx

    ).

     

    Good luck

    - Jerry

    Wednesday, December 3, 2008 5:02 PM