locked
Runtime/Application Error in browser AND Can't get into Console; HP Home Server with Win Vista on PC RRS feed

  • Question

  • Hello: Can someone please help me find my way back into my HP Home Server running WHS? I've looked around here at various postings for both the the issues I'm having, and each seems to rely on access to one or the other of the things not working for me, so I'm kind of at a loss. Here's my scenario:

    A: When I try to access the server via a web browser I get the application runtime error with the request to set a web.config file on the server. Because of problem B (below) I cannot get into the console, so not sure how to begin to do this.

    B: When I try to access the server console I get an error saying that the computer cannot connect to the server and I should check my connection.

    My connection is via a TwoWire wireless router, which seems to be working fine, and which I have configured to use DHCP. Several computers, a printer, and the HP Home Server are all in this network together, and all can access each other except for the home server, which I can't seem to get into on this computer, or on either of the Macs I've tried. (I have one other PC running XP, which I guess might be worth a try...).

    I have tried multiple times to reboot the server, and one time (long ago) this actually seemed to work for a little while, such that I was able to get into the console, but then it disconnected again and I have not been able to get back in since. Nothing seems to help the browser error.

    The server icon on my desktop remains green and happy as long as the server is able to continue doing nightly scheduled backups, which it happily does. I can also access shared folders by right-clicking this icon. So as far as I can tell, the server is connected properly.

    The trouble might have began when I tried to do some remote access configuration in the browser (I have a vague memory of that), or possibly with a Windows update on my Vista machine. I am pretty sure my firewall on the router is letting everything through, and I can completely turn off the firewall on the Vista machine without any positive (or negative) effect.

    Obviously I am shooting in the dark here. I have no idea how WHS even operates, what it eats, or when to take it for a walk. (-; But I am good at following highly technical instructions, as long as you don't ask me to go somewhere without giving me a map. Even a push in the right direction would be extremely helpful at this point, as I have been forced to think of my Home Server as just a big disk that also does backups (from which I would probably not be able to restore anything) for the last several months while I've been trying different things on and off to no avail.

    Thanks in advance for any help!

    Leha

    Monday, June 6, 2011 5:16 PM

All replies

  • Anyone?
    Leha
    Wednesday, June 8, 2011 3:42 PM
  • Have you tried a Remote Desktop Connection into your server to fix Problem A?
    Wednesday, June 8, 2011 4:41 PM
  • Thank you, Philip, for your reply. Doesn't that require use of the browser to log into the server? That's where the problem occurs. I don't know another way to log in remotely, but if you do, please let me know.

     

    Regards,

    Leha


    Leha
    Thursday, June 9, 2011 4:38 PM
  • Leha

    No. On your client machine go to Start, All Programs, Accessories, Communications, Remote Desktop Connection (that's where it is on XP). Then in the pop up box type your server name or IP address and you should be able to see your Server Desktop on your client after entering "Administrator" and the admin password. You can then work on your WHS desktop and hopefully fix the initial problem.

    Phil


    Thursday, June 9, 2011 5:44 PM
  • Hi, Philip: Thank you so much. I was able to log in remotely and found out some things, although I'm still struggling to resolve the problems.

    The number one problem is that the system volume, C, is totally full--I have no idea why. It's allocated 20GB, but says it has only about 45KB available. I tried to run disk defrag, because apparently the volume is badly defragmented, but you need some disk space to do that, and now I seem to be needing to run Chkdsk /f before trying again. I've scheduled the server to do that on restart, and then restarted it, which of course booted me off.

    Other problems:

    My router doesn't support UPnP, and my server is telling me I'm going to have to manually configure port forwarding, but I'm not sure what to set to what. I can't connect to the MediaSmart web server I configured, which I'm guessing is because of the lack of port forwarding??

    Because of that, I can't install any updates to the server, either.

    There may be other problems, but those were the glaring ones. Any help greatly appreciated!

    Leha


    Leha
    Friday, June 10, 2011 2:53 AM
  • LeHa

    Well that's a significant step forward - now you can start to sort out the real problems. I have never experienced WHS filling up the C: Drive - do you have any other programs installed that could be doing so or are you somehow using it to store some of your own data? It should be relatively easy to find out what is using up the space now you have access to your Desktop by looking at your folders on C:.

    Once you have solved that, many of your problems are likely to go away. With regard to port forwarding (worry about that later) but there are many sources of information on this forum to help you with that.

    Phil

    Friday, June 10, 2011 12:39 PM
  • Thank you, again, Phil. Yes, I looked on he C drive and there is nothing of mine on there. I'm thinking at this point that it must have just gotten crazily fragmented somehow, but I'll go through each folder and look for something big.

    Thanks for all your help. I feel like this is actually going to be possible to fix now! :)


    Leha
    Friday, June 10, 2011 7:40 PM
  • I'm not having any luck with the disk defrag, or with trying to find stuff to move off to the D drive. Oddly, as soon as I move some stuff and free up some space, the space seems to get consumed again. When I can even get enough space to run defrag for a little while (before it stops due to lack of space), it seems to help--but it's just temporary and then the disk fills up again.

     

    I looked everywhere and the only thing that looks awry is that I have failed Windows updates on the server since March 2010. That might actually be the time the server stopped working, so it might be relevant. But I'm just guessing. I tried uninstalling that last update, but ran out of disk space on the attempt.

     

    Any other ideas would be awesome. Feeling stuck again.

     

    Thanks so much.


    Leha
    Saturday, June 11, 2011 4:53 AM
  • Okay--just found 13GB of log files in an obscure folder in system32/. Moving them off to D drive before deleting them entirely, just in case I need them for something, which I doubt. (-:

    Hopefully this will enable me to move forward...

     

     


    Leha
    Saturday, June 11, 2011 6:20 AM
  • Ohhhh-kaaayyy...

    Got rid of the pesky log files, and now the system is only saving the log file of the day, instead of saving all the log files for all time. I can access the console, defrag'd the disk, and all is well with the server itself. Phwew!

    Was also able to get in and find the ports to forward, and figured out how to do that on my particular router, so ports are forwarding and I now have a web server. Yay!

     

    None of this would have been possible without the big clue Phil gave me about logging in with Remote Desktop, so if any of you future seekers are dealing with similar issues, take that tip!

     

    And thank you again, Phil, for your help and support!!


    Leha
    Saturday, June 11, 2011 4:46 PM
  • Excellent - most happy to help.
    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Saturday, June 11, 2011 5:13 PM