CRM 4.0 e-mail router error: 5.7.1 Client does not have permissions to send as this sender RRS feed

  • Question

  • Hey everyone...I'm working on configuring the outgoing (SMTP) profile in the e-mail router configuration and I'm having a problem.

    Just as background: I'm running CRM 4.0 with the latest update rollup installed. I have the CRM server and e-mail router installed on the same box. We are running Exchange 2007 (on a separate server). My outgoing profile is configured:

    • E-mail server type: SMTP
    • Authentication type: Windows Authentication
    • E-mail server: mail.companyname.com (use SSL = checked)
    • Access credentials: Other specified
    • User Name/password: A domain account that is configured as a CRM user (and has an Exchange mailbox)
    From the CRM web client, I can send an e-mail (to anyone) with no problems as long as it is sent "From:" the same user specified in the outgoing profile.  If I try to send from any other CRM user, the mail doesn't go through and the following is logged on the server:

    #61042 - An error occurred while processing the outgoing e-mail message with subject "Testing CRM:0001023" for SMTP: http://houcrm01/OrganizationName for delivery through mail.companyname.com. System.Net.Mail.SmtpException: Mailbox unavailable. The server response was: 5.7.1 Client does not have permissions to send as this sender
       at System.Net.Mail.MailCommand.CheckResponse(SmtpStatusCode statusCode, String response)
       at System.Net.Mail.MailCommand.Send(SmtpConnection conn, Byte[] command, String from)
       at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, SmtpFailedRecipientException& exception)
       at System.Net.Mail.SmtpClient.Send(MailMessage message)
       at Microsoft.Crm.Tools.Email.Providers.SmtpPollingSendEmailProvider.ProcessMessageInternal(email emailMessage)
       at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.ProcessMessage(email emailMessage)
       at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.Run()

    I've tried giving user specified in the outgoing profile permissions to "Send As" other users (in fact, I just gave it that permission for the entire CRM UserGroup in AD) with no effect.

    It seems like if it was an Exchange server connector problem, or a CRM or e-mail router configuration problem, or a firewall problem, etc. the I wouldn't be able to send mail AT ALL.

    Any other suggestions?  I'm stumped at this point...  Thanks in advance!

    Thursday, November 18, 2010 8:12 PM

All replies

  • I think the issue lies in the User Name / Password you are using for the Outgoing Profile.  Try using a Domain Admin account rather than the CRM user account.  See this post for more configuration details and see if that helps.

    Regards, Donna

    Thursday, November 18, 2010 8:48 PM
  • I'm sorry...I appreciate your suggestion, but I'm not going to use a domain admin account for this. That shouldn't be necessary, and I doubt that our IT/systems folks would even allow it.
    Thursday, November 18, 2010 8:59 PM
  • ok, I understand, I was suggesting that you try it to see if that resolves the issue.  If so, at least it points you in the right direction.  You may need to give the login more rights on the Exchange server so you can start with testing an Admin account to see if that works. You can also have a look at this article to see if it helps: http://msdn.microsoft.com/en-us/library/dd979455.aspx

    Regards, Donna

    Thursday, November 18, 2010 9:24 PM
  • Thanks for your help and the links!  I'll talk to our Exchange/AD gurus and see if that is an option for testing.  I just worry that it won't help isolate the problem -- domain admins can do everything, so if it does work, where do we go from there?
    Thursday, November 18, 2010 9:55 PM
  • This was the part of the article I wanted to bring your attention to.  Have your IT team look at the second bullet and set the priviledges for the user on the Outgoing Profile accordingly.  The user in the Outgoing Profile needs Full Access to the other mailboxes not just 'send on behalf'.

    Outgoing profiles support the following access credentials:

    • Local system account. This option requires a machine trust between the computer where the E-mail Router is running and the computer where the Exchange Server is running. The E-mail Router must be included in the PrivUserGroup. For more information, see the Microsoft Dynamics CRM Installing Guide. For outgoing profiles, this is the only option available if you select the Anonymous authentication type.
    • Other specified. This option enables the administrator to configure the E-mail Router to send e-mail messages on each user's behalf by using the access credentials of a specified user account that has full access to all the mailboxes that the outgoing profile will serve.

    Regards, Donna

    Friday, November 19, 2010 1:37 PM
  • OK, I had our Exchange guy try the second option and it still doesn't work.  

    Let me tell you exactly what we changed, and see if maybe we missed something: we have an AD account that we are using as the "other specified" user (company\CRMSvc).  We've pulled up a CRM user (company\JoeBlow) in the Exchange admin tool, went to "Manage Full Access Permission...", and added company\CRMSvc to the list.  We then tried to send mail from CRM with JoeBlow in the "from:" field, and still no luck.

    Thanks for your help...any other ideas would be appreciated.  I'm not totally opposed to the first idea (local system account with a machine trust), but I'd like to run this one out first.

    Tuesday, November 30, 2010 4:39 PM
  • Did you get a different error on the Exchange Server or CRM Server or was it the same error message?  Maybe you and your Exchange guy can have a read through this article and see if it helps:

     Microsoft Dynamics CRM 4.0 E-mail Router deployment guidelines

    Regards, Donna

    Tuesday, November 30, 2010 6:04 PM
  • Nope, same error ("client does not have permissions to send as this sender"), but I'll have a look at the article.

    By the way, your link was wrong...I think this is the page you were trying to point to:


    Tuesday, November 30, 2010 7:29 PM