none
D365 CFS with Azure IOT Hub - Command is sent from CRM but unable to receive message from cloud. RRS feed

  • Question

  • Created d365 instance with connected field service (CFS) deployed. i am just trying to achieve the out of the box functionalities within the application and see if it is syncing with Azure.

    I am able to register the device from CRM to Azure IoT hub. Next, was trying to send command instruction from CRM to Azure IoT hub. Though i can see the status of command as 'Sent' in CRM. i actually don't see the actual messages are received at the IoT hub.

    To monitor the messages at the IoT hub,

    -->created a console application to listen to the messages received at IoT hub, no luck.

    -->installed device explorer to monitor messages received for the particular device, no luck.

    Then i tried to send messages from simulator, able to receive and read the messages from IoT hub.

    i also tried to send messages from console app, able to receive and read the messages from IoT hub.

    When the command (message) is sent from ms crm application, unable to read from IoT hub. 

    any help would be appreciated, thanks.

    Wednesday, April 18, 2018 6:55 PM

All replies

  • Hello Bhuvaneswary,

    This issue is more related to Dynamics 365 for Field Service, so you can ask a question there for dedicated information.

    Best regards,

    Rita


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, April 19, 2018 2:13 AM
  • Thanks Rita, i have posted in all relevant forums :)
    Thursday, April 19, 2018 6:51 AM